diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-06 11:56:34 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 18:19:44 +0200 |
commit | 34bf6934ea3a51e6ed9cd71616501c9d1f5e52ee (patch) | |
tree | 44d6c762732917e50d43722776fde451c78dd9e7 | |
parent | 1496c6ba34bf95bce67504c72edace1bc2c0a64e (diff) | |
download | meta-qt5-34bf6934ea3a51e6ed9cd71616501c9d1f5e52ee.tar.gz |
qt3d, qtjsondb, qtlocation, qtsensors, qtsystems: bump SRCREV to latest
* WARN: because these modules weren't released yet, we need to make sure to
use SRCREV compatible with selected PV for other modules, old revisions
were compatible with 5.0.[01], I need to test these new SRCREVs to test
git versions
* tested with 5.0.2 and 5.0.2+git%
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qt3d.inc | 10 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtjsondb_git.bb | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtlocation_git.bb | 12 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsensors_git.bb | 12 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsystems_git.bb | 8 |
6 files changed, 18 insertions, 32 deletions
diff --git a/recipes-qt/qt5/qt3d.inc b/recipes-qt/qt5/qt3d.inc index 6034be5d..5ed2232e 100644 --- a/recipes-qt/qt5/qt3d.inc +++ b/recipes-qt/qt5/qt3d.inc | |||
@@ -2,11 +2,13 @@ require qt5.inc | |||
2 | 2 | ||
3 | DEPENDS += "qtdeclarative" | 3 | DEPENDS += "qtdeclarative" |
4 | 4 | ||
5 | LICENSE = "GFDL-1.3 & LGPL-2.1 & PREVIEW.COMMERCIAL" | 5 | LICENSE = "GFDL-1.3 & LGPL-2.1 & PREVIEW.COMMERCIAL | GPL-3.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4ac745f4b16b419fa48a24d41e983c40 \ | 6 | LIC_FILES_CHKSUM = "file://LICENSE.LGPL;md5=4193e7f1d47a858f6b7c0f1ee66161de \ |
7 | file://LGPL_EXCEPTION.txt;md5=eb6c371255e1262c55ae9b652a90b528 \ | 7 | file://LGPL_EXCEPTION.txt;md5=0145c4d1b6f96a661c2c139dfb268fb6 \ |
8 | file://LICENSE.PREVIEW.COMMERCIAL;md5=9d94dadfab8b246782ffea02082ee13a \ | 8 | file://LICENSE.PREVIEW.COMMERCIAL;md5=9d94dadfab8b246782ffea02082ee13a \ |
9 | file://LICENSE.FDL;md5=f70ee9a6c44ae8917586fea34dff0ab5" | 9 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ |
10 | file://LICENSE.GPL;md5=d32239bcb673463ab874e80d47fae504 \ | ||
11 | " | ||
10 | 12 | ||
11 | INC_PR = "r1" | 13 | INC_PR = "r1" |
12 | 14 | ||
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb index e9c89e66..87d009e7 100644 --- a/recipes-qt/qt5/qt3d_git.bb +++ b/recipes-qt/qt5/qt3d_git.bb | |||
@@ -8,4 +8,4 @@ PR = "${INC_PR}.0" | |||
8 | 8 | ||
9 | QT_MODULE_BRANCH = "master" | 9 | QT_MODULE_BRANCH = "master" |
10 | 10 | ||
11 | SRCREV = "d723769d90331f4cde8dcb5aa3973e5c6bad8753" | 11 | SRCREV = "0158ce783a61bac3e4f4ff619b0601daf9174ce6" |
diff --git a/recipes-qt/qt5/qtjsondb_git.bb b/recipes-qt/qt5/qtjsondb_git.bb index 09d97324..b9bb3e74 100644 --- a/recipes-qt/qt5/qtjsondb_git.bb +++ b/recipes-qt/qt5/qtjsondb_git.bb | |||
@@ -1,9 +1,11 @@ | |||
1 | require qt5-git.inc | 1 | require qt5-git.inc |
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | PR = "${INC_PR}.0" | ||
5 | |||
6 | # qtjsondb wasn't released yet, last tag before this SRCREV isn't even 5.0.0-beta1, but lets use it for now | 4 | # qtjsondb wasn't released yet, last tag before this SRCREV isn't even 5.0.0-beta1, but lets use it for now |
7 | PV = "4.999+5.0.0-beta1+git${SRCPV}" | 5 | PV = "4.999+5.0.0-beta1+git${SRCPV}" |
8 | 6 | ||
7 | PR = "${INC_PR}.0" | ||
8 | |||
9 | QT_MODULE_BRANCH = "master" | ||
10 | |||
9 | SRCREV = "c7c1e61bb5beddc3f4502548fd9ee498f1534e67" | 11 | SRCREV = "c7c1e61bb5beddc3f4502548fd9ee498f1534e67" |
diff --git a/recipes-qt/qt5/qtlocation_git.bb b/recipes-qt/qt5/qtlocation_git.bb index 8596022f..c7960411 100644 --- a/recipes-qt/qt5/qtlocation_git.bb +++ b/recipes-qt/qt5/qtlocation_git.bb | |||
@@ -1,16 +1,6 @@ | |||
1 | require qt5-git.inc | 1 | require qt5-git.inc |
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | # LICENSE files are missing in this old SRCREV, remove when upgraded | ||
5 | # commit 54e6103798bb098bc9e83aa77decdad4868cb98e | ||
6 | # Author: Timo Jyrinki <timo.jyrinki@canonical.com> | ||
7 | # Date: Mon Feb 11 08:19:48 2013 +0200 | ||
8 | # Subject: Add license files mandated by (L)GPL. | ||
9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780 \ | ||
10 | file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \ | ||
12 | " | ||
13 | |||
14 | # qtlocation wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 | 4 | # qtlocation wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 |
15 | PV = "4.999+5.0.0-beta1+git${SRCPV}" | 5 | PV = "4.999+5.0.0-beta1+git${SRCPV}" |
16 | 6 | ||
@@ -18,4 +8,4 @@ PR = "${INC_PR}.0" | |||
18 | 8 | ||
19 | QT_MODULE_BRANCH = "master" | 9 | QT_MODULE_BRANCH = "master" |
20 | 10 | ||
21 | SRCREV = "ac83b242c26d5b8750b6bf0f9ed0bac0e4569b6c" | 11 | SRCREV = "f28408346243cf090326f4738fd838219c21e00f" |
diff --git a/recipes-qt/qt5/qtsensors_git.bb b/recipes-qt/qt5/qtsensors_git.bb index 5561f943..7d3e7663 100644 --- a/recipes-qt/qt5/qtsensors_git.bb +++ b/recipes-qt/qt5/qtsensors_git.bb | |||
@@ -1,19 +1,9 @@ | |||
1 | require qt5-git.inc | 1 | require qt5-git.inc |
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | # LICENSE files are missing in this old SRCREV, remove when upgraded | ||
5 | # commit cf831b83142dee8114df3bc37c29116a66945f5f | ||
6 | # Author: Timo Jyrinki <timo.jyrinki@canonical.com> | ||
7 | # Date: Mon Feb 11 08:56:35 2013 +0200 | ||
8 | # Subject: Add license files mandated by (L)GPL. | ||
9 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/LGPL-2.1;md5=1a6d268fd218675ffea8be556788b780 \ | ||
10 | file://${COMMON_LICENSE_DIR}/GPL-3.0;md5=c79ff39f19dfec6d293b95dea7b07891 \ | ||
11 | file://${COMMON_LICENSE_DIR}/GFDL-1.3;md5=1083add59b39991c748ea70a92166959 \ | ||
12 | " | ||
13 | |||
14 | # qtsensors wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 | 4 | # qtsensors wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 |
15 | PV = "4.999+5.0.0-beta1+git${SRCPV}" | 5 | PV = "4.999+5.0.0-beta1+git${SRCPV}" |
16 | 6 | ||
17 | PR = "${INC_PR}.0" | 7 | PR = "${INC_PR}.0" |
18 | 8 | ||
19 | SRCREV = "6323be3e2fc1b69145f37cda1d0214ec5fa3cb44" | 9 | SRCREV = "a8bb2b1720372b79b1e7c03692252a3d6f0a7c0f" |
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb index e5de6d2b..d73a9996 100644 --- a/recipes-qt/qt5/qtsystems_git.bb +++ b/recipes-qt/qt5/qtsystems_git.bb | |||
@@ -1,9 +1,11 @@ | |||
1 | require qt5-git.inc | 1 | require qt5-git.inc |
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | PR = "${INC_PR}.0" | ||
5 | |||
6 | # qtsystems wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 | 4 | # qtsystems wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 |
7 | PV = "4.999+5.0.0-beta1+git${SRCPV}" | 5 | PV = "4.999+5.0.0-beta1+git${SRCPV}" |
8 | 6 | ||
9 | SRCREV = "2dbaae64ccd0fa3646d68d77cbc9baac7d3bde2e" | 7 | PR = "${INC_PR}.0" |
8 | |||
9 | QT_MODULE_BRANCH = "master" | ||
10 | |||
11 | SRCREV = "701442ad6358b9f27978aafae82074124468f88c" | ||