diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2019-03-01 12:12:11 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2019-03-07 23:54:05 +0000 |
commit | 6280befe6c4dbbc5ac8f384cda4480a1b896b1dd (patch) | |
tree | 7d3a16932aa9b6e6e138f6ac056866d13448795d | |
parent | 77ed8fb225093148583d4d119b89c26d4acc4ee5 (diff) | |
download | meta-qt5-6280befe6c4dbbc5ac8f384cda4480a1b896b1dd.tar.gz |
qtscript: add fix for build with gcc 8.3
* fixes issue introduced with gcc upgrade to 8.3:
| /OE/build/luneos-master/webos-ports/tmp-glibc/work/i586-webos-linux/qtscript/5.12.0+gitAUTOINC+0be84da600-r0/git/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:157:5: error: expected '(' before 'volatile'
| asm volatile (
| ^~~~~~~~
| (
| /OE/build/luneos-master/webos-ports/tmp-glibc/work/i586-webos-linux/qtscript/5.12.0+gitAUTOINC+0be84da600-r0/git/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp:158:1: error: expected unqualified-id before string constant
| ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n"
| ^~~~~~~~~
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtscript/0002-Fix-build-with-GCC-8.3.patch | 235 | ||||
-rw-r--r-- | recipes-qt/qt5/qtscript_git.bb | 3 |
2 files changed, 237 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtscript/0002-Fix-build-with-GCC-8.3.patch b/recipes-qt/qt5/qtscript/0002-Fix-build-with-GCC-8.3.patch new file mode 100644 index 00000000..629cf8e8 --- /dev/null +++ b/recipes-qt/qt5/qtscript/0002-Fix-build-with-GCC-8.3.patch | |||
@@ -0,0 +1,235 @@ | |||
1 | From 03cdaf779e0d8587c6e110f1f834a15e2d3317fd Mon Sep 17 00:00:00 2001 | ||
2 | From: Thiago Macieira <thiago.macieira@intel.com> | ||
3 | Date: Mon, 28 Jan 2019 14:33:12 -0800 | ||
4 | Subject: [PATCH] Fix build with GCC 8.3 | ||
5 | |||
6 | Qualifiers in the asm statement are not allowed in the global scope. I | ||
7 | thought they were necessary for LTO, but I the commit to this file that | ||
8 | added them predates my work on setting up LTO for GCC. | ||
9 | |||
10 | Change-Id: Id98140e1c2f0426cabbefffd157e23e5ece67a49 | ||
11 | Reviewed-by: Allan Sandfeld Jensen <allan.jensen@qt.io> | ||
12 | --- | ||
13 | .../JavaScriptCore/jit/JITStubs.cpp | 48 +++++++++---------- | ||
14 | 1 file changed, 24 insertions(+), 24 deletions(-) | ||
15 | |||
16 | diff --git a/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp b/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp | ||
17 | index 1abdf8b..9f60761 100644 | ||
18 | --- a/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp | ||
19 | +++ b/src/3rdparty/javascriptcore/JavaScriptCore/jit/JITStubs.cpp | ||
20 | @@ -116,7 +116,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedEBX) == 0x3c, JITStackFrame_s | ||
21 | COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x58, JITStackFrame_callFrame_offset_matches_ctiTrampoline); | ||
22 | COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x50, JITStackFrame_code_offset_matches_ctiTrampoline); | ||
23 | |||
24 | -asm volatile ( | ||
25 | +asm ( | ||
26 | ".text\n" | ||
27 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
28 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
29 | @@ -138,7 +138,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
30 | "ret" "\n" | ||
31 | ); | ||
32 | |||
33 | -asm volatile ( | ||
34 | +asm ( | ||
35 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
36 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
37 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
38 | @@ -154,7 +154,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
39 | "ret" "\n" | ||
40 | ); | ||
41 | |||
42 | -asm volatile ( | ||
43 | +asm ( | ||
44 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
45 | HIDE_SYMBOL(ctiOpThrowNotCaught) "\n" | ||
46 | SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
47 | @@ -179,7 +179,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, savedRBX) == 0x48, JITStackFrame_s | ||
48 | COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x90, JITStackFrame_callFrame_offset_matches_ctiTrampoline); | ||
49 | COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x80, JITStackFrame_code_offset_matches_ctiTrampoline); | ||
50 | |||
51 | -asm volatile ( | ||
52 | +asm ( | ||
53 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
54 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
55 | SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
56 | @@ -206,7 +206,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
57 | "ret" "\n" | ||
58 | ); | ||
59 | |||
60 | -asm volatile ( | ||
61 | +asm ( | ||
62 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
63 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
64 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
65 | @@ -222,7 +222,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
66 | "ret" "\n" | ||
67 | ); | ||
68 | |||
69 | -asm volatile ( | ||
70 | +asm ( | ||
71 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
72 | HIDE_SYMBOL(ctiOpThrowNotCaught) "\n" | ||
73 | SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
74 | @@ -242,7 +242,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
75 | #error "JIT_STUB_ARGUMENT_VA_LIST not supported on ARMv7." | ||
76 | #endif | ||
77 | |||
78 | -asm volatile ( | ||
79 | +asm ( | ||
80 | ".text" "\n" | ||
81 | ".align 2" "\n" | ||
82 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
83 | @@ -269,7 +269,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
84 | "bx lr" "\n" | ||
85 | ); | ||
86 | |||
87 | -asm volatile ( | ||
88 | +asm ( | ||
89 | ".text" "\n" | ||
90 | ".align 2" "\n" | ||
91 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
92 | @@ -287,7 +287,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
93 | "bx lr" "\n" | ||
94 | ); | ||
95 | |||
96 | -asm volatile ( | ||
97 | +asm ( | ||
98 | ".text" "\n" | ||
99 | ".align 2" "\n" | ||
100 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
101 | @@ -305,7 +305,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
102 | |||
103 | #elif COMPILER(GCC) && CPU(ARM_TRADITIONAL) | ||
104 | |||
105 | -asm volatile ( | ||
106 | +asm ( | ||
107 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
108 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
109 | SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
110 | @@ -323,7 +323,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
111 | "mov pc, lr" "\n" | ||
112 | ); | ||
113 | |||
114 | -asm volatile ( | ||
115 | +asm ( | ||
116 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
117 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
118 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
119 | @@ -418,7 +418,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x38, JITStackFrame_ | ||
120 | COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x30, JITStackFrame_code_offset_matches_ctiTrampoline); | ||
121 | COMPILE_ASSERT(offsetof(struct JITStackFrame, savedEBX) == 0x1c, JITStackFrame_stub_argument_space_matches_ctiTrampoline); | ||
122 | |||
123 | -asm volatile ( | ||
124 | +asm ( | ||
125 | ".text\n" | ||
126 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
127 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
128 | @@ -440,7 +440,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
129 | "ret" "\n" | ||
130 | ); | ||
131 | |||
132 | -asm volatile ( | ||
133 | +asm ( | ||
134 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
135 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
136 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
137 | @@ -456,7 +456,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
138 | "ret" "\n" | ||
139 | ); | ||
140 | |||
141 | -asm volatile ( | ||
142 | +asm ( | ||
143 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
144 | HIDE_SYMBOL(ctiOpThrowNotCaught) "\n" | ||
145 | SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
146 | @@ -480,7 +480,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, callFrame) == 0x58, JITStackFrame_ | ||
147 | COMPILE_ASSERT(offsetof(struct JITStackFrame, code) == 0x48, JITStackFrame_code_offset_matches_ctiTrampoline); | ||
148 | COMPILE_ASSERT(offsetof(struct JITStackFrame, savedRBX) == 0x78, JITStackFrame_stub_argument_space_matches_ctiTrampoline); | ||
149 | |||
150 | -asm volatile ( | ||
151 | +asm ( | ||
152 | ".text\n" | ||
153 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
154 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
155 | @@ -515,7 +515,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
156 | "ret" "\n" | ||
157 | ); | ||
158 | |||
159 | -asm volatile ( | ||
160 | +asm ( | ||
161 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
162 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
163 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
164 | @@ -531,7 +531,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
165 | "ret" "\n" | ||
166 | ); | ||
167 | |||
168 | -asm volatile ( | ||
169 | +asm ( | ||
170 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
171 | HIDE_SYMBOL(ctiOpThrowNotCaught) "\n" | ||
172 | SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
173 | @@ -551,7 +551,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
174 | #error "JIT_STUB_ARGUMENT_VA_LIST not supported on ARMv7." | ||
175 | #endif | ||
176 | |||
177 | -asm volatile ( | ||
178 | +asm ( | ||
179 | ".text" "\n" | ||
180 | ".align 2" "\n" | ||
181 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
182 | @@ -578,7 +578,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
183 | "bx lr" "\n" | ||
184 | ); | ||
185 | |||
186 | -asm volatile ( | ||
187 | +asm ( | ||
188 | ".text" "\n" | ||
189 | ".align 2" "\n" | ||
190 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
191 | @@ -596,7 +596,7 @@ SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
192 | "bx lr" "\n" | ||
193 | ); | ||
194 | |||
195 | -asm volatile ( | ||
196 | +asm ( | ||
197 | ".text" "\n" | ||
198 | ".align 2" "\n" | ||
199 | ".globl " SYMBOL_STRING(ctiOpThrowNotCaught) "\n" | ||
200 | @@ -614,7 +614,7 @@ SYMBOL_STRING(ctiOpThrowNotCaught) ":" "\n" | ||
201 | |||
202 | #elif COMPILER(GCC) && CPU(ARM_TRADITIONAL) | ||
203 | |||
204 | -asm volatile ( | ||
205 | +asm ( | ||
206 | ".text\n" | ||
207 | ".globl " SYMBOL_STRING(ctiTrampoline) "\n" | ||
208 | HIDE_SYMBOL(ctiTrampoline) "\n" | ||
209 | @@ -632,7 +632,7 @@ SYMBOL_STRING(ctiTrampoline) ":" "\n" | ||
210 | "mov pc, lr" "\n" | ||
211 | ); | ||
212 | |||
213 | -asm volatile ( | ||
214 | +asm ( | ||
215 | ".globl " SYMBOL_STRING(ctiVMThrowTrampoline) "\n" | ||
216 | HIDE_SYMBOL(ctiVMThrowTrampoline) "\n" | ||
217 | SYMBOL_STRING(ctiVMThrowTrampoline) ":" "\n" | ||
218 | @@ -1024,7 +1024,7 @@ static NEVER_INLINE void throwStackOverflowError(CallFrame* callFrame, JSGlobalD | ||
219 | extern "C" { \ | ||
220 | rtype JITStubThunked_##op(STUB_ARGS_DECLARATION); \ | ||
221 | }; \ | ||
222 | - asm volatile ( \ | ||
223 | + asm ( \ | ||
224 | ".text" "\n" \ | ||
225 | ".align 2" "\n" \ | ||
226 | ".globl " SYMBOL_STRING(cti_##op) "\n" \ | ||
227 | @@ -1053,7 +1053,7 @@ COMPILE_ASSERT(offsetof(struct JITStackFrame, thunkReturnAddress) == THUNK_RETUR | ||
228 | extern "C" { \ | ||
229 | rtype JITStubThunked_##op(STUB_ARGS_DECLARATION); \ | ||
230 | }; \ | ||
231 | - asm volatile ( \ | ||
232 | + asm ( \ | ||
233 | ".globl " SYMBOL_STRING(cti_##op) "\n" \ | ||
234 | HIDE_SYMBOL(cti_##op) "\n" \ | ||
235 | SYMBOL_STRING(cti_##op) ":" "\n" \ | ||
diff --git a/recipes-qt/qt5/qtscript_git.bb b/recipes-qt/qt5/qtscript_git.bb index ed2f82ec..a6b6429c 100644 --- a/recipes-qt/qt5/qtscript_git.bb +++ b/recipes-qt/qt5/qtscript_git.bb | |||
@@ -12,9 +12,10 @@ LIC_FILES_CHKSUM = " \ | |||
12 | " | 12 | " |
13 | 13 | ||
14 | # Patches from https://github.com/meta-qt5/qtscript/commits/b5.12 | 14 | # Patches from https://github.com/meta-qt5/qtscript/commits/b5.12 |
15 | # 5.12.meta-qt5.1 | 15 | # 5.12.meta-qt5.2 |
16 | SRC_URI += " \ | 16 | SRC_URI += " \ |
17 | file://0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch \ | 17 | file://0001-Include-asm-sgidefs.h-on-non-glibc-systems.patch \ |
18 | file://0002-Fix-build-with-GCC-8.3.patch \ | ||
18 | " | 19 | " |
19 | 20 | ||
20 | # qemuarm build fails with: | 21 | # qemuarm build fails with: |