summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-19 13:25:26 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-19 13:25:54 -0800
commit69e1fd33c18297b71035c88adbcf251c6f5bb4fe (patch)
treee37841809402205786b3abfbd053086d155ba8f2
parenta4db065bedf66509f5e6331c7a0f0a71b5ba87eb (diff)
downloadmeta-qt5-69e1fd33c18297b71035c88adbcf251c6f5bb4fe.tar.gz
quazip: Fix multilib builds
Fixes following errors when baselin != lib ERROR: quazip-0.7.3-r0 do_package: QA Issue: quazip: Files/directories were installed but not shipped in any package: /usr/lib/libquazip.so /usr/lib/libquazip.so.1 /usr/lib/libquazip.so.1.0 /usr/lib/libquazip.so.1.0.0 Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes-qt/quazip/quazip/0001-Append-LIB_ARCH-to-lib.patch31
-rw-r--r--recipes-qt/quazip/quazip_0.7.3.bb6
2 files changed, 35 insertions, 2 deletions
diff --git a/recipes-qt/quazip/quazip/0001-Append-LIB_ARCH-to-lib.patch b/recipes-qt/quazip/quazip/0001-Append-LIB_ARCH-to-lib.patch
new file mode 100644
index 00000000..ca281b75
--- /dev/null
+++ b/recipes-qt/quazip/quazip/0001-Append-LIB_ARCH-to-lib.patch
@@ -0,0 +1,31 @@
1From 7bcf47c1d9ca5eb27da088f93387e42b55d6999c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Thu, 19 Dec 2019 13:22:38 -0800
4Subject: [PATCH] Append LIB_ARCH to lib
5
6Creating subdir under lib is not expected in OE, instead it should be
7appending to lib so it becomes lib64 when needed and LIB_ARCH can be set
8in evnironment
9
10Upstream-Status: Pending
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 quazip/quazip.pro | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/quazip/quazip.pro b/quazip/quazip.pro
17index 3e10f36..1ea073e 100644
18--- a/quazip/quazip.pro
19+++ b/quazip/quazip.pro
20@@ -42,7 +42,7 @@ CONFIG(debug, debug|release) {
21 unix:!symbian {
22 headers.path=$$PREFIX/include/quazip
23 headers.files=$$HEADERS
24- target.path=$$PREFIX/lib/$${LIB_ARCH}
25+ target.path=$$PREFIX/lib$${LIB_ARCH}
26 INSTALLS += headers target
27
28 OBJECTS_DIR=.obj
29--
302.24.1
31
diff --git a/recipes-qt/quazip/quazip_0.7.3.bb b/recipes-qt/quazip/quazip_0.7.3.bb
index 970204e5..b483ced8 100644
--- a/recipes-qt/quazip/quazip_0.7.3.bb
+++ b/recipes-qt/quazip/quazip_0.7.3.bb
@@ -5,11 +5,13 @@ LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=910d778aab53617cbaf13c4e1810e289" 5LIC_FILES_CHKSUM = "file://COPYING;md5=910d778aab53617cbaf13c4e1810e289"
6DEPENDS = "qtbase" 6DEPENDS = "qtbase"
7 7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz" 8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
9 file://0001-Append-LIB_ARCH-to-lib.patch \
10 "
9SRC_URI[md5sum] = "2ba7dd8b1d6dd588374c9fab5c46e76e" 11SRC_URI[md5sum] = "2ba7dd8b1d6dd588374c9fab5c46e76e"
10SRC_URI[sha256sum] = "2ad4f354746e8260d46036cde1496c223ec79765041ea28eb920ced015e269b5" 12SRC_URI[sha256sum] = "2ad4f354746e8260d46036cde1496c223ec79765041ea28eb920ced015e269b5"
11 13
12inherit qmake5 14inherit qmake5
13 15
14EXTRA_QMAKEVARS_PRE += "PREFIX=${prefix}" 16EXTRA_QMAKEVARS_PRE += "PREFIX=${prefix} LIB_ARCH=${@d.getVar('baselib').replace('lib', '')}"
15EXTRA_QMAKEVARS_POST += "SUBDIRS=${BPN}" 17EXTRA_QMAKEVARS_POST += "SUBDIRS=${BPN}"