diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-12-14 18:43:34 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-12-14 19:35:57 -0800 |
commit | 710d995b54d80f8670aad621712e92eda0eb47fd (patch) | |
tree | b2a4c9fee9a7a56744e0541002fd1e2982f4d4cf | |
parent | a02e01ca689e007db16795cde8e67d7031661425 (diff) | |
download | meta-qt5-710d995b54d80f8670aad621712e92eda0eb47fd.tar.gz |
qttools: Add option to disable qdoc
qdoc needs clang on build host, therefore add an option so it can
disabled when clang is not part of build system, it can also peek into
build host and if there is a version of clang installed it will
configure for it but then conflict with gcc during compilation
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qttools/0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch | 28 | ||||
-rw-r--r-- | recipes-qt/qt5/qttools_git.bb | 8 |
2 files changed, 35 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qttools/0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch b/recipes-qt/qt5/qttools/0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch new file mode 100644 index 00000000..55c6e22a --- /dev/null +++ b/recipes-qt/qt5/qttools/0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 623675e07231f62cdc7600dca5897a9fc70e0467 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 14 Dec 2019 18:36:49 -0800 | ||
4 | Subject: [PATCH] src.pro: Add option noqdoc to disable qdoc builds | ||
5 | |||
6 | it needs clang on host, so lets separate it out | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | --- | ||
10 | src/src.pro | 2 +- | ||
11 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
12 | |||
13 | diff --git a/src/src.pro b/src/src.pro | ||
14 | index 5c256ea3..196c34c7 100644 | ||
15 | --- a/src/src.pro | ||
16 | +++ b/src/src.pro | ||
17 | @@ -25,7 +25,7 @@ qtConfig(library) { | ||
18 | |||
19 | include($$OUT_PWD/qdoc/qtqdoc-config.pri) | ||
20 | QT_FOR_CONFIG += qdoc-private | ||
21 | -qtConfig(qdoc): qtConfig(thread): SUBDIRS += qdoc | ||
22 | +qtConfig(qdoc): qtConfig(thread):!contains(CONFIG, noqdoc): SUBDIRS += qdoc | ||
23 | |||
24 | !android|android_app: SUBDIRS += qtpaths | ||
25 | |||
26 | -- | ||
27 | 2.24.1 | ||
28 | |||
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb index b766680a..e9352e5b 100644 --- a/recipes-qt/qt5/qttools_git.bb +++ b/recipes-qt/qt5/qttools_git.bb | |||
@@ -18,6 +18,7 @@ DEPENDS += "qtbase qtdeclarative qtxmlpatterns" | |||
18 | SRC_URI += " \ | 18 | SRC_URI += " \ |
19 | file://0001-add-noqtwebkit-configuration.patch \ | 19 | file://0001-add-noqtwebkit-configuration.patch \ |
20 | file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \ | 20 | file://0002-linguist-tools-cmake-allow-overriding-the-location-f.patch \ |
21 | file://0003-src.pro-Add-option-noqdoc-to-disable-qdoc-builds.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks" | 24 | FILES_${PN}-tools += "${datadir}${QT_DIR_NAME}/phrasebooks" |
@@ -34,9 +35,14 @@ COMPATIBLE_HOST_toolchain-clang_riscv64 = "null" | |||
34 | 35 | ||
35 | export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config" | 36 | export YOCTO_ALTERNATE_EXE_PATH = "${STAGING_BINDIR}/llvm-config" |
36 | 37 | ||
38 | TOOLSTOBUILD += "linguist/lconvert linguist/lrelease linguist/lupdate pixeltool qtdiag qtpaths qtplugininfo" | ||
39 | TOOLSTOBUILD += "${@bb.utils.contains('PACKAGECONFIG', 'clang', 'qdoc', '', d)}" | ||
40 | TOOLSFORTARGET = "pixeltool qtdiag qtpaths qtplugininfo" | ||
41 | TOOLSFORHOST = "linguist ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'qdoc', '', d)}" | ||
42 | |||
37 | EXTRA_QMAKEVARS_PRE += " \ | 43 | EXTRA_QMAKEVARS_PRE += " \ |
38 | ${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \ | 44 | ${@bb.utils.contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)} \ |
39 | CONFIG+=disable_external_rpath \ | 45 | ${@bb.utils.contains('PACKAGECONFIG', 'clang', 'CONFIG+=disable_external_rpath', 'CONFIG+=noqdoc', d)} \ |
40 | " | 46 | " |
41 | EXTRA_QMAKEVARS_PRE_append_class-native = " CONFIG+=config_clang_done CONFIG-=config_clang" | 47 | EXTRA_QMAKEVARS_PRE_append_class-native = " CONFIG+=config_clang_done CONFIG-=config_clang" |
42 | EXTRA_QMAKEVARS_PRE_append_class-nativesdk = " CONFIG+=config_clang_done CONFIG-=config_clang" | 48 | EXTRA_QMAKEVARS_PRE_append_class-nativesdk = " CONFIG+=config_clang_done CONFIG-=config_clang" |