diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2018-02-22 14:50:03 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2018-04-06 12:44:47 +0000 |
commit | 9ed1897bf7520db9fa93e8aa3508994472804569 (patch) | |
tree | 8bca0963b9d120c43b4a793b1cc5f8f3fffb3c35 | |
parent | f69baf2a72b224fafad89a1422b692fb95ec439b (diff) | |
download | meta-qt5-9ed1897bf7520db9fa93e8aa3508994472804569.tar.gz |
qt5-git.inc: drop nobranch=1
* sneaked in with:
commit 333949a8239dfa7788b35f1059614733e11a6a25
Author: Samuli Piippo <samuli.piippo@qt.io>
Date: Thu Jan 26 16:54:50 2017 +0200
Upgrade to Qt 5.8
* use 5.10.1 branch by defaut and fix QT_MODULE_BRANCH
in qtknx, qtmqtt, qtwebkit-examples, qtwebkit which don't
have 5.10.1 branch at all
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qt5-git.inc | 6 | ||||
-rw-r--r-- | recipes-qt/qt5/qtknx_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtmqtt_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit-examples_git.bb | 2 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 2 |
5 files changed, 11 insertions, 3 deletions
diff --git a/recipes-qt/qt5/qt5-git.inc b/recipes-qt/qt5/qt5-git.inc index 7ee06438..beba9135 100644 --- a/recipes-qt/qt5/qt5-git.inc +++ b/recipes-qt/qt5/qt5-git.inc | |||
@@ -1,9 +1,9 @@ | |||
1 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. | 1 | # Copyright (C) 2012-2016 O.S. Systems Software LTDA. |
2 | # Copyright (C) 2013-2017 Martin Jansa <martin.jansa@gmail.com> | 2 | # Copyright (C) 2013-2018 Martin Jansa <martin.jansa@gmail.com> |
3 | 3 | ||
4 | QT_MODULE ?= "${BPN}" | 4 | QT_MODULE ?= "${BPN}" |
5 | QT_MODULE_BRANCH ?= "5.10" | 5 | QT_MODULE_BRANCH ?= "5.10.1" |
6 | QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH};nobranch=1" | 6 | QT_MODULE_BRANCH_PARAM ?= "branch=${QT_MODULE_BRANCH}" |
7 | 7 | ||
8 | # each module needs to define valid SRCREV | 8 | # each module needs to define valid SRCREV |
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
diff --git a/recipes-qt/qt5/qtknx_git.bb b/recipes-qt/qt5/qtknx_git.bb index 5e01e3c9..fa981abb 100644 --- a/recipes-qt/qt5/qtknx_git.bb +++ b/recipes-qt/qt5/qtknx_git.bb | |||
@@ -9,4 +9,6 @@ LIC_FILES_CHKSUM = " \ | |||
9 | 9 | ||
10 | DEPENDS += "qtbase" | 10 | DEPENDS += "qtbase" |
11 | 11 | ||
12 | QT_MODULE_BRANCH = "5.10" | ||
13 | |||
12 | SRCREV = "29c34e8f072afd01002ed3847d752b4e065f977e" | 14 | SRCREV = "29c34e8f072afd01002ed3847d752b4e065f977e" |
diff --git a/recipes-qt/qt5/qtmqtt_git.bb b/recipes-qt/qt5/qtmqtt_git.bb index b705f7c4..90c255d7 100644 --- a/recipes-qt/qt5/qtmqtt_git.bb +++ b/recipes-qt/qt5/qtmqtt_git.bb | |||
@@ -9,4 +9,6 @@ LIC_FILES_CHKSUM = " \ | |||
9 | 9 | ||
10 | DEPENDS += "qtbase" | 10 | DEPENDS += "qtbase" |
11 | 11 | ||
12 | QT_MODULE_BRANCH = "5.10" | ||
13 | |||
12 | SRCREV = "2c3c2a41c55a179332ec2a076856990f36dd5ef9" | 14 | SRCREV = "2c3c2a41c55a179332ec2a076856990f36dd5ef9" |
diff --git a/recipes-qt/qt5/qtwebkit-examples_git.bb b/recipes-qt/qt5/qtwebkit-examples_git.bb index 3e3e4a0b..114fab7a 100644 --- a/recipes-qt/qt5/qtwebkit-examples_git.bb +++ b/recipes-qt/qt5/qtwebkit-examples_git.bb | |||
@@ -17,4 +17,6 @@ DEPENDS += "qtwebkit qtxmlpatterns" | |||
17 | RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins" | 17 | RDEPENDS_${PN}-examples += "qtwebkit-qmlplugins" |
18 | RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}" | 18 | RDEPENDS_${PN}-examples += "${@bb.utils.contains('PACKAGECONFIG_OPENSSL', 'openssl', 'ca-certificates', '', d)}" |
19 | 19 | ||
20 | QT_MODULE_BRANCH = "5.9" | ||
21 | |||
20 | SRCREV = "a24c780b60d7d8bc00c4a48042cf7f32db777d55" | 22 | SRCREV = "a24c780b60d7d8bc00c4a48042cf7f32db777d55" |
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index 5dee6a42..b23d4d6f 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -87,4 +87,6 @@ PACKAGES_remove = "${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-db | |||
87 | RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }" | 87 | RUBY_SYS = "${@ '${BUILD_SYS}'.replace('i486', 'i386').replace('i586', 'i386').replace('i686', 'i386') }" |
88 | export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}" | 88 | export RUBYLIB="${STAGING_DATADIR_NATIVE}/rubygems:${STAGING_LIBDIR_NATIVE}/ruby:${STAGING_LIBDIR_NATIVE}/ruby/${RUBY_SYS}" |
89 | 89 | ||
90 | QT_MODULE_BRANCH = "5.9" | ||
91 | |||
90 | SRCREV = "97c4a80a1282c8c3eaa343011286b76fd4838c5f" | 92 | SRCREV = "97c4a80a1282c8c3eaa343011286b76fd4838c5f" |