diff options
author | Khem Raj <raj.khem@gmail.com> | 2020-10-31 13:09:04 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2020-11-03 17:01:57 +0100 |
commit | a72c04ee797ca70d73784e6bc2fb0701b3ff8a7c (patch) | |
tree | 6ca997163a58f695db1b1da831238d683dacaff1 | |
parent | 1d946dc8f467a37494d3d96a1fa8153199288aff (diff) | |
download | meta-qt5-a72c04ee797ca70d73784e6bc2fb0701b3ff8a7c.tar.gz |
qtwebkit: Fix build with python 3.9
backport a fix to build with python 3.9
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch | 32 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 1 |
2 files changed, 33 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch b/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch new file mode 100644 index 00000000..4eef3451 --- /dev/null +++ b/recipes-qt/qt5/qtwebkit/0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch | |||
@@ -0,0 +1,32 @@ | |||
1 | From df9f6a8c9d59996b52bfdc5ea6f780de517905e5 Mon Sep 17 00:00:00 2001 | ||
2 | From: Konstantin Tokarev <annulen@yandex.ru> | ||
3 | Date: Wed, 3 Jun 2020 15:01:42 +0300 | ||
4 | Subject: [PATCH] Fix compilation with Python 3.9: avoid passing encoding to | ||
5 | json.load() | ||
6 | |||
7 | In Python 2.7 UTF-8 is assumed by default, while in Python 3 this argument | ||
8 | is not supported. | ||
9 | |||
10 | Upstream-Status: Backport [https://github.com/qtwebkit/qtwebkit/commit/78360c01c796b6260bf828bc9c8a0ef73c5132fd] | ||
11 | Change-Id: Ic459d60a6b20bc1838d8771bc36ac41614fe61a9 | ||
12 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
13 | --- | ||
14 | Source/JavaScriptCore/generate-bytecode-files | 2 +- | ||
15 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
16 | |||
17 | diff --git a/Source/JavaScriptCore/generate-bytecode-files b/Source/JavaScriptCore/generate-bytecode-files | ||
18 | index c5dab429c..af3431275 100644 | ||
19 | --- a/Source/JavaScriptCore/generate-bytecode-files | ||
20 | +++ b/Source/JavaScriptCore/generate-bytecode-files | ||
21 | @@ -163,7 +163,7 @@ if __name__ == "__main__": | ||
22 | initBytecodesFile = openOrExit(initASMFileName, "w") | ||
23 | |||
24 | try: | ||
25 | - bytecodeSections = json.load(bytecodeFile, encoding = "utf-8") | ||
26 | + bytecodeSections = json.load(bytecodeFile) | ||
27 | except: | ||
28 | print("Unexpected error parsing {0}: {1}".format(bytecodeJSONFile, sys.exc_info())) | ||
29 | |||
30 | -- | ||
31 | 2.29.2 | ||
32 | |||
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index ce7d1b85..9ce948e0 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -18,6 +18,7 @@ SRC_URI += "\ | |||
18 | file://0005-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \ | 18 | file://0005-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \ |
19 | file://0006-Fix-build-with-bison37.patch \ | 19 | file://0006-Fix-build-with-bison37.patch \ |
20 | file://0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \ | 20 | file://0007-Disable-code-related-to-HTTP-2-when-Qt-is-configured.patch \ |
21 | file://0008-Fix-compilation-with-Python-3.9-avoid-passing-encodi.patch \ | ||
21 | " | 22 | " |
22 | 23 | ||
23 | inherit cmake_qt5 perlnative | 24 | inherit cmake_qt5 perlnative |