diff options
author | Samuli Piippo <samuli.piippo@qt.io> | 2018-07-02 09:53:22 +0300 |
---|---|---|
committer | Otavio Salvador <otavio@ossystems.com.br> | 2018-07-03 15:47:03 -0300 |
commit | c3cc11bc289363203da533e477d4f58a64a79db2 (patch) | |
tree | 86dd74dfd72a205f92906f9e521f67adc5f4e9a7 | |
parent | 7faa5d8f39381975a861e3e918789e9f33a079f6 (diff) | |
download | meta-qt5-c3cc11bc289363203da533e477d4f58a64a79db2.tar.gz |
qtbase: add PACKAGECONFIG for Link Time Optimization
qtbase configure option -ltcg enables Link Time Code Generation
using GCC's LTO feature. Enable it by default if the selected
optimization is for size.
Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 3 |
1 files changed, 2 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index 800239ad..bf05cf81 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -69,7 +69,7 @@ PACKAGECONFIG_RELEASE ?= "release" | |||
69 | # This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency | 69 | # This is in qt5.inc, because qtwebkit-examples are using it to enable ca-certificates dependency |
70 | # PACKAGECONFIG_OPENSSL ?= "openssl" | 70 | # PACKAGECONFIG_OPENSSL ?= "openssl" |
71 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \ | 71 | PACKAGECONFIG_DEFAULT ?= "dbus udev evdev widgets tools libs freetype tests \ |
72 | ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size', '', d)} \ | 72 | ${@bb.utils.contains('SELECTED_OPTIMIZATION', '-Os', 'optimize-size ltcg', '', d)} \ |
73 | " | 73 | " |
74 | 74 | ||
75 | PACKAGECONFIG ?= " \ | 75 | PACKAGECONFIG ?= " \ |
@@ -88,6 +88,7 @@ PACKAGECONFIG[release] = "-release,-debug" | |||
88 | PACKAGECONFIG[debug] = "" | 88 | PACKAGECONFIG[debug] = "" |
89 | PACKAGECONFIG[developer] = "-developer-build" | 89 | PACKAGECONFIG[developer] = "-developer-build" |
90 | PACKAGECONFIG[optimize-size] = "-optimize-size" | 90 | PACKAGECONFIG[optimize-size] = "-optimize-size" |
91 | PACKAGECONFIG[ltcg] = "-ltcg" | ||
91 | PACKAGECONFIG[sm] = "-sm,-no-sm" | 92 | PACKAGECONFIG[sm] = "-sm,-no-sm" |
92 | PACKAGECONFIG[tests] = "-make tests,-nomake tests" | 93 | PACKAGECONFIG[tests] = "-make tests,-nomake tests" |
93 | PACKAGECONFIG[examples] = "-make examples -compile-examples,-nomake examples" | 94 | PACKAGECONFIG[examples] = "-make examples -compile-examples,-nomake examples" |