diff options
author | Javier Viguera <javier.viguera@digi.com> | 2016-01-04 16:59:54 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-01-14 11:14:01 +0100 |
commit | c7cd9cb4661dd1623368d39e66c716f2222d357b (patch) | |
tree | b1776fd56124dd2372519a16a25b392f33323306 | |
parent | 511a3764506ce6bbdc5e9441a8f4e9d862ea1102 (diff) | |
download | meta-qt5-c7cd9cb4661dd1623368d39e66c716f2222d357b.tar.gz |
qtconnectivity, qtsystems: fix bluetooth support
QMAKE_CACHE_EVAL is only used in qtwebengine and qtwebkit, but not in
the rest of the QT5 packages, so use EXTRA_QMAKEVARS_PRE to pass the
packageconfig options to the do_configure task.
Also generalize bluetooth support so it can be used not only with bluez4
but with bluez5 as well.
Signed-off-by: Javier Viguera <javier.viguera@digi.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtconnectivity_git.bb | 9 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsystems_git.bb | 9 |
2 files changed, 12 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb index b1e155e2..f677f710 100644 --- a/recipes-qt/qt5/qtconnectivity_git.bb +++ b/recipes-qt/qt5/qtconnectivity_git.bb | |||
@@ -13,11 +13,14 @@ LIC_FILES_CHKSUM = " \ | |||
13 | 13 | ||
14 | DEPENDS += "qtbase qtdeclarative" | 14 | DEPENDS += "qtbase qtdeclarative" |
15 | 15 | ||
16 | PACKAGECONFIG ??= "" | 16 | inherit bluetooth |
17 | PACKAGECONFIG[bluez4] = "OE_BLUEZ_ENABLED,,bluez4" | 17 | |
18 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" | ||
19 | PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}" | ||
20 | |||
21 | EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}" | ||
18 | 22 | ||
19 | do_configure_prepend() { | 23 | do_configure_prepend() { |
20 | export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}" | ||
21 | # disable bluez test if it isn't enabled by PACKAGECONFIG | 24 | # disable bluez test if it isn't enabled by PACKAGECONFIG |
22 | sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro | 25 | sed -i 's/^qtCompileTest(bluez)/OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtconnectivity.pro |
23 | } | 26 | } |
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb index 27d2bff3..9d9d245d 100644 --- a/recipes-qt/qt5/qtsystems_git.bb +++ b/recipes-qt/qt5/qtsystems_git.bb | |||
@@ -11,11 +11,14 @@ LIC_FILES_CHKSUM = " \ | |||
11 | 11 | ||
12 | DEPENDS += "qtbase qtdeclarative udev gconf" | 12 | DEPENDS += "qtbase qtdeclarative udev gconf" |
13 | 13 | ||
14 | PACKAGECONFIG ??= "" | 14 | inherit bluetooth |
15 | PACKAGECONFIG[bluez4] = "OE_BLUEZ_ENABLED,,bluez4" | 15 | |
16 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" | ||
17 | PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}" | ||
18 | |||
19 | EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}" | ||
16 | 20 | ||
17 | do_configure_prepend() { | 21 | do_configure_prepend() { |
18 | export QMAKE_CACHE_EVAL="CONFIG+=${EXTRA_OECONF}" | ||
19 | # disable bluez test if it isn't enabled by PACKAGECONFIG | 22 | # disable bluez test if it isn't enabled by PACKAGECONFIG |
20 | sed -i 's/^ qtCompileTest(bluez)/ OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtsystems.pro | 23 | sed -i 's/^ qtCompileTest(bluez)/ OE_BLUEZ_ENABLED:qtCompileTest(bluez)/g' ${S}/qtsystems.pro |
21 | } | 24 | } |