diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-07-12 11:58:19 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2019-07-15 13:58:33 +0000 |
commit | c978dd1cf10f4391919e6760eb6691dd1a7034b6 (patch) | |
tree | c5f433241b66de6d2f8a6d8d7caccafabc7d0ebd | |
parent | 5d6ea2efcb9d751e631b86a066ab7c59ca91ac41 (diff) | |
download | meta-qt5-c978dd1cf10f4391919e6760eb6691dd1a7034b6.tar.gz |
qtconnectivity,qtsystems: Account for bluez4 from oe-core
bluez4 has been deprecated for few years now it has been removed
completely from oe-core
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | recipes-qt/qt5/qtconnectivity_git.bb | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qtsystems_git.bb | 4 |
2 files changed, 2 insertions, 6 deletions
diff --git a/recipes-qt/qt5/qtconnectivity_git.bb b/recipes-qt/qt5/qtconnectivity_git.bb index 414ce334..00c161d3 100644 --- a/recipes-qt/qt5/qtconnectivity_git.bb +++ b/recipes-qt/qt5/qtconnectivity_git.bb | |||
@@ -14,10 +14,8 @@ SRC_URI += "file://0001-Add-missing-header-for-errno.patch" | |||
14 | 14 | ||
15 | DEPENDS += "qtbase qtdeclarative" | 15 | DEPENDS += "qtbase qtdeclarative" |
16 | 16 | ||
17 | inherit bluetooth | ||
18 | |||
19 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" | 17 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" |
20 | PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,${BLUEZ}" | 18 | PACKAGECONFIG[bluez] = "-feature-bluez,-no-feature-bluez,bluez5" |
21 | 19 | ||
22 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" | 20 | EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" |
23 | 21 | ||
diff --git a/recipes-qt/qt5/qtsystems_git.bb b/recipes-qt/qt5/qtsystems_git.bb index 05741de7..5f5e1ad8 100644 --- a/recipes-qt/qt5/qtsystems_git.bb +++ b/recipes-qt/qt5/qtsystems_git.bb | |||
@@ -12,10 +12,8 @@ LIC_FILES_CHKSUM = " \ | |||
12 | 12 | ||
13 | DEPENDS += "qtbase qtdeclarative udev gconf" | 13 | DEPENDS += "qtbase qtdeclarative udev gconf" |
14 | 14 | ||
15 | inherit bluetooth | ||
16 | |||
17 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" | 15 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)}" |
18 | PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,${BLUEZ}" | 16 | PACKAGECONFIG[bluez] = "CONFIG+=OE_BLUEZ_ENABLED,,bluez5" |
19 | 17 | ||
20 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" | 18 | EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" |
21 | 19 | ||