summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:48:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 15:25:25 +0200
commitf8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch)
tree2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
parentf52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff)
downloadmeta-qt5-f8b065ea1174dd1fa7d93359f6826bfc9d23174c.tar.gz
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of changes in .inc files and we have only one version of modules without release (only one _git.bb) and it's impossible to find SRCREV which would be compatible with all 4 versions. * 0005-AddSynchoronization-qimagereader.patch was already backported to 5.0.2 in upstream * 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was already applied in 5.0.2 * 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in qt5-versions.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch221
1 files changed, 0 insertions, 221 deletions
diff --git a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch b/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
deleted file mode 100644
index 8c100bc5..00000000
--- a/recipes-qt/qt5/qtbase/0003-Add-external-hostbindir-option.patch
+++ /dev/null
@@ -1,221 +0,0 @@
1From 3b0a595bbe9d5bce898fc5a84c9bb39c976b9f7d Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 6 Apr 2013 13:15:07 +0200
4Subject: [PATCH 03/12] Add -external-hostbindir option
5
6* when cross-compiling it's sometimes useful to use existing tools from machine
7 (or in OpenEmbedded built with separate native recipe) when building for target
8
9* this way we can skip bootstraping tools we already have
10
11Upstream-Status: Pending
12
13Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
14---
15 configure | 15 ++++++++++++++-
16 mkspecs/features/qt_functions.prf | 5 ++++-
17 mkspecs/features/qt_tool.prf | 2 +-
18 qmake/property.cpp | 1 +
19 qtbase.pro | 15 +++++++++++----
20 src/corelib/global/qlibraryinfo.cpp | 3 ++-
21 src/corelib/global/qlibraryinfo.h | 1 +
22 tools/configure/configureapp.cpp | 8 ++++++++
23 8 files changed, 42 insertions(+), 8 deletions(-)
24
25diff --git a/configure b/configure
26index 0ab8eee..50f1ef2 100755
27--- a/configure
28+++ b/configure
29@@ -928,6 +928,7 @@ CFG_GCC_SYSROOT="yes"
30 QT_HOST_PREFIX=
31 QT_HOST_BINS=
32 QT_HOST_DATA=
33+QT_EXTERNAL_HOST_BINS=
34
35 #flags for SQL drivers
36 QT_CFLAGS_PSQL=
37@@ -1026,7 +1027,7 @@ while [ "$#" -gt 0 ]; do
38 VAL=no
39 ;;
40 #Qt style options that pass an argument
41- -prefix|-docdir|-headerdir|-plugindir|-importdir|-qmldir|-archdatadir|-datadir|-libdir|-bindir|-libexecdir|-translationdir|-sysconfdir|-examplesdir|-testsdir|-depths|-make|-nomake|-platform|-xplatform|-device|-device-option|-sdk|-arch|-host-arch|-mysql_config|-sysroot|-hostdatadir|-hostbindir|-qpa|-qconfig)
42+ -prefix|-docdir|-headerdir|-plugindir|-importdir|-qmldir|-archdatadir|-datadir|-libdir|-bindir|-libexecdir|-translationdir|-sysconfdir|-examplesdir|-testsdir|-depths|-make|-nomake|-platform|-xplatform|-device|-device-option|-sdk|-arch|-host-arch|-mysql_config|-sysroot|-hostdatadir|-hostbindir|-qpa|-qconfig|-external-hostbindir)
43 VAR=`echo $1 | sed "s,^-\(.*\),\1,"`
44 shift
45 VAL="$1"
46@@ -1223,6 +1224,9 @@ while [ "$#" -gt 0 ]; do
47 hostbindir)
48 QT_HOST_BINS="$VAL"
49 ;;
50+ external-hostbindir)
51+ QT_EXTERNAL_HOST_BINS="$VAL"
52+ ;;
53 pkg-config)
54 if [ "$VAL" = "yes" ] || [ "$VAL" = "no" ]; then
55 CFG_PKGCONFIG="$VAL"
56@@ -2921,6 +2925,11 @@ else
57 QT_HOST_DATA=`"$relpath/config.tests/unix/makeabs" "$QT_HOST_DATA"`
58 fi
59
60+# default is empty, don't call makeabs if it is empty
61+if [ ! -z "$QT_EXTERNAL_HOST_BINS" ]; then
62+ QT_EXTERNAL_HOST_BINS=`"$relpath/config.tests/unix/makeabs" "$QT_EXTERNAL_HOST_BINS"`
63+fi
64+
65 #-------------------------------------------------------------------------------
66 # help - interactive parts of the script _after_ this section please
67 #-------------------------------------------------------------------------------
68@@ -3087,6 +3096,9 @@ Installation options:
69 -hostdatadir <dir> . Data used by qmake will be installed to <dir>
70 (default HOSTPREFIX)
71
72+ -external-hostbindir <dir> Use external host executables instead of building them
73+ (not used by defaut)
74+
75 Configure options:
76
77 The defaults (*) are usually acceptable. A plus (+) denotes a default value
78@@ -3558,6 +3570,7 @@ static const char qt_configure_prefix_path_strs[][256 + 12] = {
79 "qt_hpfxpath=$QT_HOST_PREFIX",
80 "qt_hbinpath=$QT_HOST_BINS",
81 "qt_hdatpath=$QT_HOST_DATA",
82+ "qt_ebinpath=$QT_EXTERNAL_HOST_BINS",
83 "qt_targspec=$shortxspec",
84 "qt_hostspec=$shortspec",
85 #endif
86diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf
87index 389f241..e249960 100644
88--- a/mkspecs/features/qt_functions.prf
89+++ b/mkspecs/features/qt_functions.prf
90@@ -194,7 +194,10 @@ defineTest(qtAddModules) {
91 defineTest(qtPrepareTool) {
92 $$1 = $$eval(QT_TOOL.$${2}.command)
93 isEmpty($$1) {
94- $$1 = $$[QT_HOST_BINS/get]/$$2
95+ $$1 = $$[QT_EXTERNAL_HOST_BINS]/$$2
96+ isEmpty($$[QT_EXTERNAL_HOST_BINS]) {
97+ $$1 = $$[QT_HOST_BINS/get]/$$2
98+ }
99 contains(QMAKE_HOST.os, Windows):!contains($$1, .*\\.(exe|bat)$) {
100 exists($$eval($$1).bat) {
101 $$1 = $$eval($$1).bat
102diff --git a/mkspecs/features/qt_tool.prf b/mkspecs/features/qt_tool.prf
103index 16db6c7..5518933 100644
104--- a/mkspecs/features/qt_tool.prf
105+++ b/mkspecs/features/qt_tool.prf
106@@ -31,7 +31,7 @@ load(qt_targets)
107
108 # If we are doing a prefix build, create a "module" pri which enables
109 # qtPrepareTool() to work with the non-installed build.
110-!build_pass:!exists($$[QT_INSTALL_PREFIX]/.qmake.cache) {
111+!build_pass:!exists($$[QT_INSTALL_PREFIX]/.qmake.cache):isEmpty($$[QT_EXTERNAL_HOST_BINS]) {
112
113 isEmpty(MODULE):MODULE = $$TARGET
114
115diff --git a/qmake/property.cpp b/qmake/property.cpp
116index bbd4734..dca0c58 100644
117--- a/qmake/property.cpp
118+++ b/qmake/property.cpp
119@@ -74,6 +74,7 @@ static const struct {
120 { "QT_HOST_PREFIX", QLibraryInfo::HostPrefixPath, true },
121 { "QT_HOST_DATA", QLibraryInfo::HostDataPath, true },
122 { "QT_HOST_BINS", QLibraryInfo::HostBinariesPath, true },
123+ { "QT_EXTERNAL_HOST_BINS", QLibraryInfo::ExternalHostBinariesPath, true },
124 { "QMAKE_SPEC", QLibraryInfo::HostSpecPath, true },
125 { "QMAKE_XSPEC", QLibraryInfo::TargetSpecPath, true },
126 };
127diff --git a/qtbase.pro b/qtbase.pro
128index e66d9fb..a6ae763 100644
129--- a/qtbase.pro
130+++ b/qtbase.pro
131@@ -68,17 +68,24 @@ CONFIG -= qt
132
133 #qmake
134 qmake.path = $$[QT_HOST_BINS]
135+qmake.files = $$OUT_PWD/bin/qmake
136+!isEmpty($$[QT_EXTERNAL_HOST_BINS]) {
137+ qmake.files = $$[QT_EXTERNAL_HOST_BINS]/bin/qmake
138+}
139 equals(QMAKE_HOST.os, Windows) {
140- qmake.files = $$OUT_PWD/bin/qmake.exe
141-} else {
142- qmake.files = $$OUT_PWD/bin/qmake
143+ qmake.files = $${qmake.files}.exe
144 }
145 INSTALLS += qmake
146
147 #syncqt
148 syncqt.path = $$[QT_HOST_BINS]
149 syncqt.files = $$PWD/bin/syncqt
150-equals(QMAKE_HOST.os, Windows):syncqt.files += $$PWD/bin/syncqt.bat
151+!isEmpty($$[QT_EXTERNAL_HOST_BINS]) {
152+ syncqt.files = $$[QT_EXTERNAL_HOST_BINS]/bin/syncqt
153+}
154+equals(QMAKE_HOST.os, Windows) {
155+ syncqt.files = $${syncqt.files}.bat
156+}
157 INSTALLS += syncqt
158
159 #mkspecs
160diff --git a/src/corelib/global/qlibraryinfo.cpp b/src/corelib/global/qlibraryinfo.cpp
161index 8138fff..301643f 100644
162--- a/src/corelib/global/qlibraryinfo.cpp
163+++ b/src/corelib/global/qlibraryinfo.cpp
164@@ -270,7 +270,7 @@ QLibraryInfo::isDebugBuild()
165 */
166
167 static const struct {
168- char key[19], value[13];
169+ char key[21], value[13];
170 } qtConfEntries[] = {
171 { "Prefix", "." },
172 { "Documentation", "doc" }, // should be ${Data}/doc
173@@ -291,6 +291,7 @@ static const struct {
174 { "HostPrefix", "" },
175 { "HostBinaries", "bin" },
176 { "HostData", "." },
177+ { "ExternalHostBinaries", "" },
178 { "TargetSpec", "" },
179 { "HostSpec", "" },
180 #endif
181diff --git a/src/corelib/global/qlibraryinfo.h b/src/corelib/global/qlibraryinfo.h
182index a574b4b..1535d20 100644
183--- a/src/corelib/global/qlibraryinfo.h
184+++ b/src/corelib/global/qlibraryinfo.h
185@@ -85,6 +85,7 @@ public:
186 HostPrefixPath,
187 HostBinariesPath,
188 HostDataPath,
189+ ExternalHostBinariesPath,
190 TargetSpecPath,
191 HostSpecPath,
192 LastHostPath = HostSpecPath,
193diff --git a/tools/configure/configureapp.cpp b/tools/configure/configureapp.cpp
194index 126643e..0e01ab5 100644
195--- a/tools/configure/configureapp.cpp
196+++ b/tools/configure/configureapp.cpp
197@@ -1143,6 +1143,13 @@ void Configure::parseCmdLine()
198 dictionary[ "QT_HOST_DATA" ] = configCmdLine.at(i);
199 }
200
201+ else if (configCmdLine.at(i) == "-external-hostbindir") {
202+ ++i;
203+ if (i == argCount)
204+ break;
205+ dictionary[ "QT_EXTERNAL_HOST_BINS" ] = configCmdLine.at(i);
206+ }
207+
208 else if (configCmdLine.at(i) == "-make-tool") {
209 ++i;
210 if (i == argCount)
211@@ -3627,6 +3634,7 @@ void Configure::generateQConfigCpp()
212 << " \"qt_hpfxpath=" << formatPath(dictionary["QT_HOST_PREFIX"]) << "\"," << endl
213 << " \"qt_hbinpath=" << formatPath(dictionary["QT_HOST_BINS"]) << "\"," << endl
214 << " \"qt_hdatpath=" << formatPath(dictionary["QT_HOST_DATA"]) << "\"," << endl
215+ << " \"qt_ebinpath=" << formatPath(dictionary["QT_EXTERNAL_HOST_BINS"]) << "\"," << endl
216 << " \"qt_targspec=" << targSpec << "\"," << endl
217 << " \"qt_hostspec=" << hostSpec << "\"," << endl
218 << "#endif" << endl
219--
2201.8.2.1
221