diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 11:48:09 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 15:25:25 +0200 |
commit | f8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch) | |
tree | 2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch | |
parent | f52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff) | |
download | meta-qt5-f8b065ea1174dd1fa7d93359f6826bfc9d23174c.tar.gz |
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of
changes in .inc files and we have only one version of modules without
release (only one _git.bb) and it's impossible to find SRCREV which
would be compatible with all 4 versions.
* 0005-AddSynchoronization-qimagereader.patch was already backported to
5.0.2 in upstream
* 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was
already applied in 5.0.2
* 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in
qt5-versions.inc
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch')
-rw-r--r-- | recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch | 50 |
1 files changed, 0 insertions, 50 deletions
diff --git a/recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch b/recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch deleted file mode 100644 index d39130c1..00000000 --- a/recipes-qt/qt5/qtbase/0004-qt_functions-temporary-remove-isEmpty-check.patch +++ /dev/null | |||
@@ -1,50 +0,0 @@ | |||
1 | From ff72f8350e8b2ded813163150a7d1874061ed589 Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Wed, 17 Apr 2013 18:06:25 +0200 | ||
4 | Subject: [PATCH 04/12] qt_functions: temporary remove isEmpty check | ||
5 | |||
6 | * now we assume that every build will provide QT_EXTERNAL_HOST_BINS value | ||
7 | * isEmpty works correctly only with qmake variables (e.g. $$FOO - | ||
8 | isEmpty(FOO)), but doesn't work with system properties like $$[FOO]. | ||
9 | |||
10 | Upstream-Status: Pending | ||
11 | |||
12 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
13 | --- | ||
14 | mkspecs/features/qt_functions.prf | 6 +++++- | ||
15 | mkspecs/features/qt_tool.prf | 2 +- | ||
16 | 2 files changed, 6 insertions(+), 2 deletions(-) | ||
17 | |||
18 | diff --git a/mkspecs/features/qt_functions.prf b/mkspecs/features/qt_functions.prf | ||
19 | index e249960..105ba4c 100644 | ||
20 | --- a/mkspecs/features/qt_functions.prf | ||
21 | +++ b/mkspecs/features/qt_functions.prf | ||
22 | @@ -195,7 +195,11 @@ defineTest(qtPrepareTool) { | ||
23 | $$1 = $$eval(QT_TOOL.$${2}.command) | ||
24 | isEmpty($$1) { | ||
25 | $$1 = $$[QT_EXTERNAL_HOST_BINS]/$$2 | ||
26 | - isEmpty($$[QT_EXTERNAL_HOST_BINS]) { | ||
27 | + # for some reason isEmpty does not work here, FIXME before submitting upstream | ||
28 | + # DEBUG 1: mkspecs/features/qt_functions.prf:198: calling built-in isEmpty(/OE/oe-core/tmp-eglibc/sysroots/x86_64-linux/usr/bin/qt5) | ||
29 | + # DEBUG 1: mkspecs/features/qt_functions.prf:198: test function returned true | ||
30 | + # DEBUG 1: mkspecs/features/qt_functions.prf:198: taking 'then' branch | ||
31 | + !exists($$[QT_EXTERNAL_HOST_BINS]/$$2) { | ||
32 | $$1 = $$[QT_HOST_BINS/get]/$$2 | ||
33 | } | ||
34 | contains(QMAKE_HOST.os, Windows):!contains($$1, .*\\.(exe|bat)$) { | ||
35 | diff --git a/mkspecs/features/qt_tool.prf b/mkspecs/features/qt_tool.prf | ||
36 | index 5518933..b0e4f28 100644 | ||
37 | --- a/mkspecs/features/qt_tool.prf | ||
38 | +++ b/mkspecs/features/qt_tool.prf | ||
39 | @@ -31,7 +31,7 @@ load(qt_targets) | ||
40 | |||
41 | # If we are doing a prefix build, create a "module" pri which enables | ||
42 | # qtPrepareTool() to work with the non-installed build. | ||
43 | -!build_pass:!exists($$[QT_INSTALL_PREFIX]/.qmake.cache):isEmpty($$[QT_EXTERNAL_HOST_BINS]) { | ||
44 | +!build_pass:!exists($$[QT_INSTALL_PREFIX]/.qmake.cache):!exists($$[QT_EXTERNAL_HOST_BINS]) { | ||
45 | |||
46 | isEmpty(MODULE):MODULE = $$TARGET | ||
47 | |||
48 | -- | ||
49 | 1.8.2.1 | ||
50 | |||