diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 11:48:09 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-05-28 15:25:25 +0200 |
commit | f8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch) | |
tree | 2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch | |
parent | f52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff) | |
download | meta-qt5-f8b065ea1174dd1fa7d93359f6826bfc9d23174c.tar.gz |
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of
changes in .inc files and we have only one version of modules without
release (only one _git.bb) and it's impossible to find SRCREV which
would be compatible with all 4 versions.
* 0005-AddSynchoronization-qimagereader.patch was already backported to
5.0.2 in upstream
* 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was
already applied in 5.0.2
* 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in
qt5-versions.inc
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch')
-rw-r--r-- | recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch | 37 |
1 files changed, 0 insertions, 37 deletions
diff --git a/recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch b/recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch deleted file mode 100644 index a16731a9..00000000 --- a/recipes-qt/qt5/qtbase/0005-AddSynchoronization-qimagereader.patch +++ /dev/null | |||
@@ -1,37 +0,0 @@ | |||
1 | commit e28c03cb829c229209090d7939a9aba1af1fdea9 | ||
2 | Author: aavit <eirik.aavitsland@digia.com> | ||
3 | Date: Tue Feb 19 18:11:16 2013 +0100 | ||
4 | |||
5 | Fix reentrancy problem in image reading | ||
6 | |||
7 | There were race conditions when accessing the plugin factory and | ||
8 | the image reader plugins from different threads; ref QTBUG-29281. | ||
9 | Added a mutex lock to avoid. | ||
10 | |||
11 | Change-Id: Ic1a3b6cbaf5603f1bcf7025b58247a9a3f6d08a9 | ||
12 | Reviewed-by: Samuel Rødal <samuel.rodal@digia.com> | ||
13 | |||
14 | Upstream-Status: Backport (from 5.1.0) | ||
15 | |||
16 | diff --git a/src/gui/image/qimagereader.cpp b/src/gui/image/qimagereader.cpp | ||
17 | index 5eaf7bb..6847786 100644 | ||
18 | --- a/src/gui/image/qimagereader.cpp | ||
19 | +++ b/src/gui/image/qimagereader.cpp | ||
20 | @@ -133,6 +133,7 @@ | ||
21 | // factory loader | ||
22 | #include <qcoreapplication.h> | ||
23 | #include <private/qfactoryloader_p.h> | ||
24 | +#include <QMutexLocker> | ||
25 | |||
26 | // image handlers | ||
27 | #include <private/qbmphandler_p.h> | ||
28 | @@ -232,6 +233,9 @@ static QImageIOHandler *createReadHandlerHelper(QIODevice *device, | ||
29 | QByteArray suffix; | ||
30 | |||
31 | #ifndef QT_NO_IMAGEFORMATPLUGIN | ||
32 | + static QMutex mutex; | ||
33 | + QMutexLocker locker(&mutex); | ||
34 | + | ||
35 | typedef QMultiMap<int, QString> PluginKeyMap; | ||
36 | |||
37 | // check if we have plugins that support the image format | ||