summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:48:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 15:25:25 +0200
commitf8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch)
tree2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch
parentf52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff)
downloadmeta-qt5-f8b065ea1174dd1fa7d93359f6826bfc9d23174c.tar.gz
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of changes in .inc files and we have only one version of modules without release (only one _git.bb) and it's impossible to find SRCREV which would be compatible with all 4 versions. * 0005-AddSynchoronization-qimagereader.patch was already backported to 5.0.2 in upstream * 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was already applied in 5.0.2 * 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in qt5-versions.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch')
-rw-r--r--recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch62
1 files changed, 0 insertions, 62 deletions
diff --git a/recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch b/recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch
deleted file mode 100644
index dde3b95b..00000000
--- a/recipes-qt/qt5/qtbase/0009-qt_module-Fix-paths-in-.prl-files.patch
+++ /dev/null
@@ -1,62 +0,0 @@
1From 1a0133993cc7924208dd4a0d818599accbcf999e Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 28 Apr 2013 12:56:55 +0200
4Subject: [PATCH 09/12] qt_module: Fix paths in .prl files
5
6* qmake does not prefix them with QT_SYSROOT when using them
7 so e.g. when building qtdeclarative we get -L/usr/lib to LINKAGE
8 variable, which is unsafe for cross-compilation
9* writting QT_SYSROOT in .prl files is dangerous for sstate when
10 builds are in different directories, so we need
11 SSTATE_SCAN_FILES += "*.pri *.prl"
12 to make them relocateble
13
14Upstream-Status: Pending
15
16Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
17---
18 mkspecs/features/qt_module.prf | 28 +++++++++++++++++-----------
19 1 file changed, 17 insertions(+), 11 deletions(-)
20
21diff --git a/mkspecs/features/qt_module.prf b/mkspecs/features/qt_module.prf
22index 9532377..73053f7 100644
23--- a/mkspecs/features/qt_module.prf
24+++ b/mkspecs/features/qt_module.prf
25@@ -195,17 +195,23 @@ unix|win32-g++* {
26 pkgconfig_include_replace.replace = "\$$\\{includedir}"
27 pkgconfig_lib_replace.match = $$rplbase/lib
28 pkgconfig_lib_replace.replace = "\$$\\{libdir}"
29- include_replace.match = $$rplbase/include
30- include_replace.replace = $$[QT_INSTALL_HEADERS/raw]
31- lib_replace.match = $$rplbase/lib
32- lib_replace.replace = $$[QT_INSTALL_LIBS/raw]
33- lafile_replace.match = $$rplbase
34- lafile_replace.replace = "=$$[QT_INSTALL_PREFIX/raw]"
35-
36- !isEmpty(SYSROOT): \
37- rplbase = $$[SYSROOT] \
38- lafile_replace.match = $$rplbase \
39- lafile_replace.replace = "=" \
40+ !exists($$[QT_SYSROOT]) {
41+ include_replace.match = $$rplbase/include
42+ include_replace.replace = $$[QT_INSTALL_HEADERS/raw]
43+ lib_replace.match = $$rplbase/lib
44+ lib_replace.replace = $$[QT_INSTALL_LIBS/raw]
45+ lafile_replace.match = $$rplbase
46+ lafile_replace.replace = "$$[QT_INSTALL_PREFIX/raw]"
47+ } else {
48+ # include_replace and lib_replace are duplicate, but we don't want to
49+ # make QMAKE_PKGCONFIG_INSTALL_REPLACE, QMAKE_PRL_INSTALL_REPLACE conditional
50+ include_replace.match = $$rplbase
51+ include_replace.replace = $$[QT_SYSROOT]$$[QT_INSTALL_PREFIX/raw]
52+ lib_replace.match = $$rplbase
53+ lib_replace.replace = $$[QT_SYSROOT]$$[QT_INSTALL_PREFIX/raw]
54+ lafile_replace.match = $$rplbase
55+ lafile_replace.replace = "=$$[QT_INSTALL_PREFIX/raw]"
56+ }
57
58 QMAKE_PKGCONFIG_INSTALL_REPLACE += pkgconfig_include_replace pkgconfig_lib_replace
59 }
60--
611.8.2.1
62