summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 11:48:09 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2013-05-28 15:25:25 +0200
commitf8b065ea1174dd1fa7d93359f6826bfc9d23174c (patch)
tree2da2a4be9b5aff64e54a818a19a8939266eed05f /recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
parentf52b59a5cc9ddfb0ede39194e284c858bfd0cbd8 (diff)
downloadmeta-qt5-f8b065ea1174dd1fa7d93359f6826bfc9d23174c.tar.gz
qt5: drop 5.0.0 and 5.0.1 versions
* maintaining 4 different versions requires a lot more testing of changes in .inc files and we have only one version of modules without release (only one _git.bb) and it's impossible to find SRCREV which would be compatible with all 4 versions. * 0005-AddSynchoronization-qimagereader.patch was already backported to 5.0.2 in upstream * 0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch was already applied in 5.0.2 * 5.0.2 is now default version (based on DEFAULT_PREFERENCE and in qt5-versions.inc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch')
-rw-r--r--recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch39
1 files changed, 0 insertions, 39 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch b/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
deleted file mode 100644
index 650e603a..00000000
--- a/recipes-qt/qt5/qtdeclarative/0001-Flickable-Fix-bug-when-flicking-twice-using-touches.patch
+++ /dev/null
@@ -1,39 +0,0 @@
1From 27be7a832f017653ffda705407bb7a64246eda1f Mon Sep 17 00:00:00 2001
2From: Daniel d'Andrada <daniel.dandrada@canonical.com>
3Date: Tue, 18 Dec 2012 10:51:21 -0200
4Subject: [PATCH] Flickable: Fix bug when flicking twice using touches
5
6When you flick twice in rapid succession, in the same direction,
7the expected behavior is for flickable to be moving quite fast in the
8direction of the flicks.
9
10But when you flicked using touch events instead of mouse ones,
11the second flick caused Flickable to immediately halt. This change fixes it.
12
13Upstream-Status: Backport
14
15Change-Id: I02bd02fed30bd4a98959194e04f0a26b4420cd05
16Reviewed-by: Andras Becsi <andras.becsi@digia.com>
17---
18 src/quick/items/qquickflickable.cpp | 5 +++++
19 1 file changed, 5 insertions(+)
20
21diff --git a/src/quick/items/qquickflickable.cpp b/src/quick/items/qquickflickable.cpp
22index 6e5e6b7..88ef20f 100644
23--- a/src/quick/items/qquickflickable.cpp
24+++ b/src/quick/items/qquickflickable.cpp
25@@ -2038,6 +2038,11 @@ bool QQuickFlickable::sendMouseEvent(QQuickItem *item, QMouseEvent *event)
26
27 QQuickWindow *c = window();
28 QQuickItem *grabber = c ? c->mouseGrabberItem() : 0;
29+ if (grabber == this && d->stealMouse) {
30+ // we are already the grabber and we do want the mouse event to ourselves.
31+ return true;
32+ }
33+
34 bool grabberDisabled = grabber && !grabber->isEnabled();
35 bool stealThisEvent = d->stealMouse;
36 if ((stealThisEvent || contains(localPos)) && (!grabber || !grabber->keepMouseGrab() || grabberDisabled)) {
37--
381.7.9.5
39