summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2019-04-17 23:32:56 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-04-18 23:04:41 +0000
commite2707a016c3475c167a421c9c73d88f81cc61bd1 (patch)
treee4bae2a878e4c97496dcd536af717f093c9579f2 /recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
parent07784245c1822766d54405d835ac2dc08652df1a (diff)
downloadmeta-qt5-e2707a016c3475c167a421c9c73d88f81cc61bd1.tar.gz
qt5: upgrade to 5.12.3
* be aware that in 3 qt* project the v5.12.3 tag wasn't created yet: qtknx_git.bb:# v5.12.3 tag wasn't created yet qtmqtt_git.bb:# v5.12.3 tag wasn't created yet qtopcua_git.bb:# v5.12.3 tag wasn't created yet * and qttools, qt3d, qtremoteobjects v5.12.3 tag isn't in 5.12 branch Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
index c9266582..7136b475 100644
--- a/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
+++ b/recipes-qt/qt5/qtwebengine/0001-Force-host-toolchain-configuration.patch
@@ -1,4 +1,4 @@
1From a321d1b96ce0563a08d0bb44c39d24f86608f6ae Mon Sep 17 00:00:00 2001 1From bf92c8a03189d7a559aff7d62c2d9fc6047d2659 Mon Sep 17 00:00:00 2001
2From: Samuli Piippo <samuli.piippo@qt.io> 2From: Samuli Piippo <samuli.piippo@qt.io>
3Date: Wed, 15 Mar 2017 13:53:28 +0200 3Date: Wed, 15 Mar 2017 13:53:28 +0200
4Subject: [PATCH] Force host toolchain configuration 4Subject: [PATCH] Force host toolchain configuration
@@ -17,6 +17,8 @@ Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
17 src/core/config/linux.pri | 2 +- 17 src/core/config/linux.pri | 2 +-
18 2 files changed, 8 insertions(+), 8 deletions(-) 18 2 files changed, 8 insertions(+), 8 deletions(-)
19 19
20diff --git a/src/buildtools/configure_host.pro b/src/buildtools/configure_host.pro
21index dd0d3e32..70161c82 100644
20--- a/src/buildtools/configure_host.pro 22--- a/src/buildtools/configure_host.pro
21+++ b/src/buildtools/configure_host.pro 23+++ b/src/buildtools/configure_host.pro
22@@ -4,7 +4,7 @@ TEMPLATE = aux 24@@ -4,7 +4,7 @@ TEMPLATE = aux
@@ -35,9 +37,9 @@ Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
35-" cc = \"$$which($$QMAKE_CC)\" " \ 37-" cc = \"$$which($$QMAKE_CC)\" " \
36-" cxx = \"$$which($$QMAKE_CXX)\" " \ 38-" cxx = \"$$which($$QMAKE_CXX)\" " \
37-" ld = \"$$which($$QMAKE_LINK)\" " \ 39-" ld = \"$$which($$QMAKE_LINK)\" " \
38+" cc = \"$$which($$CC_host)\" " \ 40+" cc = \"$$which(gcc)\" " \
39+" cxx = \"$$which($$CXX_host)\" " \ 41+" cxx = \"$$which(g++)\" " \
40+" ld = \"$$which($$CXX_host)\" " \ 42+" ld = \"$$which(g++)\" " \
41 " ar = \"$$which(ar)\" " \ 43 " ar = \"$$which(ar)\" " \
42 " nm = \"$$which(nm)\" " \ 44 " nm = \"$$which(nm)\" " \
43 " extra_cppflags = \"$$GN_HOST_EXTRA_CPPFLAGS\" " \ 45 " extra_cppflags = \"$$GN_HOST_EXTRA_CPPFLAGS\" " \
@@ -48,15 +50,17 @@ Signed-off-by: Samuli Piippo <samuli.piippo@qt.io>
48-" cc = \"$$which($$QMAKE_CC)\" " \ 50-" cc = \"$$which($$QMAKE_CC)\" " \
49-" cxx = \"$$which($$QMAKE_CXX)\" " \ 51-" cxx = \"$$which($$QMAKE_CXX)\" " \
50-" ld = \"$$which($$QMAKE_LINK)\" " \ 52-" ld = \"$$which($$QMAKE_LINK)\" " \
51+" cc = \"$$which($$CC_host)\" " \ 53+" cc = \"$$which(gcc)\" " \
52+" cxx = \"$$which($$CXX_host)\" " \ 54+" cxx = \"$$which(g++)\" " \
53+" ld = \"$$which($$CXX_host)\" " \ 55+" ld = \"$$which(g++)\" " \
54 " ar = \"$$which(ar)\" " \ 56 " ar = \"$$which(ar)\" " \
55 " nm = \"$$which(nm)\" " \ 57 " nm = \"$$which(nm)\" " \
56 " toolchain_args = { " \ 58 " toolchain_args = { " \
59diff --git a/src/core/config/linux.pri b/src/core/config/linux.pri
60index 9fc8c6e8..f3768585 100644
57--- a/src/core/config/linux.pri 61--- a/src/core/config/linux.pri
58+++ b/src/core/config/linux.pri 62+++ b/src/core/config/linux.pri
59@@ -112,7 +112,7 @@ contains(QT_ARCH, "mips") { 63@@ -113,7 +113,7 @@ contains(QT_ARCH, "mips") {
60 64
61 host_build { 65 host_build {
62 gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\" 66 gn_args += custom_toolchain=\"$$QTWEBENGINE_OUT_ROOT/src/toolchain:host\"