summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:55:56 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2020-01-11 14:59:12 +0100
commitb814111ed28cab46d9d896919b2b5fe308614e1d (patch)
tree09b7b2ee7a67ed0e732cc8d789499dde4b90bc8f /recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch
parent1fde17e1a570aa5495ecbe8a8daae95b628db260 (diff)
downloadmeta-qt5-b814111ed28cab46d9d896919b2b5fe308614e1d.tar.gz
qtwebengine: refresh the patches and upload them to meta-qt5 forks on github for maintenance
* fixes 0004-mkspecs-Allow-builds-with-libc-glibc.patch which didn't apply at all, because the modified mkspecs/features/configure.prf was dropped completely in: commit 047d61f188aae3fe3ebc689900b8a5c9fb6e901d Author: Michal Klocek michal.klocek@qt.io Date: Fri Aug 9 17:40:29 2019 +0200 Add webengine-core feature The same chunk can be found in src/buildtools/config/support.pri, so I've updated the .patch accordingly, but haven't tried the build with musl yet. * fixes 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch to apply ERROR: qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0 do_patch: Command Error: 'quilt --quiltrc /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0 Output: Applying patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch patching file chromium/cc/base/list_container_helper.cc Hunk #1 FAILED at 13. 1 out of 1 hunk FAILED -- rejects in file chromium/cc/base/list_container_helper.cc patching file chromium/cc/base/list_container_helper.h Hunk #1 FAILED at 8. Hunk #2 succeeded at 174 with fuzz 1. 1 out of 2 hunks FAILED -- rejects in file chromium/cc/base/list_container_helper.h Patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch does not apply (enforce with -f) ERROR: Logfile of failure stored in: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/temp/log.do_patch.21067 NOTE: recipe qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0: task do_patch: Failed ERROR: Task (/OE/build/oe-core/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_patch) failed with exit code '1' * build is still going (it will be a while on my slow builder) Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch')
-rw-r--r--recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch
new file mode 100644
index 00000000..2fdc4944
--- /dev/null
+++ b/recipes-qt/qt5/qtwebengine/chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch
@@ -0,0 +1,23 @@
1From 04a11fa6f38987091b6b65244950d3d83579c9a8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 7 Jul 2017 14:54:38 -0700
4Subject: [PATCH] chromium: musl: linux != glibc, make the distinction
5
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7---
8 chromium/base/allocator/allocator_check.cc | 2 +-
9 1 file changed, 1 insertion(+), 1 deletion(-)
10
11diff --git a/chromium/base/allocator/allocator_check.cc b/chromium/base/allocator/allocator_check.cc
12index 5fb86467dde..9864858eb67 100644
13--- a/chromium/base/allocator/allocator_check.cc
14+++ b/chromium/base/allocator/allocator_check.cc
15@@ -27,7 +27,7 @@ bool IsAllocatorInitialized() {
16 // Set by allocator_shim_override_ucrt_symbols_win.h when the
17 // shimmed _set_new_mode() is called.
18 return g_is_win_shim_layer_initialized;
19-#elif defined(OS_LINUX) && defined(USE_TCMALLOC) && \
20+#elif defined(__GLIBC__) && defined(USE_TCMALLOC) && \
21 !defined(MEMORY_TOOL_REPLACES_ALLOCATOR)
22 // From third_party/tcmalloc/chromium/src/gperftools/tcmalloc.h.
23 // TODO(primiano): replace with an include once base can depend on allocator.