diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2020-01-11 14:55:56 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2020-01-11 14:59:12 +0100 |
commit | b814111ed28cab46d9d896919b2b5fe308614e1d (patch) | |
tree | 09b7b2ee7a67ed0e732cc8d789499dde4b90bc8f /recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch | |
parent | 1fde17e1a570aa5495ecbe8a8daae95b628db260 (diff) | |
download | meta-qt5-b814111ed28cab46d9d896919b2b5fe308614e1d.tar.gz |
qtwebengine: refresh the patches and upload them to meta-qt5 forks on github for maintenance
* fixes 0004-mkspecs-Allow-builds-with-libc-glibc.patch which didn't apply at all,
because the modified mkspecs/features/configure.prf was dropped completely in:
commit 047d61f188aae3fe3ebc689900b8a5c9fb6e901d
Author: Michal Klocek michal.klocek@qt.io
Date: Fri Aug 9 17:40:29 2019 +0200
Add webengine-core feature
The same chunk can be found in src/buildtools/config/support.pri, so I've updated
the .patch accordingly, but haven't tried the build with musl yet.
* fixes 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch to apply
ERROR: qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0 do_patch: Command Error: 'quilt --quiltrc /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/recipe-sysroot-native/etc/quiltrc push' exited with 0 Output:
Applying patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch
patching file chromium/cc/base/list_container_helper.cc
Hunk #1 FAILED at 13.
1 out of 1 hunk FAILED -- rejects in file chromium/cc/base/list_container_helper.cc
patching file chromium/cc/base/list_container_helper.h
Hunk #1 FAILED at 8.
Hunk #2 succeeded at 174 with fuzz 1.
1 out of 2 hunks FAILED -- rejects in file chromium/cc/base/list_container_helper.h
Patch 0023-chromium-Move-CharAllocator-definition-to-a-header-f.patch does not apply (enforce with -f)
ERROR: Logfile of failure stored in: /OE/build/oe-core/tmp-glibc/work/core2-64-oe-linux/qtwebengine/5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0/temp/log.do_patch.21067
NOTE: recipe qtwebengine-5.14.0+gitAUTOINC+d366f1d5d3_939daf833f-r0: task do_patch: Failed
ERROR: Task (/OE/build/oe-core/meta-qt5/recipes-qt/qt5/qtwebengine_git.bb:do_patch) failed with exit code '1'
* build is still going (it will be a while on my slow builder)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch')
-rw-r--r-- | recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch b/recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch new file mode 100644 index 00000000..631ae8a0 --- /dev/null +++ b/recipes-qt/qt5/qtwebengine/chromium/0023-chromium-musl-pread-pwrite.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 725941687b118b90904fbc7e6b25a288b9d3c52b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 23 Dec 2018 16:58:04 -0800 | ||
4 | Subject: [PATCH] chromium: musl: pread pwrite | ||
5 | |||
6 | Redefine pread/pwrite in terms of 64bit variants on musl | ||
7 | since 32bit variants don't exist and aliases are not defined in | ||
8 | libc either | ||
9 | |||
10 | Upstream-Status: Submitted [https://codereview.chromium.org/1743093002/] | ||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | chromium/third_party/lss/linux_syscall_support.h | 5 +++++ | ||
14 | 1 file changed, 5 insertions(+) | ||
15 | |||
16 | diff --git a/chromium/third_party/lss/linux_syscall_support.h b/chromium/third_party/lss/linux_syscall_support.h | ||
17 | index 622cc1fbf7e..cd561b80c05 100644 | ||
18 | --- a/chromium/third_party/lss/linux_syscall_support.h | ||
19 | +++ b/chromium/third_party/lss/linux_syscall_support.h | ||
20 | @@ -1239,6 +1239,11 @@ struct kernel_statfs { | ||
21 | #ifndef __NR_fallocate | ||
22 | #define __NR_fallocate 285 | ||
23 | #endif | ||
24 | +#undef __NR_pread | ||
25 | +#define __NR_pread __NR_pread64 | ||
26 | +#undef __NR_pwrite | ||
27 | +#define __NR_pwrite __NR_pwrite64 | ||
28 | + | ||
29 | /* End of x86-64 definitions */ | ||
30 | #elif defined(__mips__) | ||
31 | #if _MIPS_SIM == _MIPS_SIM_ABI32 | ||