summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-01-26 16:54:50 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-01-26 16:18:39 +0100
commit333949a8239dfa7788b35f1059614733e11a6a25 (patch)
tree420843abad8bfc939484fa34bd6f7da9d432db8d /recipes-qt/qt5/qtwebengine_git.bb
parentc0ba8ab590ba4e17a2a04925cf48915233d4f493 (diff)
downloadmeta-qt5-333949a8239dfa7788b35f1059614733e11a6a25.tar.gz
Upgrade to Qt 5.8
The linux-oe-g++ mkspec is changed to use $$(...) operator to obtain the contents of an environment value when qmake is run instead of when Makefile is processed. All OE_QMAKE_xxx variables need to be exported for qmake to find them. configure's setBootstrapVariable function needs to change $$(..) to normal $(...) operator to work with qmake's Makefile. qt.conf generation for qtbase recipes is not needed, as configure will generate its own version based on configure arguments. Skip running qmake, since configure is now automatically invoked when it's run in qtbase's root folder. Update PACKAGECONFIGs for qtbase to match current configure options. The new Qt configuration system [1] can be used with a new variable EXTRA_QMAKEVARS_CONFIGURE, which takes both command line and feature arguments. Merge the two qtwayland recipes to one that supports all three targets (target, native, nativesdk) without need for additional patch. Recipes for new Qt modules: QtSCXML, QtNetworkAuth, QtGamepad. Removes qtdeclarative-render2d [1] https://www.mail-archive.com/development@qt-project.org/msg25257.html Change-Id: Ib37c4d7323e8b45aa2b171e8427b6ec15aaee213 Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb26
1 files changed, 7 insertions, 19 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 6ec58ead..4ab30ead 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -20,14 +20,9 @@ DEPENDS += " \
20 libdrm fontconfig pixman openssl pango cairo icu pciutils \ 20 libdrm fontconfig pixman openssl pango cairo icu pciutils \
21 libcap \ 21 libcap \
22 gperf-native \ 22 gperf-native \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \
23" 24"
24 25
25# when qtbase is built with xcb enabled (default with x11 in DISTRO_FEATURES),
26# qtwebengine will have additional dependencies:
27# contains(QT_CONFIG, xcb): REQUIRED_PACKAGES += libdrm xcomposite xcursor xi xrandr xscrnsaver xtst
28# xscreensaver isn't covered in qtbase DEPENDS
29DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxscrnsaver', '', d)}"
30
31DEPENDS += "yasm-native" 26DEPENDS += "yasm-native"
32EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm" 27EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm"
33 28
@@ -52,6 +47,7 @@ COMPATIBLE_MACHINE_x86-64 = "(.*)"
52COMPATIBLE_MACHINE_armv6 = "(.*)" 47COMPATIBLE_MACHINE_armv6 = "(.*)"
53COMPATIBLE_MACHINE_armv7a = "(.*)" 48COMPATIBLE_MACHINE_armv7a = "(.*)"
54COMPATIBLE_MACHINE_armv7ve = "(.*)" 49COMPATIBLE_MACHINE_armv7ve = "(.*)"
50COMPATIBLE_MACHINE_aarch64 = "(.*)"
55 51
56inherit qmake5 52inherit qmake5
57inherit gettext 53inherit gettext
@@ -65,10 +61,6 @@ def gettext_oeconf(d):
65require qt5.inc 61require qt5.inc
66require qt5-git.inc 62require qt5-git.inc
67 63
68# To avoid trouble start with not separated build directory
69SEPB = "${S}"
70B = "${SEPB}"
71
72export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja" 64export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja"
73 65
74do_configure() { 66do_configure() {
@@ -82,11 +74,11 @@ do_configure() {
82 export QMAKE_CACHE_EVAL="${PACKAGECONFIG_CONFARGS}" 74 export QMAKE_CACHE_EVAL="${PACKAGECONFIG_CONFARGS}"
83 75
84 # Disable autodetection from sysroot: 76 # Disable autodetection from sysroot:
85 sed -i 's/packagesExist([^)]*vpx[^)]*):/false:/g; s/config_srtp:/false:/g; s/config_snappy:/false:/g; s/packagesExist(nss):/false:/g; s/packagesExist(minizip, zlib):/false:/g; s/packagesExist(libwebp,libwebpdemux):/false:/g; s/packagesExist(libxml-2.0,libxslt):/false:/g; s/^ *packagesExist($$package):/false:/g' ${S}/tools/qmake/mkspecs/features/configure.prf 77 sed -i 's/packagesExist([^)]*vpx[^)]*):/false:/g; s/config_libvpx:/false:/g; s/config_srtp:/false:/g; s/config_snappy:/false:/g; s/packagesExist(nss):/false:/g; s/packagesExist(minizip, zlib):/false:/g; s/packagesExist(libwebp,libwebpdemux):/false:/g; s/packagesExist(libxml-2.0,libxslt):/false:/g; s/^ *packagesExist($$package):/false:/g' ${S}/tools/qmake/mkspecs/features/configure.prf
86 78
87 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as 79 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as
88 # arguments here 80 # arguments here
89 ${OE_QMAKE_QMAKE} -r ${EXTRA_QMAKEVARS_PRE} QTWEBENGINE_ROOT="${S}" \ 81 ${OE_QMAKE_QMAKE} ${OE_QMAKE_QTCONF} -r ${EXTRA_QMAKEVARS_PRE} ${S} \
90 QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \ 82 QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \
91 QMAKE_LINK="${OE_QMAKE_LINK}" \ 83 QMAKE_LINK="${OE_QMAKE_LINK}" \
92 QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \ 84 QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \
@@ -110,7 +102,7 @@ RDEPENDS_${PN}-examples += " \
110 qtdeclarative-qmlplugins \ 102 qtdeclarative-qmlplugins \
111" 103"
112 104
113QT_MODULE_BRANCH_CHROMIUM = "49-based" 105QT_MODULE_BRANCH_CHROMIUM = "53-based"
114 106
115SRC_URI += " \ 107SRC_URI += " \
116 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 108 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
@@ -123,15 +115,11 @@ SRC_URI += " \
123 file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \ 115 file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch \
124" 116"
125 117
126SRCREV_qtwebengine = "dbf7dd27428ff755444eac5e975cb69802ac9771" 118SRCREV_qtwebengine = "d740d6a7dbfec387752c7bc8a8b06db0e757c9dc"
127# This is in git submodule, but we're using the latest in 49-based 119SRCREV_chromium = "15d257fd921f37b32ef643225f21df0ea24c8302"
128# SRCREV_chromium = "c109a95a067af783e48f93d1cdeca870cda98878"
129SRCREV_chromium = "29c16917b33c26ad32893fa05af971c6c6f50297"
130SRCREV = "${SRCREV_qtwebengine}" 120SRCREV = "${SRCREV_qtwebengine}"
131 121
132SRCREV_FORMAT = "qtwebengine_chromium" 122SRCREV_FORMAT = "qtwebengine_chromium"
133 123
134S = "${WORKDIR}/git"
135
136# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel] 124# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel]
137INSANE_SKIP_${PN} += "textrel" 125INSANE_SKIP_${PN} += "textrel"