summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2017-12-14 16:39:54 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-12-16 15:51:12 +0000
commit5ae76bbcf5b59b12a03d0f017aab9139609f16f6 (patch)
tree8fdd5068969a476fa482fe7d6f280e1d753918eb /recipes-qt/qt5/qtwebengine_git.bb
parent06d1c47396508ea50112a00e1c70c40da559aa1a (diff)
downloadmeta-qt5-5ae76bbcf5b59b12a03d0f017aab9139609f16f6.tar.gz
Upgrade to Qt 5.10.0
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb72
1 files changed, 32 insertions, 40 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 50a98b66..f88e5e7d 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -13,26 +13,23 @@ LIC_FILES_CHKSUM = " \
13" 13"
14 14
15DEPENDS += " \ 15DEPENDS += " \
16 libpng-native \
17 nss-native \
18 nspr-native \
16 ninja-native \ 19 ninja-native \
17 yasm-native \ 20 yasm-native \
18 qtwebchannel \ 21 qtwebchannel \
19 qtbase qtdeclarative qtxmlpatterns qtquickcontrols qtquickcontrols2 \ 22 qtbase qtdeclarative qtxmlpatterns qtquickcontrols qtquickcontrols2 \
20 qtlocation \ 23 qtlocation \
21 libdrm fontconfig pixman openssl pango cairo icu pciutils \ 24 libdrm fontconfig pixman openssl pango cairo icu pciutils nss \
22 libcap \ 25 libcap \
23 gperf-native \ 26 gperf-native \
24 ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \ 27 ${@bb.utils.contains('DISTRO_FEATURES', 'alsa', 'alsa-lib', '', d)} \
25" 28"
26 29
27DEPENDS += "yasm-native"
28DEPENDS_append_libc-musl = " libexecinfo" 30DEPENDS_append_libc-musl = " libexecinfo"
29 31
30EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm \ 32EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
31 GYP_CONFIG+=generate_character_data=0 \
32 GYP_CONFIG+=use_allocator=none \
33 GYP_CONFIG+=use_experimental_allocator_shim=false \
34"
35EXTRA_QMAKEVARS_CONFIGURE += "-feature-system-ninja -no-feature-system-gn"
36 33
37# chromium/third_party/openh264/openh264.gyp adds 34# chromium/third_party/openh264/openh264.gyp adds
38# -Wno-format to openh264_cflags_add 35# -Wno-format to openh264_cflags_add
@@ -42,22 +39,26 @@ EXTRA_QMAKEVARS_CONFIGURE += "-feature-system-ninja -no-feature-system-gn"
42# http://errors.yoctoproject.org/Errors/Details/150333/ 39# http://errors.yoctoproject.org/Errors/Details/150333/
43SECURITY_STRINGFORMAT = "" 40SECURITY_STRINGFORMAT = ""
44 41
45# To use system ffmpeg you need to enable also libwebp, opus, vpx 42# To use system ffmpeg you need to enable also libwebp, opus, vpx
46# Only depenedencies available in oe-core are enabled by default 43# Only depenedencies available in oe-core are enabled by default
47PACKAGECONFIG ??= "libwebp flac libevent libxslt speex nss" 44PACKAGECONFIG ??= "libwebp libevent libpng"
48PACKAGECONFIG[opus] = "WEBENGINE_CONFIG+=use_system_opus,,libopus" 45PACKAGECONFIG[icu] = "-feature-webengine-system-icu,-no-feature-webengine-system-icu,icu"
49PACKAGECONFIG[icu] = "WEBENGINE_CONFIG+=use_system_icu,,icu" 46PACKAGECONFIG[ffmpeg] = "-feature-webengine-system-ffmpeg,-no-feature-webengine-system-ffmpeg,libav"
50PACKAGECONFIG[ffmpeg] = "WEBENGINE_CONFIG+=use_system_ffmpeg,,libav" 47PACKAGECONFIG[webrtc] = "-feature-webengine-webrtc,-no-feature-webengine-webrtc,libvpx"
51PACKAGECONFIG[libwebp] = "WEBENGINE_CONFIG+=use_system_libwebp,,libwebp" 48PACKAGECONFIG[libwebp] = "-feature-webengine-system-libwebp,-no-feature-webengine-system-libwebp,libwebp"
52PACKAGECONFIG[flac] = "WEBENGINE_CONFIG+=use_system_flac,,flac" 49PACKAGECONFIG[opus] = "-feature-webengine-system-opus,-no-feature-webengine-system-opus,libopus"
53PACKAGECONFIG[libevent] = "WEBENGINE_CONFIG+=use_system_libevent,,libevent" 50PACKAGECONFIG[libvpx] = "-feature-webengine-system-libvpx,-no-feature-webengine-system-libvpx,libvpx"
54PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt" 51PACKAGECONFIG[libevent] = "-feature-webengine-system-libevent,-no-feature-webengine-system-libevent,libevent"
55PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex" 52PACKAGECONFIG[libpng] = "-feature-webengine-system-png,-no-feature-webengine-system-png,libpng"
56PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx" 53PACKAGECONFIG[harfbuzz] = "-feature-webengine-system-harfbuzz,-no-feature-webengine-system-harfbuzz,harfbuzz"
57PACKAGECONFIG[webrtc] = "WEBENGINE_CONFIG+=use_webrtc,,libvpx" 54PACKAGECONFIG[glib] = "-feature-webengine-system-glib,-no-feature-webengine-system-glib,glib"
58PACKAGECONFIG[nss] = "WEBENGINE_CONFIG+=use_nss,,nss" 55PACKAGECONFIG[zlib] = "-feature-webengine-system-zlib,-no-feature-webengine-system-zlib,zlib"
59 56PACKAGECONFIG[protobuf] = "-feature-webengine-system-protobuf,-no-feature-webengine-system-protobuf,protobuf"
60EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" 57PACKAGECONFIG[jasoncpp] = "-feature-webengine-system-jsoncpp,-no-feature-webengine-system-jsoncpp,jasoncpp"
58PACKAGECONFIG[libxml2] = "-feature-webengine-system-libxml2,-no-feature-webengine-system-libxml2,libxml2"
59PACKAGECONFIG[minizip] = "-feature-webengine-system-minizip,-no-feature-webengine-system-minizip,minizip"
60
61EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
61 62
62COMPATIBLE_MACHINE = "(-)" 63COMPATIBLE_MACHINE = "(-)"
63COMPATIBLE_MACHINE_x86 = "(.*)" 64COMPATIBLE_MACHINE_x86 = "(.*)"
@@ -79,18 +80,10 @@ def gettext_oeconf(d):
79require qt5.inc 80require qt5.inc
80require qt5-git.inc 81require qt5-git.inc
81 82
83export GN_PKG_CONFIG_HOST = "${STAGING_BINDIR_NATIVE}/pkg-config-native"
84export GN_HOST_TOOLCHAIN_EXTRA_CPPFLAGS = "-I${STAGING_DIR_NATIVE}/usr/include"
85
82do_configure() { 86do_configure() {
83 # Disable autodetection from sysroot:
84 sed -e 's/packagesExist([^)]*vpx[^)]*):/false:/g'\
85 -e 's/config_libvpx:/false:/g' \
86 -e 's/config_srtp:/false:/g' \
87 -e 's/config_snappy:/false:/g' \
88 -e 's/packagesExist(nss):/false:/g' \
89 -e 's/packagesExist(minizip, zlib):/false:/g' \
90 -e 's/packagesExist(libwebp,libwebpdemux):/false:/g' \
91 -e 's/packagesExist(libxml-2.0,libxslt):/false:/g'\
92 -e 's/^ *packagesExist($$package):/false:/g' \
93 -i ${S}/mkspecs/features/configure.prf
94 87
95 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as 88 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as
96 # arguments here 89 # arguments here
@@ -127,28 +120,27 @@ RDEPENDS_${PN}-examples += " \
127 qtdeclarative-qmlplugins \ 120 qtdeclarative-qmlplugins \
128" 121"
129 122
130QT_MODULE_BRANCH_CHROMIUM = "56-based" 123QT_MODULE_BRANCH_CHROMIUM = "61-based"
131 124
132# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.9 125# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.9
133# 5.9.meta-qt5.3 126# 5.9.meta-qt5.3
134SRC_URI += " \ 127SRC_URI += " \
135 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 128 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
136 file://0001-functions.prf-allow-build-for-linux-oe-g-platform.patch \
137 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \ 129 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
138 file://0003-Include-dependency-to-QCoreApplication-translate.patch \ 130 file://0003-Include-dependency-to-QCoreApplication-translate.patch \
139 file://0004-Force-host-toolchain-configuration.patch \ 131 file://0004-Force-host-toolchain-configuration.patch \
140 file://0005-tests-make-accessibility-tests-conditional.patch \
141" 132"
142 133
143# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based 134# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/56-based
144# 56-based.meta-qt5.2 135# 56-based.meta-qt5.2
145SRC_URI += " \ 136SRC_URI += " \
146 file://0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch;patchdir=src/3rdparty \
147 file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 137 file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
148 file://0003-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 138 file://0003-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
149" 139"
150 140
151SRC_URI_append_libc-musl = "\ 141SRC_URI_append_libc-musl = "\
142 file://0005-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
143 file://0006-musl-link-against-libexecinfo.patch \
152 file://0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 144 file://0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
153 file://0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 145 file://0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
154 file://0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 146 file://0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
@@ -164,8 +156,8 @@ SRC_URI_append_libc-musl = "\
164 file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \ 156 file://0016-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
165" 157"
166 158
167SRCREV_qtwebengine = "c11c2c8981e647c1eb2c6753ce77d436b92fff87" 159SRCREV_qtwebengine = "efa6d3f0d3a01753dd40823ce119e7d4f9765c8e"
168SRCREV_chromium = "cfe8c60903b327ac94406661350f4ac05aa8c21b" 160SRCREV_chromium = "e36dcec23b79a52fd7794ed2fad49bbf65a8146b"
169SRCREV = "${SRCREV_qtwebengine}" 161SRCREV = "${SRCREV_qtwebengine}"
170 162
171SRCREV_FORMAT = "qtwebengine_chromium" 163SRCREV_FORMAT = "qtwebengine_chromium"