summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@qt.io>2018-07-04 10:20:19 +0300
committerMartin Jansa <Martin.Jansa@gmail.com>2018-12-23 19:40:34 +0000
commitd45b966b4612fe59ac3c53e0f7a3c480d29b2fbe (patch)
treee12362298f3ce80a2f24b9200d2ec9342d4c7f22 /recipes-qt/qt5/qtwebengine_git.bb
parent8c7797ba5a2c2ba39a4389954b2ca72efc37e036 (diff)
downloadmeta-qt5-d45b966b4612fe59ac3c53e0f7a3c480d29b2fbe.tar.gz
qtwebengine: update chromium musl patchset
Signed-off-by: Mikko Gronoff <mikko.gronoff@qt.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb37
1 files changed, 20 insertions, 17 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 71b9ecba..7d5c80bf 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -112,7 +112,6 @@ do_configure_prepend_libc-musl() {
112 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do 112 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do
113 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f 113 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f
114 done 114 done
115 sed -i -e "s:define HAVE_STRUCT_MALLINFO 1:/*undef HAVE_STRUCT_MALLINFO */:g" ${S}/src/3rdparty/chromium/third_party/tcmalloc/chromium/src/config_linux.h
116} 115}
117 116
118do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+" 117do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
@@ -136,35 +135,39 @@ RDEPENDS_${PN}-examples += " \
136QT_MODULE_BRANCH_CHROMIUM = "69-based" 135QT_MODULE_BRANCH_CHROMIUM = "69-based"
137 136
138# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.12 137# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.12
139# 5.12.meta-qt5.1 138# 5.12.meta-qt5.2
140SRC_URI += " \ 139SRC_URI += " \
141 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 140 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
142 file://0001-Force-host-toolchain-configuration.patch \ 141 file://0001-Force-host-toolchain-configuration.patch \
142 file://0002-chromium_overrides.cpp-Fix-build-with-plugins-and-oz.patch \
143" 143"
144SRC_URI_append_libc-musl = "\ 144SRC_URI_append_libc-musl = "\
145 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 145 file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
146 file://0003-musl-link-against-libexecinfo.patch \ 146 file://0004-musl-link-against-libexecinfo.patch \
147" 147"
148 148
149# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based 149# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based
150# 69-based.meta-qt5.1 150# 69-based.meta-qt5.2
151SRC_URI += " \ 151SRC_URI += " \
152 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 152 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
153 file://chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
154 file://chromium/0003-chromium-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \
153" 155"
154 156
155SRC_URI_append_libc-musl = "\ 157SRC_URI_append_libc-musl = "\
156 file://chromium/0002-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 158 file://chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
157 file://chromium/0003-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 159 file://chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
158 file://chromium/0004-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 160 file://chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
159 file://chromium/0005-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 161 file://chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
160 file://chromium/0006-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 162 file://chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
161 file://chromium/0007-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 163 file://chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
162 file://chromium/0008-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 164 file://chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
163 file://chromium/0009-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 165 file://chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
164 file://chromium/0010-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 166 file://chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
165 file://chromium/0011-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \ 167 file://chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
166 file://chromium/0012-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \ 168 file://chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
167 file://chromium/0013-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \ 169 file://chromium/0015-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
170 file://chromium/0016-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
168" 171"
169 172
170SRCREV_qtwebengine = "4f1e0003d98116e33a847360e0e95c46daae25fc" 173SRCREV_qtwebengine = "4f1e0003d98116e33a847360e0e95c46daae25fc"