diff options
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index a1b38de2..8f901ad7 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -46,3 +46,20 @@ BBCLASSEXTEND =+ "native nativesdk" | |||
46 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" | 46 | LDFLAGS_append_x86 = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" |
47 | 47 | ||
48 | SRC_URI += "file://0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch" | 48 | SRC_URI += "file://0001-Revert-use-new-feature-name-xkbcommon_evdev-xkbcommo.patch" |
49 | |||
50 | # Since version 5.11.2 some private headers are not installed. Work around | ||
51 | # until fixed upstream. See https://bugreports.qt.io/browse/QTBUG-71340 for | ||
52 | # further details | ||
53 | do_install_append() { | ||
54 | if [ -d "${B}/src/client" ]; then | ||
55 | upstream_pv=`echo "${PV}" | sed 's:+git.*::g'` | ||
56 | for header in `find ${B}/src/client -name '*wayland-*.h'`; do | ||
57 | header_base=`basename $header` | ||
58 | dest="${D}${includedir}/QtWaylandClient/$upstream_pv/QtWaylandClient/private/$header_base" | ||
59 | if [ ! -e "$dest" ]; then | ||
60 | echo "Manual install: $header_base to $dest" | ||
61 | install -m 644 "$header" "$dest" | ||
62 | fi | ||
63 | done | ||
64 | fi | ||
65 | } | ||