diff options
-rw-r--r-- | recipes-qt/qsiv/qsiv_1.1.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-qt/qsiv/qsiv_1.1.bb b/recipes-qt/qsiv/qsiv_1.1.bb new file mode 100644 index 00000000..bb2efa69 --- /dev/null +++ b/recipes-qt/qsiv/qsiv_1.1.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "Qt Simple Image Viewer" | ||
2 | DESCRIPTION = "A simple image viewer using a mix of C++ and qml code for demonstration." | ||
3 | LICENSE = "GPL-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=11c7965a9059e287de5d93b98adf6d1a" | ||
5 | DEPENDS = "qtdeclarative" | ||
6 | |||
7 | SRCREV = "7b9810b0f02f9ac74fae3ead6e2e9fb5c1382173" | ||
8 | SRC_URI = "git://code.ossystems.com.br/qt/qsiv;protocol=http" | ||
9 | |||
10 | S = "${WORKDIR}/git" | ||
11 | |||
12 | inherit qmake5 | ||
13 | |||
14 | EXTRA_QMAKEVARS_PRE += "target.path=${libdir}/${P}" | ||
15 | |||
16 | do_install_append() { | ||
17 | install -d ${D}${bindir} | ||
18 | echo "#!/bin/sh" > ${D}${bindir}/qsiv | ||
19 | echo "export QML_IMPORT_PATH=${libdir}/${P}/qml/qsiv" >> ${D}${bindir}/qsiv | ||
20 | echo "export QML2_IMPORT_PATH=${libdir}/${P}/qml/qsiv" >> ${D}${bindir}/qsiv | ||
21 | echo "${libdir}/${P}/qsiv \$* " >> ${D}${bindir}/qsiv | ||
22 | chmod +x ${D}${bindir}/qsiv | ||
23 | } | ||
24 | |||
25 | FILES_${PN} += "${libdir}/${P}" | ||
26 | RDEPENDS_${PN} += "qtdeclarative-qmlplugins" | ||
27 | |||
28 | FILES_${PN}-dbg += "${libdir}/${P}/.debug" | ||