diff options
-rw-r--r-- | recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch | 30 | ||||
-rw-r--r-- | recipes-qt/qt5/qtdeclarative_git.bb | 1 |
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch b/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch new file mode 100644 index 00000000..d803a294 --- /dev/null +++ b/recipes-qt/qt5/qtdeclarative/0001-qmldebug-Include-limits-header.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From ab263a3e79a36d3e6536adc900b296cdf27f09ae Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Thu, 4 Mar 2021 14:37:06 -0800 | ||
4 | Subject: [PATCH] qmldebug: Include limits header | ||
5 | |||
6 | this is needed to solve | ||
7 | qmldebug/qqmlprofilerevent_p.h:314:65: error: 'numeric_limits' is not a member of 'std' | ||
8 | |||
9 | Its exposed bu gcc11 | ||
10 | |||
11 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
12 | --- | ||
13 | src/qmldebug/qqmlprofilerevent_p.h | 1 + | ||
14 | 1 file changed, 1 insertion(+) | ||
15 | |||
16 | diff --git a/src/qmldebug/qqmlprofilerevent_p.h b/src/qmldebug/qqmlprofilerevent_p.h | ||
17 | index a7e37d1964..f778628f8c 100644 | ||
18 | --- a/src/qmldebug/qqmlprofilerevent_p.h | ||
19 | +++ b/src/qmldebug/qqmlprofilerevent_p.h | ||
20 | @@ -47,6 +47,7 @@ | ||
21 | #include <QtCore/qvarlengtharray.h> | ||
22 | #include <QtCore/qmetatype.h> | ||
23 | |||
24 | +#include <limits> | ||
25 | #include <initializer_list> | ||
26 | #include <type_traits> | ||
27 | |||
28 | -- | ||
29 | 2.30.1 | ||
30 | |||
diff --git a/recipes-qt/qt5/qtdeclarative_git.bb b/recipes-qt/qt5/qtdeclarative_git.bb index 05f6327c..1bbcb57c 100644 --- a/recipes-qt/qt5/qtdeclarative_git.bb +++ b/recipes-qt/qt5/qtdeclarative_git.bb | |||
@@ -17,6 +17,7 @@ LIC_FILES_CHKSUM = " \ | |||
17 | SRC_URI += " \ | 17 | SRC_URI += " \ |
18 | file://0001-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-locate-qmlca.patch \ | 18 | file://0001-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-locate-qmlca.patch \ |
19 | file://0001-yarr-Include-limits-for-numeric_limits.patch \ | 19 | file://0001-yarr-Include-limits-for-numeric_limits.patch \ |
20 | file://0001-qmldebug-Include-limits-header.patch \ | ||
20 | " | 21 | " |
21 | 22 | ||
22 | LDFLAGS_append_riscv64 = " -pthread" | 23 | LDFLAGS_append_riscv64 = " -pthread" |