diff options
-rw-r--r-- | recipes-qt/qt5/nativesdk-qtbase_git.bb | 1 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 1 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch | 48 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase_git.bb | 1 |
4 files changed, 51 insertions, 0 deletions
diff --git a/recipes-qt/qt5/nativesdk-qtbase_git.bb b/recipes-qt/qt5/nativesdk-qtbase_git.bb index b769c9fa..594173aa 100644 --- a/recipes-qt/qt5/nativesdk-qtbase_git.bb +++ b/recipes-qt/qt5/nativesdk-qtbase_git.bb | |||
@@ -43,6 +43,7 @@ SRC_URI += "\ | |||
43 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ | 43 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ |
44 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ | 44 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ |
45 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ | 45 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ |
46 | file://0021-qfloat16-Include-limits-header.patch \ | ||
46 | " | 47 | " |
47 | 48 | ||
48 | # common for qtbase-native and nativesdk-qtbase | 49 | # common for qtbase-native and nativesdk-qtbase |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index 8effb0af..d210e222 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -38,6 +38,7 @@ SRC_URI += "\ | |||
38 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ | 38 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ |
39 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ | 39 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ |
40 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ | 40 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ |
41 | file://0021-qfloat16-Include-limits-header.patch \ | ||
41 | " | 42 | " |
42 | 43 | ||
43 | # common for qtbase-native and nativesdk-qtbase | 44 | # common for qtbase-native and nativesdk-qtbase |
diff --git a/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch b/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch new file mode 100644 index 00000000..e781392d --- /dev/null +++ b/recipes-qt/qt5/qtbase/0021-qfloat16-Include-limits-header.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From f680222892b44b3c1de129dc086613c6fe025c2d Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 2 Mar 2021 13:18:47 -0800 | ||
4 | Subject: [PATCH] qfloat16: Include <limits> header | ||
5 | |||
6 | gcc11 complains | ||
7 | error: 'numeric_limits' is not a class template | ||
8 | | 344 | template<> class numeric_limits<const QT_PREPEND_NAMESPACE(qfloat16)> | ||
9 | |||
10 | This is because its missing right header which perhaps is included | ||
11 | implicitly in older compilers | ||
12 | |||
13 | Upstream-Status: Pending | ||
14 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
15 | --- | ||
16 | src/corelib/global/qfloat16.h | 1 + | ||
17 | 1 file changed, 1 insertion(+) | ||
18 | |||
19 | --- a/src/corelib/global/qfloat16.h | ||
20 | +++ b/src/corelib/global/qfloat16.h | ||
21 | @@ -44,6 +44,7 @@ | ||
22 | #include <QtCore/qglobal.h> | ||
23 | #include <QtCore/qmetatype.h> | ||
24 | #include <string.h> | ||
25 | +#include <limits> | ||
26 | |||
27 | #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__) | ||
28 | // All processors that support AVX2 do support F16C too. That doesn't mean | ||
29 | --- a/src/corelib/text/qbytearraymatcher.h | ||
30 | +++ b/src/corelib/text/qbytearraymatcher.h | ||
31 | @@ -40,6 +40,7 @@ | ||
32 | #ifndef QBYTEARRAYMATCHER_H | ||
33 | #define QBYTEARRAYMATCHER_H | ||
34 | |||
35 | +#include <limits> | ||
36 | #include <QtCore/qbytearray.h> | ||
37 | |||
38 | QT_BEGIN_NAMESPACE | ||
39 | --- a/src/corelib/tools/qoffsetstringarray_p.h | ||
40 | +++ b/src/corelib/tools/qoffsetstringarray_p.h | ||
41 | @@ -55,6 +55,7 @@ | ||
42 | |||
43 | #include <tuple> | ||
44 | #include <array> | ||
45 | +#include <limits> | ||
46 | |||
47 | QT_BEGIN_NAMESPACE | ||
48 | |||
diff --git a/recipes-qt/qt5/qtbase_git.bb b/recipes-qt/qt5/qtbase_git.bb index daaa1dce..e845dfe0 100644 --- a/recipes-qt/qt5/qtbase_git.bb +++ b/recipes-qt/qt5/qtbase_git.bb | |||
@@ -34,6 +34,7 @@ SRC_URI += "\ | |||
34 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ | 34 | file://0018-tst_qpainter-FE_-macros-are-not-defined-for-every-pl.patch \ |
35 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ | 35 | file://0019-Define-__NR_futex-if-it-does-not-exist.patch \ |
36 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ | 36 | file://0020-Revert-Fix-workaround-in-pthread-destructor.patch \ |
37 | file://0021-qfloat16-Include-limits-header.patch \ | ||
37 | " | 38 | " |
38 | 39 | ||
39 | # Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with | 40 | # Disable LTO for now, QT5 patches are being worked upstream, perhaps revisit with |