diff options
-rw-r--r-- | recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch | 62 | ||||
-rw-r--r-- | recipes-qt/maliit/maliit-framework-qt5_git.bb | 1 |
2 files changed, 63 insertions, 0 deletions
diff --git a/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch b/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch new file mode 100644 index 00000000..d86be1e1 --- /dev/null +++ b/recipes-qt/maliit/maliit-framework-qt5/0001-Fix-test-installations.patch | |||
@@ -0,0 +1,62 @@ | |||
1 | From 78a4b12b64c26f29e64fe56801e92d1e76f362b0 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@qt.io> | ||
3 | Date: Fri, 16 Aug 2019 15:08:41 +0300 | ||
4 | Subject: [PATCH] Fix test installations | ||
5 | |||
6 | Qmake won't ignore install errors anymore. | ||
7 | |||
8 | Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> | ||
9 | --- | ||
10 | .../ut_mattributeextensionmanager.pro | 7 ++++--- | ||
11 | tests/ut_mimpluginmanager/ut_mimpluginmanager.pro | 7 ++++--- | ||
12 | .../ut_mimpluginmanagerconfig.pro | 3 --- | ||
13 | 3 files changed, 8 insertions(+), 9 deletions(-) | ||
14 | |||
15 | diff --git a/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro b/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro | ||
16 | index 22280882..d0c390ef 100644 | ||
17 | --- a/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro | ||
18 | +++ b/tests/ut_mattributeextensionmanager/ut_mattributeextensionmanager.pro | ||
19 | @@ -13,9 +13,10 @@ CONFIG += plugin | ||
20 | include($$TOP_DIR/src/libmaliit-plugins.pri) | ||
21 | include($$TOP_DIR/connection/libmaliit-connection.pri) | ||
22 | |||
23 | -target.files += \ | ||
24 | - $$TARGET \ | ||
25 | +extra.files += \ | ||
26 | toolbar1.xml \ | ||
27 | - toolbar2.xml \ | ||
28 | + toolbar2.xml | ||
29 | +extra.path = $$target.path | ||
30 | +INSTALLS += extra | ||
31 | |||
32 | include(../common_check.pri) | ||
33 | diff --git a/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro b/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro | ||
34 | index 19e68e6a..44e0fa0f 100644 | ||
35 | --- a/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro | ||
36 | +++ b/tests/ut_mimpluginmanager/ut_mimpluginmanager.pro | ||
37 | @@ -17,9 +17,10 @@ include($$TOP_DIR/src/libmaliit-plugins.pri) | ||
38 | # For MImInputContextConnection pulled in by TestInputMethodHost | ||
39 | include($$TOP_DIR/connection/libmaliit-connection.pri) | ||
40 | |||
41 | -target.files += \ | ||
42 | - $$TARGET \ | ||
43 | +extra.files += \ | ||
44 | toolbar1.xml \ | ||
45 | - toolbar2.xml \ | ||
46 | + toolbar2.xml | ||
47 | +extra.path = $$target.path | ||
48 | +INSTALLS += extra | ||
49 | |||
50 | include(../common_check.pri) | ||
51 | diff --git a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro | ||
52 | index 739ceef6..e0b363c8 100644 | ||
53 | --- a/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro | ||
54 | +++ b/tests/ut_mimpluginmanagerconfig/ut_mimpluginmanagerconfig.pro | ||
55 | @@ -17,7 +17,4 @@ include($$TOP_DIR/src/libmaliit-plugins.pri) | ||
56 | # For MImInputContextConnection pulled in by TestInputMethodHost | ||
57 | include($$TOP_DIR/connection/libmaliit-connection.pri) | ||
58 | |||
59 | -target.files += \ | ||
60 | - $$TARGET \ | ||
61 | - | ||
62 | include(../common_check.pri) | ||
diff --git a/recipes-qt/maliit/maliit-framework-qt5_git.bb b/recipes-qt/maliit/maliit-framework-qt5_git.bb index c767d2a1..1f0dc8d6 100644 --- a/recipes-qt/maliit/maliit-framework-qt5_git.bb +++ b/recipes-qt/maliit/maliit-framework-qt5_git.bb | |||
@@ -12,6 +12,7 @@ SRC_URI = "git://github.com/maliit/framework.git;branch=master \ | |||
12 | file://0001-config.pri-Use-O1-optimization-in-DEBUG-flags.patch \ | 12 | file://0001-config.pri-Use-O1-optimization-in-DEBUG-flags.patch \ |
13 | file://0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch \ | 13 | file://0001-Drop-tr1-namespace-its-not-there-in-c-11-and-newer.patch \ |
14 | file://0001-examples-plugins-Replace-obsolete-screenGeometry.patch \ | 14 | file://0001-examples-plugins-Replace-obsolete-screenGeometry.patch \ |
15 | file://0001-Fix-test-installations.patch \ | ||
15 | " | 16 | " |
16 | 17 | ||
17 | SRCREV = "60b1b10de14f932420313c547ab801daf522d539" | 18 | SRCREV = "60b1b10de14f932420313c547ab801daf522d539" |