diff options
-rw-r--r-- | recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch | 38 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb | 6 |
2 files changed, 42 insertions, 2 deletions
diff --git a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch new file mode 100644 index 00000000..ff0eb56f --- /dev/null +++ b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch/0001-include-errno.h-for-errno-definition.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From 2486c9ecc1db12132ee8c77ed69b1d301e75786b Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Fri, 1 Feb 2019 23:35:24 -0800 | ||
4 | Subject: [PATCH] include errno.h for errno definition | ||
5 | |||
6 | This fixes errors with clang/libc++ | ||
7 | |||
8 | Upstream-Status: Pending | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | vboxtouch/setshape.cpp | 1 + | ||
12 | vboxtouch/vboxtouch.cpp | 1 + | ||
13 | 2 files changed, 2 insertions(+) | ||
14 | |||
15 | diff --git a/vboxtouch/setshape.cpp b/vboxtouch/setshape.cpp | ||
16 | index 092f888..4dd25a1 100644 | ||
17 | --- a/vboxtouch/setshape.cpp | ||
18 | +++ b/vboxtouch/setshape.cpp | ||
19 | @@ -24,6 +24,7 @@ | ||
20 | #include <QByteArray> | ||
21 | #include <QDebug> | ||
22 | |||
23 | +#include <errno.h> | ||
24 | #include <stdint.h> | ||
25 | #include <string.h> | ||
26 | |||
27 | diff --git a/vboxtouch/vboxtouch.cpp b/vboxtouch/vboxtouch.cpp | ||
28 | index 345fdcb..ffe1d50 100644 | ||
29 | --- a/vboxtouch/vboxtouch.cpp | ||
30 | +++ b/vboxtouch/vboxtouch.cpp | ||
31 | @@ -32,6 +32,7 @@ | ||
32 | |||
33 | #include <qpa/qwindowsysteminterface.h> | ||
34 | |||
35 | +#include <errno.h> | ||
36 | #include <fcntl.h> | ||
37 | #include <string.h> | ||
38 | #include <unistd.h> | ||
diff --git a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb index 1f29dcfe..4e83c267 100644 --- a/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb +++ b/recipes-qt/qt5/qt5-plugin-generic-vboxtouch_git.bb | |||
@@ -16,7 +16,10 @@ DEPENDS = "qtbase" | |||
16 | # Needed with gcc-5.2 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65801 | 16 | # Needed with gcc-5.2 https://gcc.gnu.org/bugzilla/show_bug.cgi?id=65801 |
17 | CXXFLAGS += "-Wno-narrowing" | 17 | CXXFLAGS += "-Wno-narrowing" |
18 | 18 | ||
19 | SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git" | 19 | SRC_URI = "git://github.com/nemomobile/qt5-plugin-generic-vboxtouch.git \ |
20 | file://0001-VirtualboxTouchScreenHandler-initialize-m_mouse.patch;patchdir=.. \ | ||
21 | file://0001-include-errno.h-for-errno-definition.patch;patchdir=.. \ | ||
22 | " | ||
20 | SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb" | 23 | SRCREV = "3f2bdb5a1d346f02d5ab185522271ba2288a42bb" |
21 | S = "${WORKDIR}/git/vboxtouch" | 24 | S = "${WORKDIR}/git/vboxtouch" |
22 | 25 | ||
@@ -25,4 +28,3 @@ inherit qmake5 | |||
25 | FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/generic/libvboxtouchplugin.so" | 28 | FILES_${PN} += "${OE_QMAKE_PATH_PLUGINS}/generic/libvboxtouchplugin.so" |
26 | FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/cmake/*" | 29 | FILES_${PN}-dev += "${OE_QMAKE_PATH_LIBS}/cmake/*" |
27 | 30 | ||
28 | SRC_URI += "file://0001-VirtualboxTouchScreenHandler-initialize-m_mouse.patch;patchdir=.." | ||