diff options
-rw-r--r-- | recipes-qt/qt5/nativesdk-qttools_git.bb | 42 | ||||
-rw-r--r-- | recipes-qt/qt5/qttools-native_git.bb | 24 | ||||
-rw-r--r-- | recipes-qt/qt5/qttools_git.bb | 10 |
3 files changed, 9 insertions, 67 deletions
diff --git a/recipes-qt/qt5/nativesdk-qttools_git.bb b/recipes-qt/qt5/nativesdk-qttools_git.bb deleted file mode 100644 index b217da1f..00000000 --- a/recipes-qt/qt5/nativesdk-qttools_git.bb +++ /dev/null | |||
@@ -1,42 +0,0 @@ | |||
1 | LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)" | ||
2 | LIC_FILES_CHKSUM = " \ | ||
3 | file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \ | ||
4 | file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \ | ||
5 | file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \ | ||
6 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | ||
7 | " | ||
8 | |||
9 | QT_MODULE = "qttools" | ||
10 | |||
11 | DEPENDS = "nativesdk-qtbase qtbase-native" | ||
12 | |||
13 | require nativesdk-qt5.inc | ||
14 | require qt5-git.inc | ||
15 | |||
16 | SRC_URI += "file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch" | ||
17 | |||
18 | PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" | ||
19 | |||
20 | FILES_${PN}-dbg = " \ | ||
21 | ${OE_QMAKE_PATH_BINS}/.debug \ | ||
22 | " | ||
23 | |||
24 | FILES_${PN} = " \ | ||
25 | ${OE_QMAKE_PATH_BINS}/* \ | ||
26 | " | ||
27 | |||
28 | do_configure() { | ||
29 | ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S} CONFIG+=linguistonly | ||
30 | } | ||
31 | |||
32 | do_install() { | ||
33 | # Fix install paths for all | ||
34 | find -name "Makefile*" | xargs sed -i "s,(INSTALL_ROOT)${STAGING_DIR_HOST},(INSTALL_ROOT),g" | ||
35 | |||
36 | oe_runmake install INSTALL_ROOT=${D} | ||
37 | |||
38 | # remove things unused in nativesdk | ||
39 | rm -rf ${D}${libdir} | ||
40 | } | ||
41 | |||
42 | SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" | ||
diff --git a/recipes-qt/qt5/qttools-native_git.bb b/recipes-qt/qt5/qttools-native_git.bb deleted file mode 100644 index cb786978..00000000 --- a/recipes-qt/qt5/qttools-native_git.bb +++ /dev/null | |||
@@ -1,24 +0,0 @@ | |||
1 | DEPENDS = "qtbase-native" | ||
2 | |||
3 | LICENSE = "GFDL-1.3 & BSD & (LGPL-2.1 & Digia-Qt-LGPL-Exception-1.1 | LGPL-3.0)" | ||
4 | LIC_FILES_CHKSUM = " \ | ||
5 | file://LICENSE.LGPLv21;md5=58a180e1cf84c756c29f782b3a485c29 \ | ||
6 | file://LICENSE.LGPLv3;md5=c4fe8c6de4eef597feec6e90ed62e962 \ | ||
7 | file://LGPL_EXCEPTION.txt;md5=9625233da42f9e0ce9d63651a9d97654 \ | ||
8 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | ||
9 | " | ||
10 | |||
11 | QT_MODULE = "qttools" | ||
12 | |||
13 | require qt5-native.inc | ||
14 | require qt5-git.inc | ||
15 | |||
16 | do_configure() { | ||
17 | ${OE_QMAKE_QMAKE} ${OE_QMAKE_DEBUG_OUTPUT} -r ${S} CONFIG+=linguistonly | ||
18 | } | ||
19 | |||
20 | do_install() { | ||
21 | oe_runmake install INSTALL_ROOT=${D} | ||
22 | } | ||
23 | |||
24 | SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" | ||
diff --git a/recipes-qt/qt5/qttools_git.bb b/recipes-qt/qt5/qttools_git.bb index afc89849..a13fb747 100644 --- a/recipes-qt/qt5/qttools_git.bb +++ b/recipes-qt/qt5/qttools_git.bb | |||
@@ -9,9 +9,11 @@ LIC_FILES_CHKSUM = " \ | |||
9 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | 9 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ |
10 | " | 10 | " |
11 | 11 | ||
12 | DEPENDS += "qtbase qtdeclarative qtxmlpatterns" | 12 | DEPENDS += "qtbase" |
13 | DEPENDS_class-target = "qtdeclarative qtxmlpatterns" | ||
13 | 14 | ||
14 | SRC_URI += " \ | 15 | SRC_URI += " \ |
16 | file://0001-Allow-to-build-only-lrelease-lupdate-lconvert.patch \ | ||
15 | file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ | 17 | file://0002-assistant-help-fix-linking-of-dependent-libraries.patch \ |
16 | file://0003-add-noqtwebkit-configuration.patch \ | 18 | file://0003-add-noqtwebkit-configuration.patch \ |
17 | " | 19 | " |
@@ -20,8 +22,14 @@ FILES_${PN}-tools += "${datadir}/${QT_DIR_NAME}/phrasebooks" | |||
20 | FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples" | 22 | FILES_${PN}-examples = "${datadir}/${QT_DIR_NAME}/examples" |
21 | 23 | ||
22 | PACKAGECONFIG ??= "" | 24 | PACKAGECONFIG ??= "" |
25 | PACKAGECONFIG_class-native ??= "linguistonly" | ||
26 | PACKAGECONFIG_class-nativesdk ??= "linguistonly" | ||
27 | PACKAGECONFIG[linguistonly] = "" | ||
23 | PACKAGECONFIG[qtwebkit] = ",,qtwebkit" | 28 | PACKAGECONFIG[qtwebkit] = ",,qtwebkit" |
24 | 29 | ||
25 | EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" | 30 | EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'qtwebkit', '', 'CONFIG+=noqtwebkit', d)}" |
31 | EXTRA_QMAKEVARS_PRE += "${@base_contains('PACKAGECONFIG', 'linguistonly', 'CONFIG+=linguistonly', '', d)}" | ||
26 | 32 | ||
27 | SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" | 33 | SRCREV = "33c65366a7c3901d2aecfde3dbc485e1eac5c10c" |
34 | |||
35 | BBCLASSEXTEND = "native nativesdk" | ||