diff options
-rw-r--r-- | recipes-python/pyqt5/python-pyqt5_5.13.2.bb | 7 | ||||
-rw-r--r-- | recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb | 4 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebengine_git.bb | 9 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwebkit_git.bb | 9 |
4 files changed, 26 insertions, 3 deletions
diff --git a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb index b8b1d086..e051b156 100644 --- a/recipes-python/pyqt5/python-pyqt5_5.13.2.bb +++ b/recipes-python/pyqt5/python-pyqt5_5.13.2.bb | |||
@@ -1,6 +1,11 @@ | |||
1 | require python-pyqt5.inc | 1 | require python-pyqt5.inc |
2 | 2 | ||
3 | inherit pythonnative python-dir | 3 | inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative python-dir", "", d)} |
4 | |||
5 | python() { | ||
6 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
7 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') | ||
8 | } | ||
4 | 9 | ||
5 | DEPENDS += "sip sip-native python" | 10 | DEPENDS += "sip sip-native python" |
6 | 11 | ||
diff --git a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb index 44bdf18c..8ae0e9ef 100644 --- a/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb +++ b/recipes-qt/qt-kiosk-browser/qt-kiosk-browser_git.bb | |||
@@ -4,6 +4,10 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464" | |||
4 | LICENSE = "GPLv3" | 4 | LICENSE = "GPLv3" |
5 | 5 | ||
6 | DEPENDS = "qtwebengine" | 6 | DEPENDS = "qtwebengine" |
7 | python() { | ||
8 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
9 | raise bb.parse.SkipRecipe('qtwebengine dependency requires meta-python2 to be present.') | ||
10 | } | ||
7 | 11 | ||
8 | SRC_URI = " \ | 12 | SRC_URI = " \ |
9 | git://github.com/OSSystems/qt-kiosk-browser;protocol=https \ | 13 | git://github.com/OSSystems/qt-kiosk-browser;protocol=https \ |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index e42cf491..c00120b3 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -79,10 +79,17 @@ COMPATIBLE_MACHINE_aarch64 = "(.*)" | |||
79 | 79 | ||
80 | inherit qmake5 | 80 | inherit qmake5 |
81 | inherit gettext | 81 | inherit gettext |
82 | inherit pythonnative | ||
83 | inherit perlnative | 82 | inherit perlnative |
84 | inherit features_check | 83 | inherit features_check |
85 | 84 | ||
85 | inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)} | ||
86 | |||
87 | python() { | ||
88 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
89 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') | ||
90 | } | ||
91 | |||
92 | |||
86 | # Static builds of QtWebEngine aren't supported. | 93 | # Static builds of QtWebEngine aren't supported. |
87 | CONFLICT_DISTRO_FEATURES = "qt5-static" | 94 | CONFLICT_DISTRO_FEATURES = "qt5-static" |
88 | 95 | ||
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb index 6cc789f0..942e733a 100644 --- a/recipes-qt/qt5/qtwebkit_git.bb +++ b/recipes-qt/qt5/qtwebkit_git.bb | |||
@@ -18,7 +18,14 @@ SRC_URI += "\ | |||
18 | file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \ | 18 | file://0004-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \ |
19 | " | 19 | " |
20 | 20 | ||
21 | inherit cmake_qt5 perlnative pythonnative | 21 | inherit cmake_qt5 perlnative |
22 | |||
23 | inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "pythonnative", "", d)} | ||
24 | |||
25 | python() { | ||
26 | if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split(): | ||
27 | raise bb.parse.SkipRecipe('Requires meta-python2 to be present.') | ||
28 | } | ||
22 | 29 | ||
23 | # qemuarm build fails with: | 30 | # qemuarm build fails with: |
24 | # | {standard input}: Assembler messages: | 31 | # | {standard input}: Assembler messages: |