diff options
-rw-r--r-- | recipes-qt/qt5/qt5-native.inc | 7 | ||||
-rw-r--r-- | recipes-qt/qt5/qt5.inc | 8 | ||||
-rw-r--r-- | recipes-qt/qt5/qtbase-native_git.bb | 21 |
3 files changed, 15 insertions, 21 deletions
diff --git a/recipes-qt/qt5/qt5-native.inc b/recipes-qt/qt5/qt5-native.inc index 76816027..85350288 100644 --- a/recipes-qt/qt5/qt5-native.inc +++ b/recipes-qt/qt5/qt5-native.inc | |||
@@ -10,3 +10,10 @@ OE_QMAKE_PATH_DOCS = "${OE_QMAKE_PATH_QT_DOCS}" | |||
10 | OE_QMAKE_PATH_SETTINGS = "${OE_QMAKE_PATH_QT_SETTINGS}" | 10 | OE_QMAKE_PATH_SETTINGS = "${OE_QMAKE_PATH_QT_SETTINGS}" |
11 | OE_QMAKE_PATH_EXAMPLES = "${OE_QMAKE_PATH_QT_EXAMPLES}" | 11 | OE_QMAKE_PATH_EXAMPLES = "${OE_QMAKE_PATH_QT_EXAMPLES}" |
12 | OE_QMAKE_PATH_TESTS = "${OE_QMAKE_PATH_QT_TESTS}" | 12 | OE_QMAKE_PATH_TESTS = "${OE_QMAKE_PATH_QT_TESTS}" |
13 | |||
14 | # Regenerate header files when they are included in source tarball | ||
15 | # Otherwise cmake files don't set PRIVATE_HEADERS correctly | ||
16 | do_configure_prepend() { | ||
17 | rm -rf ${S}/include | ||
18 | mkdir -p ${S}/.git || true | ||
19 | } | ||
diff --git a/recipes-qt/qt5/qt5.inc b/recipes-qt/qt5/qt5.inc index 57ffe098..7e739c54 100644 --- a/recipes-qt/qt5/qt5.inc +++ b/recipes-qt/qt5/qt5.inc | |||
@@ -32,6 +32,14 @@ python __anonymous() { | |||
32 | d.setVar("PACKAGE_ARCH", tarch) | 32 | d.setVar("PACKAGE_ARCH", tarch) |
33 | } | 33 | } |
34 | 34 | ||
35 | |||
36 | # Regenerate header files when they are included in source tarball | ||
37 | # Otherwise cmake files don't set PRIVATE_HEADERS correctly | ||
38 | do_configure_prepend() { | ||
39 | rm -rf ${S}/include | ||
40 | mkdir -p ${S}/.git || true | ||
41 | } | ||
42 | |||
35 | PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmlplugins ${PN}-tools ${PN}-plugins ${PN}-mkspecs ${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples " | 43 | PACKAGES =. "${PN}-qmlplugins-dbg ${PN}-tools-dbg ${PN}-plugins-dbg ${PN}-qmlplugins ${PN}-tools ${PN}-plugins ${PN}-mkspecs ${PN}-examples-dev ${PN}-examples-staticdev ${PN}-examples-dbg ${PN}-examples " |
36 | 44 | ||
37 | # extra -dbg packages | 45 | # extra -dbg packages |
diff --git a/recipes-qt/qt5/qtbase-native_git.bb b/recipes-qt/qt5/qtbase-native_git.bb index ce823d26..471d95b3 100644 --- a/recipes-qt/qt5/qtbase-native_git.bb +++ b/recipes-qt/qt5/qtbase-native_git.bb | |||
@@ -1,27 +1,6 @@ | |||
1 | require qt5-git.inc | 1 | require qt5-git.inc |
2 | require ${PN}.inc | 2 | require ${PN}.inc |
3 | 3 | ||
4 | # common with target version | ||
5 | SRC_URI = "\ | ||
6 | git://qt.gitorious.org/qt/${QT_MODULE}.git;branch=${QT_MODULE_BRANCH} \ | ||
7 | file://0001-Add-linux-oe-g-platform.patch \ | ||
8 | file://0002-qlibraryinfo-allow-to-set-qt.conf-from-the-outside-u.patch \ | ||
9 | file://0003-Add-external-hostbindir-option.patch \ | ||
10 | file://0004-qt_functions-temporary-remove-isEmpty-check.patch \ | ||
11 | file://0005-configureapp-Prefix-default-LIBDIRS-and-INCDIRS-with.patch \ | ||
12 | file://0006-qt_module-Fix-pkgconfig-replacement.patch \ | ||
13 | file://0007-qt_module-Fix-paths-in-.prl-files.patch \ | ||
14 | file://0008-wayland-scanner-disable-silent-rules.patch \ | ||
15 | file://0009-configure-don-t-export-SYSTEM_VARIABLES-to-.qmake.va.patch \ | ||
16 | file://0010-configure.prf-Allow-to-add-extra-arguments-to-make.patch \ | ||
17 | file://0011-configure-make-pulseaudio-a-configurable-option.patch \ | ||
18 | file://0012-configure-make-alsa-a-configurable-option.patch \ | ||
19 | file://0013-configure-make-freetype-a-configurable-option.patch \ | ||
20 | file://0014-Use-OE_QMAKE_PATH_EXTERNAL_HOST_BINS-to-determine-pa.patch \ | ||
21 | " | ||
22 | |||
23 | SRC_URI += "file://0015-Always-build-uic.patch" | ||
24 | |||
25 | do_install_append() { | 4 | do_install_append() { |
26 | # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt) | 5 | # for modules which are still using syncqt and call qtPrepareTool(QMAKE_SYNCQT, syncqt) |
27 | # e.g. qt3d, qtwayland | 6 | # e.g. qt3d, qtwayland |