diff options
-rw-r--r-- | recipes-qt/qt5/ogl-runtime/0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch | 35 | ||||
-rw-r--r-- | recipes-qt/qt5/ogl-runtime_git.bb | 1 |
2 files changed, 36 insertions, 0 deletions
diff --git a/recipes-qt/qt5/ogl-runtime/0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch b/recipes-qt/qt5/ogl-runtime/0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch new file mode 100644 index 00000000..94ca4f5c --- /dev/null +++ b/recipes-qt/qt5/ogl-runtime/0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 84a9dd3f1bce450b3a6eb589ab9794178d74d1d7 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 7 Oct 2019 11:58:21 -0700 | ||
4 | Subject: [PATCH] Qt3DSSimpleTypes: make QT3DSU64 as unsigned long on linux as | ||
5 | well | ||
6 | |||
7 | linux 64bit platform defines uint64_t as unsigned long as well, which | ||
8 | inturn is used to define GLuint64, therefore its needed to be compatible | ||
9 | or else we get compile errors | ||
10 | |||
11 | src/render/backends/gl/Qt3DSRenderBackendGL3.cpp:754:80: error: cannot initialize a parameter of type 'GLuint64 *' (aka 'unsigned long *') with an lvalue of type 'qt3ds::QT3DSU64 *' (aka 'unsigned long long *') | ||
12 | | queryID, m_Conversion.fromQueryResultTypeToGL(resultType), params)); | ||
13 | |||
14 | Upstream-Status: Pending | ||
15 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
16 | --- | ||
17 | src/foundation/Qt3DSSimpleTypes.h | 2 +- | ||
18 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
19 | |||
20 | diff --git a/src/foundation/Qt3DSSimpleTypes.h b/src/foundation/Qt3DSSimpleTypes.h | ||
21 | index 05ac8d9..adb72e9 100644 | ||
22 | --- a/src/foundation/Qt3DSSimpleTypes.h | ||
23 | +++ b/src/foundation/Qt3DSSimpleTypes.h | ||
24 | @@ -54,7 +54,7 @@ typedef quint32 QT3DSU32; | ||
25 | typedef qint32 QT3DSI32; | ||
26 | |||
27 | // Android's definition of GLuint64 as unsigned long (64-bits) requires this workaround | ||
28 | -#if Q_PROCESSOR_WORDSIZE == 8 && (defined(Q_OS_ANDROID) || defined(Q_OS_INTEGRITY)) | ||
29 | +#if Q_PROCESSOR_WORDSIZE == 8 && (defined(Q_OS_ANDROID) || defined(Q_OS_INTEGRITY) || defined(Q_OS_LINUX)) | ||
30 | typedef unsigned long QT3DSU64; | ||
31 | #else | ||
32 | typedef quint64 QT3DSU64; | ||
33 | -- | ||
34 | 2.23.0 | ||
35 | |||
diff --git a/recipes-qt/qt5/ogl-runtime_git.bb b/recipes-qt/qt5/ogl-runtime_git.bb index 049f885a..97e25bc1 100644 --- a/recipes-qt/qt5/ogl-runtime_git.bb +++ b/recipes-qt/qt5/ogl-runtime_git.bb | |||
@@ -19,6 +19,7 @@ SRC_URI += " \ | |||
19 | file://0001-Fix-examples-build-error.patch \ | 19 | file://0001-Fix-examples-build-error.patch \ |
20 | file://0002-Fix-format-security-issues.patch \ | 20 | file://0002-Fix-format-security-issues.patch \ |
21 | file://0003-Fix-build-on-musl-libc.patch \ | 21 | file://0003-Fix-build-on-musl-libc.patch \ |
22 | file://0001-Qt3DSSimpleTypes-make-QT3DSU64-as-unsigned-long-on-l.patch \ | ||
22 | " | 23 | " |
23 | 24 | ||
24 | SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f" | 25 | SRCREV_ogl-runtime = "a41270dced230d90e0e07f2ebb880e4f97317a7f" |