diff options
5 files changed, 6 insertions, 59 deletions
diff --git a/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch b/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch deleted file mode 100644 index 6a2162f4..00000000 --- a/recipes-qt/qt5/qtwebengine-git/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 7d20d5e4584abce2353557c90e79ee0b3cdc330e Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Fri, 27 Feb 2015 19:51:55 +0100 | ||
4 | Subject: [PATCH 4/4] configure.prf: don't fail when libcap test fails | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | tools/qmake/mkspecs/features/configure.prf | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/tools/qmake/mkspecs/features/configure.prf b/tools/qmake/mkspecs/features/configure.prf | ||
12 | index 6e74b55..b91fde8 100644 | ||
13 | --- a/tools/qmake/mkspecs/features/configure.prf | ||
14 | +++ b/tools/qmake/mkspecs/features/configure.prf | ||
15 | @@ -20,7 +20,7 @@ defineTest(runConfigure) { | ||
16 | qtCompileTest($$test) | ||
17 | } | ||
18 | # libcap-dev package doesn't ship .pc files on Ubuntu. | ||
19 | - linux:!config_libcap:skipBuild("libcap appears to be missing") | ||
20 | + #linux:!config_libcap:skipBuild("libcap appears to be missing") | ||
21 | contains(QT_CONFIG, xcb) { | ||
22 | for(package, $$list("libdrm xcomposite xi xrandr")) { | ||
23 | !packagesExist($$package):skipBuild("Unmet dependency: $$package") | ||
24 | -- | ||
25 | 2.3.1 | ||
26 | |||
diff --git a/recipes-qt/qt5/qtwebengine.inc b/recipes-qt/qt5/qtwebengine.inc index 46060c08..a9c7005a 100644 --- a/recipes-qt/qt5/qtwebengine.inc +++ b/recipes-qt/qt5/qtwebengine.inc | |||
@@ -35,11 +35,12 @@ export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja" | |||
35 | 35 | ||
36 | do_configure() { | 36 | do_configure() { |
37 | # replace LD with CXX, to workaround a possible gyp inheritssue? | 37 | # replace LD with CXX, to workaround a possible gyp inheritssue? |
38 | LD="${CXX}" export LD | 38 | export LD="${CXX}" |
39 | CC="${CC}" export CC | 39 | export CC="${CC}" |
40 | CXX="${CXX}" export CXX | 40 | export CXX="${CXX}" |
41 | CC_host="gcc" export CC_host | 41 | export CC_host="gcc" |
42 | CXX_host="g++" export CXX_host | 42 | export CXX_host="g++" |
43 | export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}" | ||
43 | 44 | ||
44 | # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as | 45 | # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as |
45 | # arguments here | 46 | # arguments here |
diff --git a/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch b/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch deleted file mode 100644 index 71ee4fe7..00000000 --- a/recipes-qt/qt5/qtwebengine/0004-configure.prf-don-t-fail-when-libcap-test-fails.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From 1306df17fccb672e95911398740d48408488035a Mon Sep 17 00:00:00 2001 | ||
2 | From: Martin Jansa <Martin.Jansa@gmail.com> | ||
3 | Date: Fri, 27 Feb 2015 19:51:55 +0100 | ||
4 | Subject: [PATCH 4/4] configure.prf: don't fail when libcap test fails | ||
5 | |||
6 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
7 | --- | ||
8 | tools/qmake/mkspecs/features/configure.prf | 2 +- | ||
9 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
10 | |||
11 | diff --git a/tools/qmake/mkspecs/features/configure.prf b/tools/qmake/mkspecs/features/configure.prf | ||
12 | index 6e74b55..b91fde8 100644 | ||
13 | --- a/tools/qmake/mkspecs/features/configure.prf | ||
14 | +++ b/tools/qmake/mkspecs/features/configure.prf | ||
15 | @@ -20,7 +20,7 @@ defineTest(runConfigure) { | ||
16 | qtCompileTest($$test) | ||
17 | } | ||
18 | # libcap-dev package doesn't ship .pc files on Ubuntu. | ||
19 | - linux:!config_libcap:skipBuild("libcap appears to be missing") | ||
20 | + #linux:!config_libcap:skipBuild("libcap appears to be missing") | ||
21 | contains(QT_CONFIG, xcb) { | ||
22 | for(package, $$list("libdrm xcomposite xi xrandr")) { | ||
23 | !packagesExist($$package):skipBuild("Unmet dependency: $$package") | ||
24 | -- | ||
25 | 2.3.1 | ||
26 | |||
diff --git a/recipes-qt/qt5/qtwebengine_5.4.1.bb b/recipes-qt/qt5/qtwebengine_5.4.1.bb index 4b21f32c..92e8c048 100644 --- a/recipes-qt/qt5/qtwebengine_5.4.1.bb +++ b/recipes-qt/qt5/qtwebengine_5.4.1.bb | |||
@@ -8,6 +8,5 @@ SRC_URI += " \ | |||
8 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ | 8 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
9 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ | 9 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ |
10 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ | 10 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ |
11 | file://0004-configure.prf-don-t-fail-when-libcap-test-fails.patch \ | ||
12 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \ | 11 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \ |
13 | " | 12 | " |
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb index 450609d7..b451c37e 100644 --- a/recipes-qt/qt5/qtwebengine_git.bb +++ b/recipes-qt/qt5/qtwebengine_git.bb | |||
@@ -9,7 +9,6 @@ SRC_URI += " \ | |||
9 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ | 9 | file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ |
10 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ | 10 | file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ |
11 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ | 11 | file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ |
12 | file://0004-configure.prf-don-t-fail-when-libcap-test-fails.patch \ | ||
13 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \ | 12 | file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch \ |
14 | " | 13 | " |
15 | SRCREV_qtwebengine = "4eceed9ac0b646238e76d77569a619d4dc515ba5" | 14 | SRCREV_qtwebengine = "4eceed9ac0b646238e76d77569a619d4dc515ba5" |