summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtwebkit/0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch40
-rw-r--r--recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch204
-rw-r--r--recipes-qt/qt5/qtwebkit_git.bb5
3 files changed, 43 insertions, 206 deletions
diff --git a/recipes-qt/qt5/qtwebkit/0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch b/recipes-qt/qt5/qtwebkit/0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch
new file mode 100644
index 00000000..8c718b47
--- /dev/null
+++ b/recipes-qt/qt5/qtwebkit/0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch
@@ -0,0 +1,40 @@
1From c00c61a42f9076aecad195b7f72b7db9b3601181 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 24 Sep 2018 02:11:10 -0700
4Subject: [PATCH] PlatformQt.cmake: Do not generate hardcoded include paths
5
6If we do not use this define,then it falls into else case which
7generated .pri files with /usr/include and so on for includes and
8compiler does not like specifying absolute include paths pointing to
9build host includes
10
11Signed-off-by: Khem Raj <raj.khem@gmail.com>
12---
13 Source/WebKit/PlatformQt.cmake | 4 ++--
14 1 file changed, 2 insertions(+), 2 deletions(-)
15
16diff --git a/Source/WebKit/PlatformQt.cmake b/Source/WebKit/PlatformQt.cmake
17index 3792def6f..b6cb36bb1 100644
18--- a/Source/WebKit/PlatformQt.cmake
19+++ b/Source/WebKit/PlatformQt.cmake
20@@ -510,7 +510,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
21 install(FILES ${WebKit_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
22 endif ()
23
24-if (KDE_INSTALL_USE_QT_SYS_PATHS)
25+if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE)
26 set(WebKit_PRI_ARGUMENTS
27 BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE"
28 LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE"
29@@ -734,7 +734,7 @@ if (NOT MACOS_BUILD_FRAMEWORKS)
30 install(FILES ${WebKitWidgets_PKGCONFIG_FILENAME} DESTINATION ${ECM_PKGCONFIG_INSTALL_DIR} COMPONENT Data)
31 endif ()
32
33-if (KDE_INSTALL_USE_QT_SYS_PATHS)
34+if (KDE_INSTALL_USE_QT_SYS_PATHS OR CROSS_COMPILE)
35 set(WebKitWidgets_PRI_ARGUMENTS
36 BIN_INSTALL_DIR "$$QT_MODULE_BIN_BASE"
37 LIB_INSTALL_DIR "$$QT_MODULE_LIB_BASE"
38--
392.19.0
40
diff --git a/recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch b/recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch
deleted file mode 100644
index c24eb69e..00000000
--- a/recipes-qt/qt5/qtwebkit/0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch
+++ /dev/null
@@ -1,204 +0,0 @@
1From ef1b87e4ce8db720a4d7f5ee80fec4388dc3b086 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 24 Aug 2018 07:13:39 +0000
4Subject: [PATCH] WebKitMacros: Append to -I and not to -isystem
5
6gcc-6 has now introduced stdlib.h in libstdc++ for better
7compliance and its including the C library stdlib.h using
8include_next which is sensitive to order of system header
9include paths. Its infact better to not tinker with the
10system header include paths at all. Since adding /usr/include
11to -system is redundant and compiler knows about it moreover
12now with gcc6 it interferes with compiler's functioning
13and ends up with compile errors e.g.
14
15/usr/include/c++/6.0.0/cstdlib:75:25: fatal error: stdlib.h: No such file or directory
16
17Upstream-Status: Pending
18
19Signed-off-by: Khem Raj <raj.khem@gmail.com>
20---
21 Source/JavaScriptCore/shell/CMakeLists.txt | 2 +-
22 Source/WebKit/qt/declarative/CMakeLists.txt | 2 +-
23 Source/WebKit/qt/tests/CMakeLists.txt | 2 +-
24 Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt | 2 +-
25 Source/cmake/WebKitMacros.cmake | 2 +-
26 Tools/DumpRenderTree/CMakeLists.txt | 2 +-
27 Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt | 2 +-
28 Tools/ImageDiff/CMakeLists.txt | 2 +-
29 Tools/MiniBrowser/qt/CMakeLists.txt | 2 +-
30 Tools/QtTestBrowser/CMakeLists.txt | 2 +-
31 Tools/TestWebKitAPI/PlatformQt.cmake | 2 +-
32 Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt | 2 +-
33 Tools/WebKitTestRunner/CMakeLists.txt | 2 +-
34 13 files changed, 13 insertions(+), 13 deletions(-)
35
36diff --git a/Source/JavaScriptCore/shell/CMakeLists.txt b/Source/JavaScriptCore/shell/CMakeLists.txt
37index 27d81336f..9480f6d88 100644
38--- a/Source/JavaScriptCore/shell/CMakeLists.txt
39+++ b/Source/JavaScriptCore/shell/CMakeLists.txt
40@@ -20,7 +20,7 @@ WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS()
41
42 WEBKIT_WRAP_SOURCELIST(${JSC_SOURCES})
43 include_directories(./ ${JavaScriptCore_INCLUDE_DIRECTORIES})
44-include_directories(SYSTEM ${JavaScriptCore_SYSTEM_INCLUDE_DIRECTORIES})
45+include_directories(${JavaScriptCore_SYSTEM_INCLUDE_DIRECTORIES})
46 add_executable(jsc ${JSC_SOURCES})
47 target_link_libraries(jsc ${JSC_LIBRARIES})
48 set_target_properties(jsc PROPERTIES FOLDER "JavaScriptCore")
49diff --git a/Source/WebKit/qt/declarative/CMakeLists.txt b/Source/WebKit/qt/declarative/CMakeLists.txt
50index e1ba22bc1..84cb56544 100644
51--- a/Source/WebKit/qt/declarative/CMakeLists.txt
52+++ b/Source/WebKit/qt/declarative/CMakeLists.txt
53@@ -15,7 +15,7 @@ include_directories(
54
55 ${WTF_DIR}
56 )
57-include_directories(SYSTEM
58+include_directories(
59 ${ICU_INCLUDE_DIRS}
60 ${Qt5Quick_INCLUDE_DIRS}
61 ${Qt5Quick_PRIVATE_INCLUDE_DIRS}
62diff --git a/Source/WebKit/qt/tests/CMakeLists.txt b/Source/WebKit/qt/tests/CMakeLists.txt
63index 3dc6af1d5..d821f0284 100644
64--- a/Source/WebKit/qt/tests/CMakeLists.txt
65+++ b/Source/WebKit/qt/tests/CMakeLists.txt
66@@ -7,7 +7,7 @@ include_directories(
67 "${WEBKIT_DIR}/qt/WidgetApi"
68 )
69
70-include_directories(SYSTEM
71+include_directories(
72 ${ICU_INCLUDE_DIRS}
73 ${Qt5Gui_PRIVATE_INCLUDE_DIRS}
74 ${Qt5Widgets_INCLUDE_DIRS}
75diff --git a/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt b/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
76index 210342ef5..bfc768fa0 100644
77--- a/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
78+++ b/Source/WebKit2/UIProcess/API/qt/tests/CMakeLists.txt
79@@ -4,7 +4,7 @@ include_directories(
80 "${WEBKIT_DIR}/qt/Api"
81 )
82
83-include_directories(SYSTEM
84+include_directories(
85 ${Qt5Quick_INCLUDE_DIRS}
86 ${Qt5Quick_PRIVATE_INCLUDE_DIRS}
87 ${Qt5QuickTest_INCLUDE_DIRS}
88diff --git a/Source/cmake/WebKitMacros.cmake b/Source/cmake/WebKitMacros.cmake
89index 07e31432a..a1e58873f 100644
90--- a/Source/cmake/WebKitMacros.cmake
91+++ b/Source/cmake/WebKitMacros.cmake
92@@ -260,7 +260,7 @@ endmacro()
93
94 macro(WEBKIT_FRAMEWORK _target)
95 include_directories(${${_target}_INCLUDE_DIRECTORIES})
96- include_directories(SYSTEM ${${_target}_SYSTEM_INCLUDE_DIRECTORIES})
97+ include_directories(${${_target}_SYSTEM_INCLUDE_DIRECTORIES})
98 add_library(${_target} ${${_target}_LIBRARY_TYPE}
99 ${${_target}_HEADERS}
100 ${${_target}_SOURCES}
101diff --git a/Tools/DumpRenderTree/CMakeLists.txt b/Tools/DumpRenderTree/CMakeLists.txt
102index 4a726ccaf..cd0c5e303 100644
103--- a/Tools/DumpRenderTree/CMakeLists.txt
104+++ b/Tools/DumpRenderTree/CMakeLists.txt
105@@ -115,7 +115,7 @@ list(APPEND TestNetscapePlugin_LIBRARIES
106 WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS()
107
108 include_directories(${DumpRenderTree_INCLUDE_DIRECTORIES})
109-include_directories(SYSTEM ${DumpRenderTree_SYSTEM_INCLUDE_DIRECTORIES})
110+include_directories(${DumpRenderTree_SYSTEM_INCLUDE_DIRECTORIES})
111
112 add_executable(DumpRenderTree ${DumpRenderTree_SOURCES})
113 target_link_libraries(DumpRenderTree ${DumpRenderTree_LIBRARIES})
114diff --git a/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt b/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
115index c431667b2..6dff24475 100644
116--- a/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
117+++ b/Tools/DumpRenderTree/TestNetscapePlugIn/CMakeLists.txt
118@@ -42,7 +42,7 @@ set(WebKitTestNetscapePlugin_SYSTEM_INCLUDE_DIRECTORIES
119 )
120
121 include_directories(${WebKitTestNetscapePlugin_INCLUDE_DIRECTORIES})
122-include_directories(SYSTEM ${WebKitTestNetscapePlugin_SYSTEM_INCLUDE_DIRECTORIES})
123+include_directories(${WebKitTestNetscapePlugin_SYSTEM_INCLUDE_DIRECTORIES})
124
125 set(WebKitTestNetscapePlugin_LIBRARIES
126 ${X11_LIBRARIES}
127diff --git a/Tools/ImageDiff/CMakeLists.txt b/Tools/ImageDiff/CMakeLists.txt
128index 6ce4ed522..4dd6c4adf 100644
129--- a/Tools/ImageDiff/CMakeLists.txt
130+++ b/Tools/ImageDiff/CMakeLists.txt
131@@ -14,7 +14,7 @@ set(IMAGE_DIFF_LIBRARIES
132 WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS()
133
134 include_directories(${IMAGE_DIFF_INCLUDE_DIRECTORIES})
135-include_directories(SYSTEM ${IMAGE_DIFF_SYSTEM_INCLUDE_DIRECTORIES})
136+include_directories(${IMAGE_DIFF_SYSTEM_INCLUDE_DIRECTORIES})
137 add_executable(ImageDiff ${IMAGE_DIFF_SOURCES})
138 target_link_libraries(ImageDiff ${IMAGE_DIFF_LIBRARIES})
139 set_target_properties(ImageDiff PROPERTIES FOLDER "Tools")
140diff --git a/Tools/MiniBrowser/qt/CMakeLists.txt b/Tools/MiniBrowser/qt/CMakeLists.txt
141index 68dd13c8b..b491df2a8 100644
142--- a/Tools/MiniBrowser/qt/CMakeLists.txt
143+++ b/Tools/MiniBrowser/qt/CMakeLists.txt
144@@ -64,7 +64,7 @@ if (ENABLE_TEST_SUPPORT)
145 endif ()
146
147 include_directories(${MiniBrowser_INCLUDE_DIRECTORIES})
148-include_directories(SYSTEM ${MiniBrowser_SYSTEM_INCLUDE_DIRECTORIES})
149+include_directories(${MiniBrowser_SYSTEM_INCLUDE_DIRECTORIES})
150 add_executable(MiniBrowser ${MiniBrowser_SOURCES})
151 target_link_libraries(MiniBrowser ${MiniBrowser_LIBRARIES})
152 set_target_properties(MiniBrowser PROPERTIES FOLDER "Tools" AUTOMOC ON)
153diff --git a/Tools/QtTestBrowser/CMakeLists.txt b/Tools/QtTestBrowser/CMakeLists.txt
154index ccd8e0ff2..18de9f274 100644
155--- a/Tools/QtTestBrowser/CMakeLists.txt
156+++ b/Tools/QtTestBrowser/CMakeLists.txt
157@@ -62,7 +62,7 @@ if (ENABLE_TEST_SUPPORT)
158 endif ()
159
160 include_directories(${QtTestBrowser_INCLUDE_DIRECTORIES})
161-include_directories(SYSTEM ${QtTestBrowser_SYSTEM_INCLUDE_DIRECTORIES})
162+include_directories(${QtTestBrowser_SYSTEM_INCLUDE_DIRECTORIES})
163 add_executable(QtTestBrowser ${QtTestBrowser_SOURCES})
164 target_link_libraries(QtTestBrowser ${QtTestBrowser_LIBRARIES})
165 set_target_properties(QtTestBrowser PROPERTIES FOLDER "Tools" AUTOMOC ON)
166diff --git a/Tools/TestWebKitAPI/PlatformQt.cmake b/Tools/TestWebKitAPI/PlatformQt.cmake
167index c054c661b..046a91abc 100644
168--- a/Tools/TestWebKitAPI/PlatformQt.cmake
169+++ b/Tools/TestWebKitAPI/PlatformQt.cmake
170@@ -7,7 +7,7 @@ include_directories(
171 ${TESTWEBKITAPI_DIR}
172 )
173
174-include_directories(SYSTEM
175+include_directories(
176 ${ICU_INCLUDE_DIRS}
177 ${Qt5Gui_INCLUDE_DIRS}
178 )
179diff --git a/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt b/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
180index b0b473962..434e4ca25 100644
181--- a/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
182+++ b/Tools/TestWebKitAPI/Tests/WebKit2Gtk/CMakeLists.txt
183@@ -23,7 +23,7 @@ include_directories(
184 ${TOOLS_DIR}/TestWebKitAPI/gtk/WebKit2Gtk
185 )
186
187-include_directories(SYSTEM
188+include_directories(
189 ${ATSPI_INCLUDE_DIRS}
190 ${GLIB_INCLUDE_DIRS}
191 ${GSTREAMER_INCLUDE_DIRS}
192diff --git a/Tools/WebKitTestRunner/CMakeLists.txt b/Tools/WebKitTestRunner/CMakeLists.txt
193index 6355772ce..627965858 100644
194--- a/Tools/WebKitTestRunner/CMakeLists.txt
195+++ b/Tools/WebKitTestRunner/CMakeLists.txt
196@@ -116,7 +116,7 @@ GENERATE_BINDINGS(WebKitTestRunner_SOURCES
197 WEBKIT_INCLUDE_CONFIG_FILES_IF_EXISTS()
198
199 include_directories(${WebKitTestRunner_INCLUDE_DIRECTORIES})
200-include_directories(SYSTEM ${WebKitTestRunner_SYSTEM_INCLUDE_DIRECTORIES})
201+include_directories(${WebKitTestRunner_SYSTEM_INCLUDE_DIRECTORIES})
202
203 add_library(TestRunnerInjectedBundle SHARED ${WebKitTestRunnerInjectedBundle_SOURCES})
204 target_link_libraries(TestRunnerInjectedBundle ${WebKitTestRunner_LIBRARIES})
diff --git a/recipes-qt/qt5/qtwebkit_git.bb b/recipes-qt/qt5/qtwebkit_git.bb
index 0a978357..a137b2f9 100644
--- a/recipes-qt/qt5/qtwebkit_git.bb
+++ b/recipes-qt/qt5/qtwebkit_git.bb
@@ -14,8 +14,8 @@ DEPENDS += "qtbase qtdeclarative icu ruby-native sqlite3 glib-2.0 libxslt gperf-
14SRC_URI += "\ 14SRC_URI += "\
15 file://0001-Do-not-skip-build-for-cross-compile.patch \ 15 file://0001-Do-not-skip-build-for-cross-compile.patch \
16 file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \ 16 file://0002-Fix-build-with-non-glibc-libc-on-musl.patch \
17 file://0003-WebKitMacros-Append-to-I-and-not-to-isystem.patch \
18 file://0004-Fix-build-bug-for-armv32-BE.patch \ 17 file://0004-Fix-build-bug-for-armv32-BE.patch \
18 file://0001-PlatformQt.cmake-Do-not-generate-hardcoded-include-p.patch \
19" 19"
20 20
21inherit cmake_qt5 perlnative pythonnative 21inherit cmake_qt5 perlnative pythonnative
@@ -40,8 +40,9 @@ ARM_INSTRUCTION_SET_armv7ve = "thumb"
40# https://bugzilla.redhat.com/show_bug.cgi?id=1582954 40# https://bugzilla.redhat.com/show_bug.cgi?id=1582954
41CXXFLAGS += "-fpermissive" 41CXXFLAGS += "-fpermissive"
42 42
43EXTRA_OECMAKE = " \ 43EXTRA_OECMAKE += " \
44 -DPORT=Qt \ 44 -DPORT=Qt \
45 -DCROSS_COMPILE=ON \
45 -DECM_MKSPECS_INSTALL_DIR=${libdir}${QT_DIR_NAME}/mkspecs/modules \ 46 -DECM_MKSPECS_INSTALL_DIR=${libdir}${QT_DIR_NAME}/mkspecs/modules \
46 -DQML_INSTALL_DIR=${OE_QMAKE_PATH_QML} \ 47 -DQML_INSTALL_DIR=${OE_QMAKE_PATH_QML} \
47" 48"