summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt5/qtwayland/0001-examples.pro-include-server-buffer-only-when-buildin.patch31
-rw-r--r--recipes-qt/qt5/qtwayland/0001-xcomposite-glx-Fix-build-on-Qt-5.2.1.patch91
-rw-r--r--recipes-qt/qt5/qtwayland_git.bb7
3 files changed, 128 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-examples.pro-include-server-buffer-only-when-buildin.patch b/recipes-qt/qt5/qtwayland/0001-examples.pro-include-server-buffer-only-when-buildin.patch
new file mode 100644
index 00000000..998f8b67
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-examples.pro-include-server-buffer-only-when-buildin.patch
@@ -0,0 +1,31 @@
1From 201b36614907584a0d446975bddbb11a495540ed Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sat, 22 Feb 2014 17:47:44 +0100
4Subject: [PATCH] examples.pro: include server-buffer only when building with
5 opengles2
6
7* it's using glBindBuffer in
8 server-buffer/client/serverbufferrenderer.cpp
9
10Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
11Change-Id: I8412dfd4ebb95c147328ac6e4dfff14a0cff4e78
12---
13 examples/examples.pro | 4 +++-
14 1 file changed, 3 insertions(+), 1 deletion(-)
15
16diff --git a/examples/examples.pro b/examples/examples.pro
17index 2d4cd1b..fb2497e 100644
18--- a/examples/examples.pro
19+++ b/examples/examples.pro
20@@ -13,5 +13,7 @@ contains(CONFIG, wayland-compositor) {
21 SUBDIRS += qml-compositor
22 }
23
24- SUBDIRS += server-buffer
25+ contains(QT_CONFIG, opengles2) {
26+ SUBDIRS += server-buffer
27+ }
28 }
29--
301.8.5.3
31
diff --git a/recipes-qt/qt5/qtwayland/0001-xcomposite-glx-Fix-build-on-Qt-5.2.1.patch b/recipes-qt/qt5/qtwayland/0001-xcomposite-glx-Fix-build-on-Qt-5.2.1.patch
new file mode 100644
index 00000000..2266f4cb
--- /dev/null
+++ b/recipes-qt/qt5/qtwayland/0001-xcomposite-glx-Fix-build-on-Qt-5.2.1.patch
@@ -0,0 +1,91 @@
1From c5c23a37b230b426ed1eeea66544af438f48d05d Mon Sep 17 00:00:00 2001
2From: Taeyeon Mori <orochimarufan.x3@gmail.com>
3Date: Sun, 9 Feb 2014 23:43:06 +0100
4Subject: [PATCH] xcomposite-glx: Fix build on Qt 5.2.1
5
6* it was made private in
7 commit b6713ec4262c05f7d103bc3b75ab81aedc690853
8 Author: Jorgen Lind <jorgen.lind@digia.com>
9 Date: Wed Dec 18 07:59:53 2013 +0100
10
11 Make classes in client private
12
13 and qwayland-xcomposite-glx wasn't adapted to it
14
15* found in
16 http;//oro.sodimm.me/~hinata/devel/.../0001-Fix-build-on-Qt-5.2.1.patch.htm
17 but because it was already gone, here is the cache:
18 http://webcache.googleusercontent.com/search?q=cache:5L0rSgqrKMoJ:oro.sodimm.me/~hinata/devel/qt5-wayland-git/0001-Fix-build-on-Qt-5.2.1.patch.htm&hl=en&gl=cz&strip=1
19
20Change-Id: I8eed3645ccacc43e2c9febba2bc6544c7068207a
21Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
22---
23 .../compositor/xcomposite-glx/xcompositeglxintegration.cpp | 2 +-
24 src/plugins/platforms/qwayland-xcomposite-glx/main.cpp | 2 +-
25 .../qwaylandxcompositeglxplatformintegration.h | 14 ++++++++------
26 3 files changed, 10 insertions(+), 8 deletions(-)
27
28diff --git a/src/hardwareintegration/compositor/xcomposite-glx/xcompositeglxintegration.cpp b/src/hardwareintegration/compositor/xcomposite-glx/xcompositeglxintegration.cpp
29index dce1fdc..8403c78 100644
30--- a/src/hardwareintegration/compositor/xcomposite-glx/xcompositeglxintegration.cpp
31+++ b/src/hardwareintegration/compositor/xcomposite-glx/xcompositeglxintegration.cpp
32@@ -112,7 +112,7 @@ void XCompositeGLXClientBufferIntegration::initializeHardware(QtWayland::Display
33 delete glContext;
34 }
35
36-void XCompositeGLXClientBufferIntegration::updateTextureFromBuffer(struct ::wl_resource *buffer)
37+void XCompositeGLXClientBufferIntegration::bindTextureToBuffer(struct ::wl_resource *buffer)
38 {
39 XCompositeBuffer *compositorBuffer = XCompositeBuffer::fromResource(buffer);
40 Pixmap pixmap = XCompositeNameWindowPixmap(mDisplay, compositorBuffer->window());
41diff --git a/src/plugins/platforms/qwayland-xcomposite-glx/main.cpp b/src/plugins/platforms/qwayland-xcomposite-glx/main.cpp
42index 17b20f9..c9450a5 100644
43--- a/src/plugins/platforms/qwayland-xcomposite-glx/main.cpp
44+++ b/src/plugins/platforms/qwayland-xcomposite-glx/main.cpp
45@@ -40,7 +40,7 @@
46 ****************************************************************************/
47
48 #include <qpa/qplatformintegrationplugin.h>
49-#include "qwaylandintegration.h"
50+#include "qwaylandxcompositeglxplatformintegration.h"
51
52 QT_BEGIN_NAMESPACE
53
54diff --git a/src/plugins/platforms/qwayland-xcomposite-glx/qwaylandxcompositeglxplatformintegration.h b/src/plugins/platforms/qwayland-xcomposite-glx/qwaylandxcompositeglxplatformintegration.h
55index fe8c5b7..fb63fea 100644
56--- a/src/plugins/platforms/qwayland-xcomposite-glx/qwaylandxcompositeglxplatformintegration.h
57+++ b/src/plugins/platforms/qwayland-xcomposite-glx/qwaylandxcompositeglxplatformintegration.h
58@@ -42,7 +42,7 @@
59 #ifndef QWAYLANDXCOMPOSITEGLXPLATFORMINTEGRATION_H
60 #define QWAYLANDXCOMPOSITEGLXPLATFORMINTEGRATION_H
61
62-#include <QtWaylandClient/qwaylandintegration.h>
63+#include <QtWaylandClient/private/qwaylandintegration_p.h>
64
65 #include "qwaylandxcompositeglxintegration.h"
66
67@@ -51,14 +51,16 @@ class QWaylandXCompositeGlxPlatformIntegration : public QWaylandIntegration
68 public:
69 QWaylandXCompositeGlxPlatformIntegration()
70 : QWaylandIntegration()
71- , m_gl_integration(new QWaylandXCompositeGLXIntegration(display()))
72- { }
73+ , m_client_buffer_integration(new QWaylandXCompositeGLXIntegration())
74+ {
75+ m_client_buffer_integration->initialize(display());
76+ }
77
78- QWaylandGLIntegration *glIntegration() const Q_DECL_OVERRIDE
79- { return m_gl_integration; }
80+ QWaylandClientBufferIntegration *clientBufferIntegration() const Q_DECL_OVERRIDE
81+ { return m_client_buffer_integration; }
82
83 private:
84- QWaylandGLIntegration *m_gl_integration;
85+ QWaylandClientBufferIntegration *m_client_buffer_integration;
86 };
87
88 #endif
89--
901.8.5.3
91
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb
index 988aa98b..789a882c 100644
--- a/recipes-qt/qt5/qtwayland_git.bb
+++ b/recipes-qt/qt5/qtwayland_git.bb
@@ -4,4 +4,9 @@ require ${PN}.inc
4# qtwayland wasn't released yet, last tag before this SRCREV is 5.0.0-beta1 4# qtwayland wasn't released yet, last tag before this SRCREV is 5.0.0-beta1
5# qt5-git PV is only to indicate that this recipe is compatible with qt5 5.2.1 5# qt5-git PV is only to indicate that this recipe is compatible with qt5 5.2.1
6 6
7SRCREV = "a237778666666ab77c4e8e6b501cf0fbe7c9223e" 7SRCREV = "573d0ee5ba86d99095f217ea9e19172bfc5e75fd"
8
9SRC_URI += " \
10 file://0001-xcomposite-glx-Fix-build-on-Qt-5.2.1.patch \
11 file://0001-examples.pro-include-server-buffer-only-when-buildin.patch \
12"