diff options
-rw-r--r-- | recipes-qt/qt5/qtwayland/0001-tst_seatv4-Include-array.patch | 30 | ||||
-rw-r--r-- | recipes-qt/qt5/qtwayland_git.bb | 4 |
2 files changed, 33 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qtwayland/0001-tst_seatv4-Include-array.patch b/recipes-qt/qt5/qtwayland/0001-tst_seatv4-Include-array.patch new file mode 100644 index 00000000..1f15ea0d --- /dev/null +++ b/recipes-qt/qt5/qtwayland/0001-tst_seatv4-Include-array.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From ccd576151ecf174dbfbb854dbcbfe55a5f723124 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sun, 6 Oct 2019 21:44:38 -0700 | ||
4 | Subject: [PATCH] tst_seatv4: Include <array> | ||
5 | |||
6 | build fails with libc++ otherwise | ||
7 | |||
8 | tests/auto/client/seatv4/tst_seatv4.cpp:330:43: error: implicit instantiation of undefined template 'std::__1::array<const char *, 4>' | ||
9 | |||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | tests/auto/client/seatv4/tst_seatv4.cpp | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | diff --git a/tests/auto/client/seatv4/tst_seatv4.cpp b/tests/auto/client/seatv4/tst_seatv4.cpp | ||
16 | index 7dc2e727..3ddbb971 100644 | ||
17 | --- a/tests/auto/client/seatv4/tst_seatv4.cpp | ||
18 | +++ b/tests/auto/client/seatv4/tst_seatv4.cpp | ||
19 | @@ -36,7 +36,7 @@ | ||
20 | #include <QtWaylandClient/private/qwaylanddisplay_p.h> | ||
21 | #include <QtWaylandClient/private/qwaylandintegration_p.h> | ||
22 | #endif | ||
23 | - | ||
24 | +#include <array> | ||
25 | using namespace MockCompositor; | ||
26 | |||
27 | // wl_seat version 5 was introduced in wayland 1.10, and although that's pretty old, | ||
28 | -- | ||
29 | 2.23.0 | ||
30 | |||
diff --git a/recipes-qt/qt5/qtwayland_git.bb b/recipes-qt/qt5/qtwayland_git.bb index cd55b43b..05f8b088 100644 --- a/recipes-qt/qt5/qtwayland_git.bb +++ b/recipes-qt/qt5/qtwayland_git.bb | |||
@@ -13,7 +13,9 @@ LIC_FILES_CHKSUM = " \ | |||
13 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ | 13 | file://LICENSE.FDL;md5=6d9f2a9af4c8b8c3c769f6cc1b6aaf7e \ |
14 | " | 14 | " |
15 | 15 | ||
16 | SRC_URI += "file://0001-Fix-use-of-private-dependency.patch" | 16 | SRC_URI += "file://0001-Fix-use-of-private-dependency.patch \ |
17 | file://0001-tst_seatv4-Include-array.patch \ | ||
18 | " | ||
17 | 19 | ||
18 | PACKAGECONFIG ?= " \ | 20 | PACKAGECONFIG ?= " \ |
19 | wayland-client \ | 21 | wayland-client \ |