diff options
-rw-r--r-- | recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch | 31 | ||||
-rw-r--r-- | recipes-qt/qt5/qt3d_git.bb | 16 |
2 files changed, 46 insertions, 1 deletions
diff --git a/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch new file mode 100644 index 00000000..c9d22231 --- /dev/null +++ b/recipes-qt/qt5/qt3d/0001-Allow-a-tools-only-build.patch | |||
@@ -0,0 +1,31 @@ | |||
1 | From 778d0c4515bae5bdeb650fb3e6b3e32a73722b51 Mon Sep 17 00:00:00 2001 | ||
2 | From: Samuli Piippo <samuli.piippo@theqtcompany.com> | ||
3 | Date: Wed, 10 Feb 2016 09:02:09 +0200 | ||
4 | Subject: [PATCH] Allow a tools-only build | ||
5 | |||
6 | --- | ||
7 | qt3d.pro | 7 ++++++- | ||
8 | 1 file changed, 6 insertions(+), 1 deletion(-) | ||
9 | |||
10 | diff --git a/qt3d.pro b/qt3d.pro | ||
11 | index a26e76d..263e3c4 100644 | ||
12 | --- a/qt3d.pro | ||
13 | +++ b/qt3d.pro | ||
14 | @@ -1,4 +1,4 @@ | ||
15 | -requires(contains(QT_CONFIG, opengl)) | ||
16 | +!tools-only:requires(contains(QT_CONFIG, opengl)) | ||
17 | |||
18 | load(configure) | ||
19 | qtCompileTest(assimp) | ||
20 | @@ -17,3 +17,8 @@ load(qt_parts) | ||
21 | |||
22 | OTHER_FILES += \ | ||
23 | sync.profile | ||
24 | + | ||
25 | +tools-only { | ||
26 | + sub_tools.depends -= sub_src | ||
27 | + SUBDIRS = sub_tools | ||
28 | +} | ||
29 | -- | ||
30 | 1.9.1 | ||
31 | |||
diff --git a/recipes-qt/qt5/qt3d_git.bb b/recipes-qt/qt5/qt3d_git.bb index 0ec99c61..a19422b6 100644 --- a/recipes-qt/qt5/qt3d_git.bb +++ b/recipes-qt/qt5/qt3d_git.bb | |||
@@ -8,7 +8,19 @@ LIC_FILES_CHKSUM = " \ | |||
8 | file://LICENSE.GPL;md5=05832301944453ec79e40ba3c3cfceec \ | 8 | file://LICENSE.GPL;md5=05832301944453ec79e40ba3c3cfceec \ |
9 | " | 9 | " |
10 | 10 | ||
11 | DEPENDS = "qtdeclarative" | 11 | DEPENDS += "qtbase" |
12 | DEPENDS_class-target += "qtdeclarative qt3d-native" | ||
13 | |||
14 | SRC_URI += " \ | ||
15 | file://0001-Allow-a-tools-only-build.patch \ | ||
16 | " | ||
17 | |||
18 | PACKAGECONFIG ??= "" | ||
19 | PACKAGECONFIG_class-native ??= "tools-only" | ||
20 | PACKAGECONFIG_class-nativesdk ??= "tools-only" | ||
21 | PACKAGECONFIG[tools-only] = "CONFIG+=tools-only" | ||
22 | |||
23 | EXTRA_QMAKEVARS_PRE += "${EXTRA_OECONF}" | ||
12 | 24 | ||
13 | FILES_${PN}-qmlplugins += " \ | 25 | FILES_${PN}-qmlplugins += " \ |
14 | ${OE_QMAKE_PATH_QML}/*/*/*.bez \ | 26 | ${OE_QMAKE_PATH_QML}/*/*/*.bez \ |
@@ -16,3 +28,5 @@ FILES_${PN}-qmlplugins += " \ | |||
16 | " | 28 | " |
17 | 29 | ||
18 | SRCREV = "9b9f34701f47824e8201453d148152fb0855f98a" | 30 | SRCREV = "9b9f34701f47824e8201453d148152fb0855f98a" |
31 | |||
32 | BBCLASSEXTEND += "native nativesdk" | ||