summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb88
1 files changed, 43 insertions, 45 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index ab293a96..19583f91 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -14,6 +14,7 @@ LIC_FILES_CHKSUM = " \
14 14
15DEPENDS += " \ 15DEPENDS += " \
16 ninja-native \ 16 ninja-native \
17 yasm-native \
17 qtwebchannel \ 18 qtwebchannel \
18 qtbase qtdeclarative qtxmlpatterns qtquickcontrols \ 19 qtbase qtdeclarative qtxmlpatterns qtquickcontrols \
19 qtlocation \ 20 qtlocation \
@@ -31,6 +32,7 @@ EXTRA_QMAKEVARS_PRE += "GYP_CONFIG+=use_system_yasm \
31 GYP_CONFIG+=use_allocator=none \ 32 GYP_CONFIG+=use_allocator=none \
32 GYP_CONFIG+=use_experimental_allocator_shim=false \ 33 GYP_CONFIG+=use_experimental_allocator_shim=false \
33" 34"
35EXTRA_QMAKEVARS_CONFIGURE += "-feature-system-ninja -no-feature-system-gn"
34 36
35# chromium/third_party/openh264/openh264.gyp adds 37# chromium/third_party/openh264/openh264.gyp adds
36# -Wno-format to openh264_cflags_add 38# -Wno-format to openh264_cflags_add
@@ -42,7 +44,7 @@ SECURITY_STRINGFORMAT = ""
42 44
43# To use system ffmpeg you need to enable also libwebp, opus, vpx 45# To use system ffmpeg you need to enable also libwebp, opus, vpx
44# Only depenedencies available in oe-core are enabled by default 46# Only depenedencies available in oe-core are enabled by default
45PACKAGECONFIG ??= "libwebp flac libevent libxslt speex" 47PACKAGECONFIG ??= "libwebp flac libevent libxslt speex nss"
46PACKAGECONFIG[opus] = "WEBENGINE_CONFIG+=use_system_opus,,libopus" 48PACKAGECONFIG[opus] = "WEBENGINE_CONFIG+=use_system_opus,,libopus"
47PACKAGECONFIG[icu] = "WEBENGINE_CONFIG+=use_system_icu,,icu" 49PACKAGECONFIG[icu] = "WEBENGINE_CONFIG+=use_system_icu,,icu"
48PACKAGECONFIG[ffmpeg] = "WEBENGINE_CONFIG+=use_system_ffmpeg,,libav" 50PACKAGECONFIG[ffmpeg] = "WEBENGINE_CONFIG+=use_system_ffmpeg,,libav"
@@ -53,6 +55,7 @@ PACKAGECONFIG[libxslt] = "WEBENGINE_CONFIG+=use_system_libxslt,,libxslt"
53PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex" 55PACKAGECONFIG[speex] = "WEBENGINE_CONFIG+=use_system_speex,,speex"
54PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx" 56PACKAGECONFIG[vpx] = "WEBENGINE_CONFIG+=use_system_vpx,,libvpx"
55PACKAGECONFIG[webrtc] = "WEBENGINE_CONFIG+=use_webrtc,,libvpx" 57PACKAGECONFIG[webrtc] = "WEBENGINE_CONFIG+=use_webrtc,,libvpx"
58PACKAGECONFIG[nss] = "WEBENGINE_CONFIG+=use_nss,,nss"
56 59
57EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}" 60EXTRA_QMAKEVARS_PRE += "${PACKAGECONFIG_CONFARGS}"
58 61
@@ -76,30 +79,29 @@ def gettext_oeconf(d):
76require qt5.inc 79require qt5.inc
77require qt5-git.inc 80require qt5-git.inc
78 81
79export NINJA_PATH="${STAGING_BINDIR_NATIVE}/ninja"
80
81do_configure() { 82do_configure() {
82 # replace LD with CXX, to workaround a possible gyp inheritssue?
83 export LD="${CXX}"
84 export CC="${CC}"
85 export CXX="${CXX}"
86 export CC_host="gcc"
87 export CXX_host="g++"
88 export QMAKE_MAKE_ARGS="${EXTRA_OEMAKE}"
89 export QMAKE_CACHE_EVAL="${PACKAGECONFIG_CONFARGS}"
90
91 # Disable autodetection from sysroot: 83 # Disable autodetection from sysroot:
92 sed -i 's/packagesExist([^)]*vpx[^)]*):/false:/g; s/config_libvpx:/false:/g; s/config_srtp:/false:/g; s/config_snappy:/false:/g; s/packagesExist(nss):/false:/g; s/packagesExist(minizip, zlib):/false:/g; s/packagesExist(libwebp,libwebpdemux):/false:/g; s/packagesExist(libxml-2.0,libxslt):/false:/g; s/^ *packagesExist($$package):/false:/g' ${S}/tools/qmake/mkspecs/features/configure.prf 84 sed -e 's/packagesExist([^)]*vpx[^)]*):/false:/g'\
85 -e 's/config_libvpx:/false:/g' \
86 -e 's/config_srtp:/false:/g' \
87 -e 's/config_snappy:/false:/g' \
88 -e 's/packagesExist(nss):/false:/g' \
89 -e 's/packagesExist(minizip, zlib):/false:/g' \
90 -e 's/packagesExist(libwebp,libwebpdemux):/false:/g' \
91 -e 's/packagesExist(libxml-2.0,libxslt):/false:/g'\
92 -e 's/^ *packagesExist($$package):/false:/g' \
93 -i ${S}/mkspecs/features/configure.prf
93 94
94 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as 95 # qmake can't find the OE_QMAKE_* variables on it's own so directly passing them as
95 # arguments here 96 # arguments here
96 ${OE_QMAKE_QMAKE} -r ${EXTRA_QMAKEVARS_PRE} ${S} \ 97 ${OE_QMAKE_QMAKE} ${EXTRA_QMAKEVARS_PRE} ${S} \
97 QMAKE_CXX="${OE_QMAKE_CXX}" QMAKE_CC="${OE_QMAKE_CC}" \ 98 QMAKE_CXX="${OE_QMAKE_CXX}" \
99 QMAKE_CC="${OE_QMAKE_CC}" \
98 QMAKE_LINK="${OE_QMAKE_LINK}" \ 100 QMAKE_LINK="${OE_QMAKE_LINK}" \
99 QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \ 101 QMAKE_CFLAGS="${OE_QMAKE_CFLAGS}" \
100 QMAKE_CXXFLAGS="${OE_QMAKE_CXXFLAGS}" \ 102 QMAKE_CXXFLAGS="${OE_QMAKE_CXXFLAGS}" \
101 QMAKE_AR="${OE_QMAKE_AR} cqs" \ 103 -after ${EXTRA_QMAKEVARS_POST} -- \
102 -after ${EXTRA_QMAKEVARS_POST} 104 ${EXTRA_QMAKEVARS_CONFIGURE}
103} 105}
104 106
105do_configure_prepend_libc-musl() { 107do_configure_prepend_libc-musl() {
@@ -112,8 +114,7 @@ do_configure_prepend_libc-musl() {
112do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+" 114do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
113 115
114do_install_append() { 116do_install_append() {
115 rmdir ${D}${OE_QMAKE_PATH_PLUGINS}/${BPN} ${D}${OE_QMAKE_PATH_PLUGINS} || true 117 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@[^ ]*${B}[^ ]* @@g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc
116 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@-L${B}[^ ]* @ @g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc
117} 118}
118PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src" 119PACKAGE_DEBUG_SPLIT_STYLE = "debug-without-src"
119 120
@@ -126,39 +127,36 @@ RDEPENDS_${PN}-examples += " \
126 qtdeclarative-qmlplugins \ 127 qtdeclarative-qmlplugins \
127" 128"
128 129
129QT_MODULE_BRANCH_CHROMIUM = "53-based" 130QT_MODULE_BRANCH_CHROMIUM = "56-based"
130 131
131SRC_URI += " \ 132SRC_URI += " \
132 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 133 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
133 file://0001-functions.prf-Don-t-match-QMAKE_EXT_CPP-or-QMAKE_EXT.patch \ 134 file://0001-functions.prf-allow-build-for-linux-oe-g-platform.patch \
134 file://0002-functions.prf-Make-sure-we-only-use-the-file-name-to.patch \ 135 file://0002-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \
135 file://0003-functions.prf-allow-build-for-linux-oe-g-platform.patch \ 136 file://0003-Include-dependency-to-QCoreApplication-translate.patch \
136 file://0004-WebEngine-qquickwebengineview_p_p.h-add-include-QCol.patch \ 137 file://0004-Force-host-toolchain-configuration.patch \
137 file://0005-Include-dependency-to-QCoreApplication-translate.patch \ 138 file://0001-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch;patchdir=src/3rdparty \
138 file://0001-chromium-base.gypi-include-atomicops_internals_x86_g.patch;patchdir=src/3rdparty \ 139 file://0002-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
139 file://0002-chromium-Change-false-to-FALSE-and-1-to-TRUE-FIX-qtw.patch;patchdir=src/3rdparty \
140 file://0003-chromium-v8-fix-build-with-gcc7.patch;patchdir=src/3rdparty \
141 file://0004-chromium-WebKit-fix-build-with-gcc7.patch;patchdir=src/3rdparty \
142" 140"
141
143SRC_URI_append_libc-musl = "\ 142SRC_URI_append_libc-musl = "\
144 file://0005-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 143 file://0003-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
145 file://0006-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 144 file://0004-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
146 file://0007-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 145 file://0005-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
147 file://0008-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 146 file://0006-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
148 file://0009-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 147 file://0007-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
149 file://0010-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 148 file://0008-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
150 file://0011-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 149 file://0009-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
151 file://0012-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \ 150 file://0010-chromium-musl-Match-syscalls-to-match-musl.patch;patchdir=src/3rdparty \
152 file://0013-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 151 file://0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
153 file://0014-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 152 file://0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
154 file://0015-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 153 file://0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
155 file://0016-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \ 154 file://0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
156 file://0017-chromium-musl-link-with-libexecinfo-on-musl.patch;patchdir=src/3rdparty \ 155 file://0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
157 file://0018-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \
158" 156"
159 157
160SRCREV_qtwebengine = "d740d6a7dbfec387752c7bc8a8b06db0e757c9dc" 158SRCREV_qtwebengine = "73f7be5b2a95eab3dce11caede538eeb7beb71f2"
161SRCREV_chromium = "15d257fd921f37b32ef643225f21df0ea24c8302" 159SRCREV_chromium = "aa2fdd6be3d465280d2a0c3aacdc738bb4ffec05"
162SRCREV = "${SRCREV_qtwebengine}" 160SRCREV = "${SRCREV_qtwebengine}"
163 161
164SRCREV_FORMAT = "qtwebengine_chromium" 162SRCREV_FORMAT = "qtwebengine_chromium"