summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb30
1 files changed, 15 insertions, 15 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 789c3de5..fd7b8e36 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -32,7 +32,7 @@ DEPENDS += " \
32 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst', '', d)} \ 32 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxcomposite libxcursor libxi libxrandr libxtst', '', d)} \
33" 33"
34 34
35DEPENDS_append_libc-musl = " libexecinfo" 35DEPENDS:append:libc-musl = " libexecinfo"
36 36
37EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn" 37EXTRA_QMAKEVARS_CONFIGURE += "-feature-webengine-system-ninja -no-feature-webengine-system-gn"
38EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info" 38EXTRA_QMAKEVARS_PRE += "CONFIG+=force_debug_info"
@@ -72,12 +72,12 @@ PACKAGECONFIG[pulseaudio] = "-feature-webengine-pulseaudio,-no-feature-webengine
72EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}" 72EXTRA_QMAKEVARS_CONFIGURE += "${PACKAGECONFIG_CONFARGS}"
73 73
74COMPATIBLE_MACHINE = "(-)" 74COMPATIBLE_MACHINE = "(-)"
75COMPATIBLE_MACHINE_x86 = "(.*)" 75COMPATIBLE_MACHINE:x86 = "(.*)"
76COMPATIBLE_MACHINE_x86-64 = "(.*)" 76COMPATIBLE_MACHINE:x86-64 = "(.*)"
77COMPATIBLE_MACHINE_armv6 = "(.*)" 77COMPATIBLE_MACHINE:armv6 = "(.*)"
78COMPATIBLE_MACHINE_armv7a = "(.*)" 78COMPATIBLE_MACHINE:armv7a = "(.*)"
79COMPATIBLE_MACHINE_armv7ve = "(.*)" 79COMPATIBLE_MACHINE:armv7ve = "(.*)"
80COMPATIBLE_MACHINE_aarch64 = "(.*)" 80COMPATIBLE_MACHINE:aarch64 = "(.*)"
81 81
82inherit qmake5 82inherit qmake5
83inherit gettext 83inherit gettext
@@ -120,7 +120,7 @@ do_configure() {
120 ${EXTRA_QMAKEVARS_CONFIGURE} 120 ${EXTRA_QMAKEVARS_CONFIGURE}
121} 121}
122 122
123do_configure_prepend_libc-musl() { 123do_configure:prepend:libc-musl() {
124 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do 124 for f in `find ${S}/src/3rdparty/chromium/third_party/ffmpeg/chromium/config/Chromium/linux/ -name config.h -o -name config.asm`; do
125 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f 125 sed -i -e "s:define HAVE_SYSCTL 1:define HAVE_SYSCTL 0:g" $f
126 done 126 done
@@ -128,17 +128,17 @@ do_configure_prepend_libc-musl() {
128 128
129do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+" 129do_compile[progress] = "outof:^\[(\d+)/(\d+)\]\s+"
130 130
131do_install_append() { 131do_install:append() {
132 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@[^ ]*${B}[^ ]* @@g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc 132 sed -i 's@ -Wl,--start-group.*-Wl,--end-group@@g; s@[^ ]*${B}[^ ]* @@g' ${D}${libdir}/pkgconfig/Qt5WebEngineCore.pc
133} 133}
134 134
135# for /usr/share/qt5/qtwebengine_resources.pak 135# for /usr/share/qt5/qtwebengine_resources.pak
136FILES_${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}" 136FILES:${PN} += "${OE_QMAKE_PATH_QT_TRANSLATIONS} ${OE_QMAKE_PATH_QT_DATA}"
137 137
138# Chromium uses libpci to determine which optimizations/workarounds to apply 138# Chromium uses libpci to determine which optimizations/workarounds to apply
139RDEPENDS_${PN}_append_x86 = " libpci" 139RDEPENDS:${PN}:append:x86 = " libpci"
140 140
141RDEPENDS_${PN}-examples += " \ 141RDEPENDS:${PN}-examples += " \
142 ${PN}-qmlplugins \ 142 ${PN}-qmlplugins \
143 qtquickcontrols-qmlplugins \ 143 qtquickcontrols-qmlplugins \
144 qtdeclarative-qmlplugins \ 144 qtdeclarative-qmlplugins \
@@ -158,7 +158,7 @@ SRC_URI += " \
158" 158"
159# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15 159# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
160# 5.15.meta-qt5.12 160# 5.15.meta-qt5.12
161SRC_URI_append_libc-musl = "\ 161SRC_URI:append:libc-musl = "\
162 file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 162 file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
163 file://0004-musl-link-against-libexecinfo.patch \ 163 file://0004-musl-link-against-libexecinfo.patch \
164 file://0005-mkspecs-Allow-builds-with-libc-glibc.patch \ 164 file://0005-mkspecs-Allow-builds-with-libc-glibc.patch \
@@ -182,7 +182,7 @@ SRC_URI += " \
182 182
183# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based 183# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
184# 87-based.meta-qt5.4 184# 87-based.meta-qt5.4
185SRC_URI_append_libc-musl = "\ 185SRC_URI:append:libc-musl = "\
186 file://chromium/0012-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 186 file://chromium/0012-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
187 file://chromium/0013-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 187 file://chromium/0013-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
188 file://chromium/0014-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 188 file://chromium/0014-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
@@ -203,4 +203,4 @@ SRCREV = "${SRCREV_qtwebengine}"
203SRCREV_FORMAT = "qtwebengine_chromium" 203SRCREV_FORMAT = "qtwebengine_chromium"
204 204
205# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel] 205# WARNING: qtwebengine-5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0 do_package_qa: QA Issue: ELF binary '/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/qtwebengine/5.5.99+5.6.0-rc+gitAUTOINC+3f02c25de4_779a2388fc-r0/packages-split/qtwebengine/usr/lib/libQt5WebEngineCore.so.5.6.0' has relocations in .text [textrel]
206INSANE_SKIP_${PN} += "textrel" 206INSANE_SKIP:${PN} += "textrel"