summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb48
1 files changed, 21 insertions, 27 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 7b157096..63c281a6 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -3,7 +3,6 @@ SUMMARY = "QtWebEngine combines the power of Chromium and Qt"
3# Read http://blog.qt.io/blog/2016/01/13/new-agreement-with-the-kde-free-qt-foundation/ 3# Read http://blog.qt.io/blog/2016/01/13/new-agreement-with-the-kde-free-qt-foundation/
4LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( LGPL-3.0 | The-Qt-Company-Commercial )" 4LICENSE = "BSD & ( GPL-3.0 & The-Qt-Company-GPL-Exception-1.0 | The-Qt-Company-Commercial ) & ( LGPL-3.0 | The-Qt-Company-Commercial )"
5LIC_FILES_CHKSUM = " \ 5LIC_FILES_CHKSUM = " \
6 file://src/core/browser_context_qt.cpp;md5=b5193b7d68699260f3b40b201365c8d2;beginline=1;endline=38 \
7 file://src/3rdparty/chromium/LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d \ 6 file://src/3rdparty/chromium/LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d \
8 file://LICENSE.LGPL3;md5=8211fde12cc8a4e2477602f5953f5b71 \ 7 file://LICENSE.LGPL3;md5=8211fde12cc8a4e2477602f5953f5b71 \
9 file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \ 8 file://LICENSE.GPLv3;md5=88e2b9117e6be406b5ed6ee4ca99a705 \
@@ -134,47 +133,42 @@ RDEPENDS_${PN}-examples += " \
134 qtdeclarative-qmlplugins \ 133 qtdeclarative-qmlplugins \
135" 134"
136 135
137QT_MODULE_BRANCH_CHROMIUM = "65-based" 136QT_MODULE_BRANCH_CHROMIUM = "69-based"
138 137
139# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.11 138# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.12
140# 5.11.meta-qt5.8 139# 5.12.meta-qt5.1
141SRC_URI += " \ 140SRC_URI += " \
142 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 141 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
143 file://0001-Force-host-toolchain-configuration.patch \ 142 file://0001-Force-host-toolchain-configuration.patch \
144 file://0002-chromium_overrides.cpp-Fix-build-with-plugins-and-oz.patch \
145" 143"
146SRC_URI_append_libc-musl = "\ 144SRC_URI_append_libc-musl = "\
147 file://0003-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 145 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
148 file://0004-musl-link-against-libexecinfo.patch \ 146 file://0003-musl-link-against-libexecinfo.patch \
149" 147"
150 148
151# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/65-based 149# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/69-based
152# 65-based.meta-qt5.7 150# 69-based.meta-qt5.1
153SRC_URI += " \ 151SRC_URI += " \
154 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \ 152 file://chromium/0001-chromium-Force-host-toolchain-configuration.patch;patchdir=src/3rdparty \
155 file://chromium/0002-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
156 file://chromium/0003-chromium-Fix-build-with-gcc8.patch;patchdir=src/3rdparty \
157" 153"
158 154
159SRC_URI_append_libc-musl = "\ 155SRC_URI_append_libc-musl = "\
160 file://chromium/0004-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 156 file://chromium/0002-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
161 file://chromium/0005-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 157 file://chromium/0003-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
162 file://chromium/0006-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 158 file://chromium/0004-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
163 file://chromium/0007-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 159 file://chromium/0005-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
164 file://chromium/0008-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 160 file://chromium/0006-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \
165 file://chromium/0009-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 161 file://chromium/0007-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \
166 file://chromium/0010-chromium-musl-Use-correct-member-name-__si_fields-fr.patch;patchdir=src/3rdparty \ 162 file://chromium/0008-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
167 file://chromium/0011-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 163 file://chromium/0009-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
168 file://chromium/0012-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 164 file://chromium/0010-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
169 file://chromium/0013-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 165 file://chromium/0011-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \
170 file://chromium/0014-chromium-musl-include-asm-generic-ioctl.h-for-TCGETS.patch;patchdir=src/3rdparty \ 166 file://chromium/0012-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
171 file://chromium/0015-chromium-musl-tcmalloc-Use-off64_t-insread-of-__off6.patch;patchdir=src/3rdparty \ 167 file://chromium/0013-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
172 file://chromium/0016-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \
173 file://chromium/0017-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
174" 168"
175 169
176SRCREV_qtwebengine = "18412af977d658f243eb5b25b62284924cfa362f" 170SRCREV_qtwebengine = "4f1e0003d98116e33a847360e0e95c46daae25fc"
177SRCREV_chromium = "2095a35f300bcbe82e968e9a547dff7c79be29d8" 171SRCREV_chromium = "323b45aa242e0b4e75689d67418ec124ba1ca815"
178SRCREV = "${SRCREV_qtwebengine}" 172SRCREV = "${SRCREV_qtwebengine}"
179 173
180SRCREV_FORMAT = "qtwebengine_chromium" 174SRCREV_FORMAT = "qtwebengine_chromium"