summaryrefslogtreecommitdiffstats
path: root/recipes-qt/qt5/qtwebengine_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-qt/qt5/qtwebengine_git.bb')
-rw-r--r--recipes-qt/qt5/qtwebengine_git.bb67
1 files changed, 32 insertions, 35 deletions
diff --git a/recipes-qt/qt5/qtwebengine_git.bb b/recipes-qt/qt5/qtwebengine_git.bb
index 357a519a..963677ca 100644
--- a/recipes-qt/qt5/qtwebengine_git.bb
+++ b/recipes-qt/qt5/qtwebengine_git.bb
@@ -144,62 +144,59 @@ RDEPENDS_${PN}-examples += " \
144 qtdeclarative-qmlplugins \ 144 qtdeclarative-qmlplugins \
145" 145"
146 146
147QT_MODULE_BRANCH_CHROMIUM = "83-based" 147QT_MODULE_BRANCH_CHROMIUM = "87-based"
148
149QT_MODULE_BRANCH = "5.15"
150PV = "5.15.3+git${SRCPV}"
148 151
149# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-glibc 152# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15-glibc
150# 5.15-glibc.meta-qt5.9 153# 5.15-glibc.meta-qt5.10
151SRC_URI += " \ 154SRC_URI += " \
152 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \ 155 ${QT_GIT}/qtwebengine-chromium.git;name=chromium;branch=${QT_MODULE_BRANCH_CHROMIUM};protocol=${QT_GIT_PROTOCOL};destsuffix=git/src/3rdparty \
153 file://0001-Force-host-toolchain-configuration.patch \ 156 file://0001-Force-host-toolchain-configuration.patch \
154" 157"
155# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15 158# Patches from https://github.com/meta-qt5/qtwebengine/commits/b5.15
156# 5.15.meta-qt5.9 159# 5.15.meta-qt5.10
157SRC_URI_append_libc-musl = "\ 160SRC_URI_append_libc-musl = "\
158 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \ 161 file://0002-musl-don-t-use-pvalloc-as-it-s-not-available-on-musl.patch \
159 file://0003-musl-link-against-libexecinfo.patch \ 162 file://0003-musl-link-against-libexecinfo.patch \
160 file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \ 163 file://0004-mkspecs-Allow-builds-with-libc-glibc.patch \
161" 164"
162 165
163# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/83-based-glibc 166# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based-glibc
164# 83-based-glibc.meta-qt5.1 167# 87-based-glibc.meta-qt5.1
165SRC_URI += " \ 168SRC_URI += " \
166 file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \ 169 file://chromium/0001-chromium-workaround-for-too-long-.rps-file-name.patch;patchdir=src/3rdparty \
167 file://chromium/0002-chromium-stack-pointer-clobber.patch;patchdir=src/3rdparty \ 170 file://chromium/0002-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \
168 file://chromium/0003-chromium-fix-build-with-clang.patch;patchdir=src/3rdparty \ 171 file://chromium/0003-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \
169 file://chromium/0004-chromium-Exclude-CRC32-for-32bit-arm.patch;patchdir=src/3rdparty \ 172 file://chromium/0004-chromium-Do-not-try-to-set-the-guessed-values-for.patch;patchdir=src/3rdparty \
170 file://chromium/0005-chromium-Do-not-try-to-set-the-guessed-values-for.patch;patchdir=src/3rdparty \ 173 file://chromium/0005-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \
171 file://chromium/0006-chromium-aarch64-skia-build-fix.patch;patchdir=src/3rdparty \ 174 file://chromium/0006-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \
172 file://chromium/0007-chromium-fix-build-after-y2038-changes-in-glibc.patch;patchdir=src/3rdparty \ 175 file://chromium/0007-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \
173 file://chromium/0008-chromium-Fix-build-on-32bit-arches-with-64bit-time_t.patch;patchdir=src/3rdparty \ 176 file://chromium/0008-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \
174 file://chromium/0009-chromium-Include-cstddef-for-size_t-definition.patch;patchdir=src/3rdparty \ 177 file://chromium/0009-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
175 file://chromium/0010-chromium-Move-CharAllocator-definition-to-a-header-f.patch;patchdir=src/3rdparty \ 178 file://chromium/0010-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
176 file://chromium/0011-chromium-Include-cstddef-and-cstdint.patch;patchdir=src/3rdparty \
177 file://chromium/0012-chromium-Link-v8-with-libatomic-on-x86.patch;patchdir=src/3rdparty \
178 file://chromium/0013-chromium-icu-use-system-library-only-targets.patch;patchdir=src/3rdparty \
179 file://chromium/0014-chromium-Fix-sandbox-Aw-snap-for-syscalls-403-and-40.patch;patchdir=src/3rdparty \
180 file://chromium/0015-chromium-gcc11-fixes.patch;patchdir=src/3rdparty \ 179 file://chromium/0015-chromium-gcc11-fixes.patch;patchdir=src/3rdparty \
181" 180"
182 181
183# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/83-based 182# Patches from https://github.com/meta-qt5/qtwebengine-chromium/commits/87-based
184# 83-based.meta-qt5.1 183# 87-based.meta-qt5.1
185SRC_URI_append_libc-musl = "\ 184SRC_URI_append_libc-musl = "\
186 file://chromium/0015-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \ 185 file://chromium/0011-chromium-musl-sandbox-Define-TEMP_FAILURE_RETRY-if-n.patch;patchdir=src/3rdparty \
187 file://chromium/0016-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \ 186 file://chromium/0012-chromium-musl-Avoid-mallinfo-APIs-on-non-glibc-linux.patch;patchdir=src/3rdparty \
188 file://chromium/0017-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \ 187 file://chromium/0013-chromium-musl-include-fcntl.h-for-loff_t.patch;patchdir=src/3rdparty \
189 file://chromium/0018-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \ 188 file://chromium/0014-chromium-musl-use-off64_t-instead-of-the-internal-__.patch;patchdir=src/3rdparty \
190 file://chromium/0019-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \ 189 file://chromium/0015-chromium-musl-linux-glibc-make-the-distinction.patch;patchdir=src/3rdparty \
191 file://chromium/0020-chromium-musl-allocator-Do-not-include-glibc_weak_sy.patch;patchdir=src/3rdparty \ 190 file://chromium/0016-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \
192 file://chromium/0021-chromium-musl-Define-res_ninit-and-res_nclose-for-no.patch;patchdir=src/3rdparty \ 191 file://chromium/0017-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \
193 file://chromium/0022-chromium-musl-Do-not-define-__sbrk-on-musl.patch;patchdir=src/3rdparty \ 192 file://chromium/0018-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \
194 file://chromium/0023-chromium-musl-Adjust-default-pthread-stack-size.patch;patchdir=src/3rdparty \ 193 file://chromium/0019-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \
195 file://chromium/0024-chromium-musl-Use-_fpstate-instead-of-_libc_fpstate-.patch;patchdir=src/3rdparty \ 194 file://chromium/0020-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
196 file://chromium/0025-chromium-musl-elf_reader.cc-include-sys-reg.h-to-get.patch;patchdir=src/3rdparty \ 195 file://chromium/0021-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
197 file://chromium/0026-chromium-musl-pread-pwrite.patch;patchdir=src/3rdparty \
198 file://chromium/0027-chromium-musl-initialize-msghdr-in-a-compatible-mann.patch;patchdir=src/3rdparty \
199" 196"
200 197
201SRCREV_qtwebengine = "5537ff4437ea7a5f9ea140071343f88bf48deddc" 198SRCREV_qtwebengine = "f121523512ab70db7d9b1e639841c9ebc3eae9a1"
202SRCREV_chromium = "f5a93d251cca15cb24a3acacd2fc0f645513c56d" 199SRCREV_chromium = "9406a89a9dfe24d96089524d9da6da18e0457330"
203SRCREV = "${SRCREV_qtwebengine}" 200SRCREV = "${SRCREV_qtwebengine}"
204 201
205SRCREV_FORMAT = "qtwebengine_chromium" 202SRCREV_FORMAT = "qtwebengine_chromium"