summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-12-13 09:20:17 -0800
committerAndrei Gherzan <andrei@gherzan.ro>2018-12-14 08:47:20 +0000
commit05c00c0e4fbeb46f86ed4b47e48a7bffb478bbed (patch)
tree65a733f42214c5e675dbc9778fbfc4563378d07a
parent12e61faf30b08909b58ed87b9542f2753d0249dc (diff)
downloadmeta-raspberrypi-05c00c0e4fbeb46f86ed4b47e48a7bffb478bbed.tar.gz
qtbase: Get eglfs/kms working with vc4graphics
- Drop enabling linuxfb, now we can get eglfs going - Enable kms and gbm feature when using vc4graphics driver - No need to set OE_QTBASE_EGLFS_DEVICE_INTEGRATION when using vc4graphics Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend6
1 files changed, 3 insertions, 3 deletions
diff --git a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
index 58f3c55..58b7b47 100644
--- a/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
+++ b/dynamic-layers/qt5-layer/recipes-qt/qt5/qtbase_%.bbappend
@@ -1,12 +1,12 @@
1PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \ 1PACKAGECONFIG_GL_rpi = "${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'gl', \
2 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2 linuxfb', \ 2 bb.utils.contains('DISTRO_FEATURES', 'opengl', 'eglfs gles2', \
3 '', d), d)}" 3 '', d), d)}"
4#PACKAGECONFIG_GL_rpi = "${@bb.utils.any_distro_features('x11 wayland', '', 'eglfs', d)}" 4PACKAGECONFIG_GL_append_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', ' gbm kms', '', d)}"
5PACKAGECONFIG_FONTS_rpi = "fontconfig" 5PACKAGECONFIG_FONTS_rpi = "fontconfig"
6PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev" 6PACKAGECONFIG_append_rpi = " libinput examples tslib xkb xkbcommon-evdev"
7PACKAGECONFIG_remove_rpi = "tests" 7PACKAGECONFIG_remove_rpi = "tests"
8 8
9OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', 'eglfs_kms', 'eglfs_brcm', d)}" 9OE_QTBASE_EGLFS_DEVICE_INTEGRATION_rpi = "${@bb.utils.contains('MACHINE_FEATURES', 'vc4graphics', '', 'eglfs_brcm', d)}"
10 10
11do_configure_prepend_rpi() { 11do_configure_prepend_rpi() {
12 # Add the appropriate EGLFS_DEVICE_INTEGRATION 12 # Add the appropriate EGLFS_DEVICE_INTEGRATION