diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-11-14 23:07:35 -0800 |
---|---|---|
committer | Paul Barker <pbarker@toganlabs.com> | 2017-11-30 13:42:48 +0000 |
commit | d8846c14266ec67e7984480a90deecac7818b81c (patch) | |
tree | 5140331efd80aa8e9ea6e249f0cd638ab4018253 | |
parent | 58965882ab3db07dc42f9c4b008af7ac0a3dbb17 (diff) | |
download | meta-raspberrypi-d8846c14266ec67e7984480a90deecac7818b81c.tar.gz |
userland: Update to latest revision
Forward port patches as needed
Signed-off-by: Khem Raj <raj.khem@gmail.com>
16 files changed, 62 insertions, 63 deletions
diff --git a/recipes-graphics/userland/userland/0001-Allow-applications-to-set-next-resource-handle.patch b/recipes-graphics/userland/userland/0001-Allow-applications-to-set-next-resource-handle.patch index d622157..5861c4e 100644 --- a/recipes-graphics/userland/userland/0001-Allow-applications-to-set-next-resource-handle.patch +++ b/recipes-graphics/userland/userland/0001-Allow-applications-to-set-next-resource-handle.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From f6540119d5b064361ffcb370373794932f97bfdd Mon Sep 17 00:00:00 2001 | 1 | From e45bc677368d0f8d42720aad242f33f6e2687fb1 Mon Sep 17 00:00:00 2001 |
2 | From: Dom Cobley <dc4@broadcom.com> | 2 | From: Dom Cobley <dc4@broadcom.com> |
3 | Date: Tue, 9 Jul 2013 09:26:26 -0400 | 3 | Date: Tue, 9 Jul 2013 09:26:26 -0400 |
4 | Subject: [PATCH 01/13] Allow applications to set next resource handle | 4 | Subject: [PATCH 01/15] Allow applications to set next resource handle |
5 | 5 | ||
6 | This patch adds provisions in userland to | 6 | This patch adds provisions in userland to |
7 | let apps callers set the next rendereing dispmanx resource. | 7 | let apps callers set the next rendereing dispmanx resource. |
@@ -204,5 +204,5 @@ index 8a5734c..51b3580 100644 | |||
204 | 204 | ||
205 | FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data)) | 205 | FN(void, eglIntGetColorData_impl, (EGL_SURFACE_ID_T s, KHRN_IMAGE_FORMAT_T format, uint32_t width, uint32_t height, int32_t stride, uint32_t y_offset, void *data)) |
206 | -- | 206 | -- |
207 | 2.12.0 | 207 | 2.15.0 |
208 | 208 | ||
diff --git a/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch b/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch index c054572..d6e6476 100644 --- a/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch +++ b/recipes-graphics/userland/userland/0002-wayland-Add-support-for-the-Wayland-winsys.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 61a9d792ed774af43e592aa8fdb2a18488696d0f Mon Sep 17 00:00:00 2001 | 1 | From 15fb270f438f4ef1413192b5ce1e0dc784b45d9e Mon Sep 17 00:00:00 2001 |
2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> | 2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> |
3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 | 3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 |
4 | Subject: [PATCH 02/13] wayland: Add support for the Wayland winsys | 4 | Subject: [PATCH 02/15] wayland: Add support for the Wayland winsys |
5 | 5 | ||
6 | * Adds EGL_WL_bind_wayland_display extension | 6 | * Adds EGL_WL_bind_wayland_display extension |
7 | * Adds wayland-egl library | 7 | * Adds wayland-egl library |
@@ -17,7 +17,7 @@ TODO: wl_dispmanx_server_buffer should probably be defined in a | |||
17 | private header that can be included from EGL and vc_* instead of in | 17 | private header that can be included from EGL and vc_* instead of in |
18 | vc_vchi_dispmanx.h | 18 | vc_vchi_dispmanx.h |
19 | --- | 19 | --- |
20 | .gitignore | 2 + | 20 | .gitignore | 1 + |
21 | CMakeLists.txt | 11 + | 21 | CMakeLists.txt | 11 + |
22 | README.md | 4 + | 22 | README.md | 4 + |
23 | buildme | 10 +- | 23 | buildme | 10 +- |
@@ -47,7 +47,7 @@ vc_vchi_dispmanx.h | |||
47 | interface/vmcs_host/vc_vchi_dispmanx.h | 15 ++ | 47 | interface/vmcs_host/vc_vchi_dispmanx.h | 15 ++ |
48 | interface/wayland/dispmanx.xml | 123 +++++++++++ | 48 | interface/wayland/dispmanx.xml | 123 +++++++++++ |
49 | makefiles/cmake/Wayland.cmake | 72 ++++++ | 49 | makefiles/cmake/Wayland.cmake | 72 ++++++ |
50 | 30 files changed, 1258 insertions(+), 98 deletions(-) | 50 | 30 files changed, 1257 insertions(+), 98 deletions(-) |
51 | create mode 100644 interface/khronos/common/linux/khrn_wayland.c | 51 | create mode 100644 interface/khronos/common/linux/khrn_wayland.c |
52 | copy interface/{vmcs_host/vc_vchi_dispmanx.h => khronos/common/linux/khrn_wayland.h} (56%) | 52 | copy interface/{vmcs_host/vc_vchi_dispmanx.h => khronos/common/linux/khrn_wayland.h} (56%) |
53 | create mode 100644 interface/khronos/ext/egl_wayland.c | 53 | create mode 100644 interface/khronos/ext/egl_wayland.c |
@@ -58,14 +58,13 @@ vc_vchi_dispmanx.h | |||
58 | create mode 100644 makefiles/cmake/Wayland.cmake | 58 | create mode 100644 makefiles/cmake/Wayland.cmake |
59 | 59 | ||
60 | diff --git a/.gitignore b/.gitignore | 60 | diff --git a/.gitignore b/.gitignore |
61 | index 4a88665..5da71a9 100644 | 61 | index 63570f1..1459436 100644 |
62 | --- a/.gitignore | 62 | --- a/.gitignore |
63 | +++ b/.gitignore | 63 | +++ b/.gitignore |
64 | @@ -13,3 +13,5 @@ build/ | 64 | @@ -30,3 +30,4 @@ build/ |
65 | *.lai | 65 | *.pts |
66 | *.la | 66 | *.ppm |
67 | *.a | 67 | *.mkv |
68 | + | ||
69 | +*~ | 68 | +*~ |
70 | diff --git a/CMakeLists.txt b/CMakeLists.txt | 69 | diff --git a/CMakeLists.txt b/CMakeLists.txt |
71 | index cfc8ae5..673a5ad 100644 | 70 | index cfc8ae5..673a5ad 100644 |
@@ -808,16 +807,16 @@ index b8bb374..03fe67b 100644 | |||
808 | /* | 807 | /* |
809 | TODO: do an RPC call to make sure the Khronos vll is loaded (and that it stays loaded until eglTerminate) | 808 | TODO: do an RPC call to make sure the Khronos vll is loaded (and that it stays loaded until eglTerminate) |
810 | Also affects global image (and possibly others?) | 809 | Also affects global image (and possibly others?) |
811 | @@ -451,6 +444,9 @@ EGLAPI const char EGLAPIENTRY * eglQueryString(EGLDisplay dpy, EGLint name) | 810 | @@ -450,6 +443,9 @@ EGLAPI const char EGLAPIENTRY * eglQueryString(EGLDisplay dpy, EGLint name) |
811 | #ifdef EGL_KHR_fence_sync | ||
812 | "EGL_KHR_fence_sync " | 812 | "EGL_KHR_fence_sync " |
813 | #endif | 813 | #endif |
814 | #endif | 814 | +#endif |
815 | +#if EGL_WL_bind_wayland_display | 815 | +#if EGL_WL_bind_wayland_display |
816 | + "EGL_WL_bind_wayland_display " | 816 | + "EGL_WL_bind_wayland_display " |
817 | +#endif | 817 | #endif |
818 | ; | 818 | ; |
819 | break; | 819 | break; |
820 | case EGL_VENDOR: | ||
821 | @@ -655,8 +651,7 @@ EGLAPI EGLSurface EGLAPIENTRY eglCreateWindowSurface(EGLDisplay dpy, EGLConfig c | 820 | @@ -655,8 +651,7 @@ EGLAPI EGLSurface EGLAPIENTRY eglCreateWindowSurface(EGLDisplay dpy, EGLConfig c |
822 | false, | 821 | false, |
823 | EGL_NO_TEXTURE, | 822 | EGL_NO_TEXTURE, |
@@ -1885,5 +1884,5 @@ index 0000000..ad90d30 | |||
1885 | + set(${_sources} ${${_sources}} PARENT_SCOPE) | 1884 | + set(${_sources} ${${_sources}} PARENT_SCOPE) |
1886 | +endfunction() | 1885 | +endfunction() |
1887 | -- | 1886 | -- |
1888 | 2.12.2 | 1887 | 2.15.0 |
1889 | 1888 | ||
diff --git a/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch b/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch index f888533..1d78755 100644 --- a/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch +++ b/recipes-graphics/userland/userland/0003-wayland-Add-Wayland-example.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 08679675740d92f022e0fd46207a42589c9f6c51 Mon Sep 17 00:00:00 2001 | 1 | From b0437cf318a26c62119ad60649430903f58bbab4 Mon Sep 17 00:00:00 2001 |
2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> | 2 | From: Tomeu Vizoso <tomeu.vizoso@collabora.com> |
3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 | 3 | Date: Tue, 1 Oct 2013 13:19:20 +0200 |
4 | Subject: [PATCH 03/13] wayland: Add Wayland example | 4 | Subject: [PATCH 03/15] wayland: Add Wayland example |
5 | 5 | ||
6 | --- | 6 | --- |
7 | .../linux/apps/hello_pi/CMakeLists.txt | 1 + | 7 | .../linux/apps/hello_pi/CMakeLists.txt | 1 + |
@@ -862,5 +862,5 @@ index 8225dd5..0be6ce7 100755 | |||
862 | - | 862 | - |
863 | +make -C hello_wayland | 863 | +make -C hello_wayland |
864 | -- | 864 | -- |
865 | 2.12.0 | 865 | 2.15.0 |
866 | 866 | ||
diff --git a/recipes-graphics/userland/userland/0004-wayland-egl-Add-bcm_host-to-dependencies.patch b/recipes-graphics/userland/userland/0004-wayland-egl-Add-bcm_host-to-dependencies.patch index f9c0b7b..d60c432 100644 --- a/recipes-graphics/userland/userland/0004-wayland-egl-Add-bcm_host-to-dependencies.patch +++ b/recipes-graphics/userland/userland/0004-wayland-egl-Add-bcm_host-to-dependencies.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From eb9d0eb386b9b3df519a299887b45962c03e732c Mon Sep 17 00:00:00 2001 | 1 | From cae4ff834eef23c8f23126ba4d630db395f13aee Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Mon, 10 Aug 2015 02:38:27 -0700 | 3 | Date: Mon, 10 Aug 2015 02:38:27 -0700 |
4 | Subject: [PATCH 04/13] wayland-egl: Add bcm_host to dependencies | 4 | Subject: [PATCH 04/15] wayland-egl: Add bcm_host to dependencies |
5 | 5 | ||
6 | It uses headers like vcos_platform_types.h but does not | 6 | It uses headers like vcos_platform_types.h but does not |
7 | depend on module which should add the required include paths | 7 | depend on module which should add the required include paths |
@@ -24,5 +24,5 @@ index 8bafc15..fd259c9 100644 | |||
24 | Libs: -L${libdir} -lwayland-egl | 24 | Libs: -L${libdir} -lwayland-egl |
25 | Cflags: -I${includedir} | 25 | Cflags: -I${includedir} |
26 | -- | 26 | -- |
27 | 2.12.0 | 27 | 2.15.0 |
28 | 28 | ||
diff --git a/recipes-graphics/userland/userland/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch b/recipes-graphics/userland/userland/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch index f69bade..676f34c 100644 --- a/recipes-graphics/userland/userland/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch +++ b/recipes-graphics/userland/userland/0005-interface-remove-faulty-assert-to-make-weston-happy-.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From ef3162e061a3231fbf836208f98c38c7c5581a9e Mon Sep 17 00:00:00 2001 | 1 | From 8ee4f6eedb81e9bfe0e603a21606c52f9501e609 Mon Sep 17 00:00:00 2001 |
2 | From: "Yann E. MORIN" <yann.morin.1998@free.fr> | 2 | From: "Yann E. MORIN" <yann.morin.1998@free.fr> |
3 | Date: Sat, 24 Jan 2015 22:07:19 +0100 | 3 | Date: Sat, 24 Jan 2015 22:07:19 +0100 |
4 | Subject: [PATCH 05/13] interface: remove faulty assert() to make weston happy | 4 | Subject: [PATCH 05/15] interface: remove faulty assert() to make weston happy |
5 | at runtime | 5 | at runtime |
6 | 6 | ||
7 | This was removed after a discussion on IRC with the weston guys | 7 | This was removed after a discussion on IRC with the weston guys |
@@ -13,7 +13,7 @@ Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr> | |||
13 | 1 file changed, 1 deletion(-) | 13 | 1 file changed, 1 deletion(-) |
14 | 14 | ||
15 | diff --git a/interface/vmcs_host/vc_vchi_dispmanx.c b/interface/vmcs_host/vc_vchi_dispmanx.c | 15 | diff --git a/interface/vmcs_host/vc_vchi_dispmanx.c b/interface/vmcs_host/vc_vchi_dispmanx.c |
16 | index 45f4cff..5d0368c 100755 | 16 | index eab146e..29e0dee 100755 |
17 | --- a/interface/vmcs_host/vc_vchi_dispmanx.c | 17 | --- a/interface/vmcs_host/vc_vchi_dispmanx.c |
18 | +++ b/interface/vmcs_host/vc_vchi_dispmanx.c | 18 | +++ b/interface/vmcs_host/vc_vchi_dispmanx.c |
19 | @@ -1306,7 +1306,6 @@ static void *dispmanx_notify_func( void *arg ) { | 19 | @@ -1306,7 +1306,6 @@ static void *dispmanx_notify_func( void *arg ) { |
@@ -25,5 +25,5 @@ index 45f4cff..5d0368c 100755 | |||
25 | } | 25 | } |
26 | } else { | 26 | } else { |
27 | -- | 27 | -- |
28 | 2.12.0 | 28 | 2.15.0 |
29 | 29 | ||
diff --git a/recipes-graphics/userland/userland/0006-zero-out-wl-buffers-in-egl_surface_free.patch b/recipes-graphics/userland/userland/0006-zero-out-wl-buffers-in-egl_surface_free.patch index 196b20b..a8f1f24 100644 --- a/recipes-graphics/userland/userland/0006-zero-out-wl-buffers-in-egl_surface_free.patch +++ b/recipes-graphics/userland/userland/0006-zero-out-wl-buffers-in-egl_surface_free.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 846e9271cf6a264e7e1f4e33be64df990ff39a74 Mon Sep 17 00:00:00 2001 | 1 | From 789b0b0c04b741c21dd573b78eded970721d14c2 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:10:47 -0800 | 3 | Date: Sat, 6 Feb 2016 11:10:47 -0800 |
4 | Subject: [PATCH 06/13] zero-out wl buffers in egl_surface_free | 4 | Subject: [PATCH 06/15] zero-out wl buffers in egl_surface_free |
5 | 5 | ||
6 | origins from buildroot | 6 | origins from buildroot |
7 | 7 | ||
@@ -29,5 +29,5 @@ index 42350bf..1f923d9 100644 | |||
29 | #endif | 29 | #endif |
30 | } | 30 | } |
31 | -- | 31 | -- |
32 | 2.12.0 | 32 | 2.15.0 |
33 | 33 | ||
diff --git a/recipes-graphics/userland/userland/0007-initialize-front-back-wayland-buffers.patch b/recipes-graphics/userland/userland/0007-initialize-front-back-wayland-buffers.patch index 0754921..ad2636a 100644 --- a/recipes-graphics/userland/userland/0007-initialize-front-back-wayland-buffers.patch +++ b/recipes-graphics/userland/userland/0007-initialize-front-back-wayland-buffers.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 15510fdf1c753c967b509046616b1e1a11b5b772 Mon Sep 17 00:00:00 2001 | 1 | From 762dd3156775f167ff0dfd44322dbb19a85822a7 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:11:41 -0800 | 3 | Date: Sat, 6 Feb 2016 11:11:41 -0800 |
4 | Subject: [PATCH 07/13] initialize front back wayland buffers | 4 | Subject: [PATCH 07/15] initialize front back wayland buffers |
5 | 5 | ||
6 | origins from metrological wayland support | 6 | origins from metrological wayland support |
7 | 7 | ||
@@ -30,5 +30,5 @@ index 1f923d9..9a9582c 100644 | |||
30 | } | 30 | } |
31 | #endif | 31 | #endif |
32 | -- | 32 | -- |
33 | 2.12.0 | 33 | 2.15.0 |
34 | 34 | ||
diff --git a/recipes-graphics/userland/userland/0008-Remove-RPC_FLUSH.patch b/recipes-graphics/userland/userland/0008-Remove-RPC_FLUSH.patch index 287e96a..1e66813 100644 --- a/recipes-graphics/userland/userland/0008-Remove-RPC_FLUSH.patch +++ b/recipes-graphics/userland/userland/0008-Remove-RPC_FLUSH.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 1df080ab9528b82321cf87d71927314294ef7121 Mon Sep 17 00:00:00 2001 | 1 | From f8929adbf95ad3d44491cf6fc8a84a686b71193e Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 11:09:18 -0800 | 3 | Date: Sat, 6 Feb 2016 11:09:18 -0800 |
4 | Subject: [PATCH 08/13] Remove RPC_FLUSH | 4 | Subject: [PATCH 08/15] Remove RPC_FLUSH |
5 | 5 | ||
6 | Origins from buildroot | 6 | Origins from buildroot |
7 | 7 | ||
@@ -23,5 +23,5 @@ index f9b7287..b04ffef 100644 | |||
23 | } | 23 | } |
24 | #endif | 24 | #endif |
25 | -- | 25 | -- |
26 | 2.12.0 | 26 | 2.15.0 |
27 | 27 | ||
diff --git a/recipes-graphics/userland/userland/0009-fix-cmake-dependency-race.patch b/recipes-graphics/userland/userland/0009-fix-cmake-dependency-race.patch index 53ccb71..214d5e2 100644 --- a/recipes-graphics/userland/userland/0009-fix-cmake-dependency-race.patch +++ b/recipes-graphics/userland/userland/0009-fix-cmake-dependency-race.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 11842307cc0e32bac6ef7622e7791ca7a0e9fa61 Mon Sep 17 00:00:00 2001 | 1 | From f53e028f33f261f85883c9168977dd5486e9b47c Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 6 Feb 2016 13:12:47 -0800 | 3 | Date: Sat, 6 Feb 2016 13:12:47 -0800 |
4 | Subject: [PATCH 09/13] fix cmake dependency race | 4 | Subject: [PATCH 09/15] fix cmake dependency race |
5 | 5 | ||
6 | Fixes errors like | 6 | Fixes errors like |
7 | 7 | ||
@@ -74,5 +74,5 @@ index f0bae30..8c44c58 100644 | |||
74 | struct wl_resource *resource; | 74 | struct wl_resource *resource; |
75 | struct wl_dispmanx *dispmanx; | 75 | struct wl_dispmanx *dispmanx; |
76 | -- | 76 | -- |
77 | 2.12.0 | 77 | 2.15.0 |
78 | 78 | ||
diff --git a/recipes-graphics/userland/userland/0010-Fix-for-framerate-with-nested-composition.patch b/recipes-graphics/userland/userland/0010-Fix-for-framerate-with-nested-composition.patch index 80e65d5..9f77920 100644 --- a/recipes-graphics/userland/userland/0010-Fix-for-framerate-with-nested-composition.patch +++ b/recipes-graphics/userland/userland/0010-Fix-for-framerate-with-nested-composition.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 532dc7dc11877a9dae0f3d101c9bfdacc50840ca Mon Sep 17 00:00:00 2001 | 1 | From 6559a57c66c5f55571a1aa29cf14d9130a9ef2c9 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Tue, 29 Mar 2016 20:38:30 -0700 | 3 | Date: Tue, 29 Mar 2016 20:38:30 -0700 |
4 | Subject: [PATCH 10/13] Fix for framerate with nested composition | 4 | Subject: [PATCH 10/15] Fix for framerate with nested composition |
5 | 5 | ||
6 | frame rate appears irregular and lower than expected when using nested composition. | 6 | frame rate appears irregular and lower than expected when using nested composition. |
7 | 7 | ||
@@ -56,5 +56,5 @@ index 03fe67b..13a110c 100644 | |||
56 | #ifdef ANDROID | 56 | #ifdef ANDROID |
57 | CLIENT_UNLOCK(); | 57 | CLIENT_UNLOCK(); |
58 | -- | 58 | -- |
59 | 2.12.0 | 59 | 2.15.0 |
60 | 60 | ||
diff --git a/recipes-graphics/userland/userland/0011-build-shared-library-for-vchostif.patch b/recipes-graphics/userland/userland/0011-build-shared-library-for-vchostif.patch index 3a35613..5ee5cbd 100644 --- a/recipes-graphics/userland/userland/0011-build-shared-library-for-vchostif.patch +++ b/recipes-graphics/userland/userland/0011-build-shared-library-for-vchostif.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 37ff90075102407d3abb3899b8c6ef64f6230207 Mon Sep 17 00:00:00 2001 | 1 | From 3e396f0b514f3acf90c02f5d55b3816028367a55 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 2 Apr 2016 10:37:24 -0700 | 3 | Date: Sat, 2 Apr 2016 10:37:24 -0700 |
4 | Subject: [PATCH 11/13] build shared library for vchostif | 4 | Subject: [PATCH 11/15] build shared library for vchostif |
5 | 5 | ||
6 | Fixes #149 | 6 | Fixes #149 |
7 | 7 | ||
@@ -24,5 +24,5 @@ index c415176..d0cca1a 100755 | |||
24 | #add_library(bufman vc_vchi_bufman.c ) | 24 | #add_library(bufman vc_vchi_bufman.c ) |
25 | 25 | ||
26 | -- | 26 | -- |
27 | 2.12.0 | 27 | 2.15.0 |
28 | 28 | ||
diff --git a/recipes-graphics/userland/userland/0012-implement-buffer-wrapping-interface-for-dispmanx.patch b/recipes-graphics/userland/userland/0012-implement-buffer-wrapping-interface-for-dispmanx.patch index c12876b..48af588 100644 --- a/recipes-graphics/userland/userland/0012-implement-buffer-wrapping-interface-for-dispmanx.patch +++ b/recipes-graphics/userland/userland/0012-implement-buffer-wrapping-interface-for-dispmanx.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From ce130bff946c3b78fc4dbbf98d9b16b5152f2e85 Mon Sep 17 00:00:00 2001 | 1 | From f5b2263c8d65e307cb085414e08118cbbe00a94c Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Sat, 2 Apr 2016 10:54:59 -0700 | 3 | Date: Sat, 2 Apr 2016 10:54:59 -0700 |
4 | Subject: [PATCH 12/13] implement buffer wrapping interface for dispmanx | 4 | Subject: [PATCH 12/15] implement buffer wrapping interface for dispmanx |
5 | 5 | ||
6 | Courtesy: Zan Dobersek | 6 | Courtesy: Zan Dobersek |
7 | 7 | ||
@@ -88,5 +88,5 @@ index c18626d..11ed1ef 100644 | |||
88 | 88 | ||
89 | </protocol> | 89 | </protocol> |
90 | -- | 90 | -- |
91 | 2.12.0 | 91 | 2.15.0 |
92 | 92 | ||
diff --git a/recipes-graphics/userland/userland/0013-Implement-triple-buffering-for-wayland.patch b/recipes-graphics/userland/userland/0013-Implement-triple-buffering-for-wayland.patch index da50ffd..d3a9840 100644 --- a/recipes-graphics/userland/userland/0013-Implement-triple-buffering-for-wayland.patch +++ b/recipes-graphics/userland/userland/0013-Implement-triple-buffering-for-wayland.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 14d915a63a4e69290966543ce12edd615bfa9a25 Mon Sep 17 00:00:00 2001 | 1 | From 10ba55489002c2ccdf96d221301ec059c4574811 Mon Sep 17 00:00:00 2001 |
2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> | 2 | From: Jeff Wannamaker <jeff_wannamaker@cable.comcast.com> |
3 | Date: Thu, 19 Jan 2017 18:56:07 +0000 | 3 | Date: Thu, 19 Jan 2017 18:56:07 +0000 |
4 | Subject: [PATCH 13/13] Implement triple buffering for wayland | 4 | Subject: [PATCH 13/15] Implement triple buffering for wayland |
5 | 5 | ||
6 | Change from double to triple buffering for wayland. | 6 | Change from double to triple buffering for wayland. |
7 | This enables higher frame rates without tearing artifacts | 7 | This enables higher frame rates without tearing artifacts |
@@ -67,10 +67,11 @@ diff --git a/interface/khronos/egl/egl_client_surface.h b/interface/khronos/egl/ | |||
67 | index e328b77..58a3184 100644 | 67 | index e328b77..58a3184 100644 |
68 | --- a/interface/khronos/egl/egl_client_surface.h | 68 | --- a/interface/khronos/egl/egl_client_surface.h |
69 | +++ b/interface/khronos/egl/egl_client_surface.h | 69 | +++ b/interface/khronos/egl/egl_client_surface.h |
70 | @@ -313,6 +313,17 @@ typedef struct { | 70 | @@ -312,6 +312,17 @@ typedef struct { |
71 | */ | ||
71 | struct wl_dispmanx_client_buffer *front_wl_buffer; | 72 | struct wl_dispmanx_client_buffer *front_wl_buffer; |
72 | 73 | ||
73 | /* | 74 | + /* |
74 | + middle_wl_buffer | 75 | + middle_wl_buffer |
75 | + | 76 | + |
76 | + Validity: | 77 | + Validity: |
@@ -81,10 +82,9 @@ index e328b77..58a3184 100644 | |||
81 | + */ | 82 | + */ |
82 | + struct wl_dispmanx_client_buffer *middle_wl_buffer; | 83 | + struct wl_dispmanx_client_buffer *middle_wl_buffer; |
83 | + | 84 | + |
84 | + /* | 85 | /* |
85 | back_wl_buffer | 86 | back_wl_buffer |
86 | 87 | ||
87 | Validity: | ||
88 | -- | 88 | -- |
89 | 2.12.0 | 89 | 2.15.0 |
90 | 90 | ||
diff --git a/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch index 2232d4b..b596056 100644 --- a/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch +++ b/recipes-graphics/userland/userland/0014-GLES2-gl2ext.h-Define-GL_R8_EXT-and-GL_RG8_EXT.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 55a66f56a14eb8c3ae8294860e49efc9c9598c46 Mon Sep 17 00:00:00 2001 | 1 | From d750c738b5c23bba24531cb713292e4ab3f2ec56 Mon Sep 17 00:00:00 2001 |
2 | From: Khem Raj <raj.khem@gmail.com> | 2 | From: Khem Raj <raj.khem@gmail.com> |
3 | Date: Wed, 10 May 2017 06:39:34 +0000 | 3 | Date: Wed, 10 May 2017 06:39:34 +0000 |
4 | Subject: [PATCH] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT | 4 | Subject: [PATCH 14/15] GLES2/gl2ext.h: Define GL_R8_EXT and GL_RG8_EXT |
5 | 5 | ||
6 | weston code uses these defines | 6 | weston code uses these defines |
7 | Upstream-Status: Pending | 7 | Upstream-Status: Pending |
@@ -26,5 +26,5 @@ index 4eacf7f..283e3e1 100644 | |||
26 | #ifndef GL_EXT_texture_type_2_10_10_10_REV | 26 | #ifndef GL_EXT_texture_type_2_10_10_10_REV |
27 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 | 27 | #define GL_UNSIGNED_INT_2_10_10_10_REV_EXT 0x8368 |
28 | -- | 28 | -- |
29 | 1.9.1 | 29 | 2.15.0 |
30 | 30 | ||
diff --git a/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch b/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch index 5a80a26..f10740b 100644 --- a/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch +++ b/recipes-graphics/userland/userland/0015-EGL-glplatform.h-define-EGL_CAST.patch | |||
@@ -1,7 +1,7 @@ | |||
1 | From 382e3b16cbcc09d825540d5bd3e45a2fca4484fe Mon Sep 17 00:00:00 2001 | 1 | From 827907f2223df93918e680101a1ac6228ba0f07e Mon Sep 17 00:00:00 2001 |
2 | From: Andrea Galbusera <gizero@gmail.com> | 2 | From: Andrea Galbusera <gizero@gmail.com> |
3 | Date: Fri, 14 Jul 2017 09:52:54 +0200 | 3 | Date: Fri, 14 Jul 2017 09:52:54 +0200 |
4 | Subject: [PATCH] EGL/glplatform.h: define EGL_CAST | 4 | Subject: [PATCH 15/15] EGL/glplatform.h: define EGL_CAST |
5 | 5 | ||
6 | C++ / C typecast macros for special EGL handle values: used by libepoxy code | 6 | C++ / C typecast macros for special EGL handle values: used by libepoxy code |
7 | The definition comes from the updated version of this header in mesa. | 7 | The definition comes from the updated version of this header in mesa. |
@@ -28,5 +28,5 @@ index 1f7c930..c39d425 100644 | |||
28 | + | 28 | + |
29 | #endif /* __eglplatform_h */ | 29 | #endif /* __eglplatform_h */ |
30 | -- | 30 | -- |
31 | 2.7.4 | 31 | 2.15.0 |
32 | 32 | ||
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb index d4624bf..d38b02d 100644 --- a/recipes-graphics/userland/userland_git.bb +++ b/recipes-graphics/userland/userland_git.bb | |||
@@ -16,7 +16,7 @@ COMPATIBLE_MACHINE = "^rpi$" | |||
16 | 16 | ||
17 | SRCBRANCH = "master" | 17 | SRCBRANCH = "master" |
18 | SRCFORK = "raspberrypi" | 18 | SRCFORK = "raspberrypi" |
19 | SRCREV = "3caf0cd4a61f46b71eff49422c36e1cd2727ab45" | 19 | SRCREV = "bc3c52a51315399a9f31ed24049eb4bc81fd1c60" |
20 | 20 | ||
21 | SRC_URI = "\ | 21 | SRC_URI = "\ |
22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ | 22 | git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ |