summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/userland/userland/0001-Fix-VCOS_INLINE_DECL-to-not-use-extern-inlines-in-de.patch45
-rw-r--r--recipes-graphics/userland/userland/0001-fix-gcc-5.x-inlines.patch26
-rw-r--r--recipes-graphics/userland/userland/0002-fix-musl-build.patch22
-rw-r--r--recipes-graphics/userland/userland/0002-musl-inspired-fixed.patch29
-rw-r--r--recipes-graphics/userland/userland/0003-fix-alloc-size-uninitialized.patch13
-rw-r--r--recipes-graphics/userland/userland/0003-set-VMCS_INSTALL_PREFIX-to-usr.patch (renamed from recipes-graphics/userland/userland/0002-set-VMCS_INSTALL_PREFIX-to-usr.patch)7
-rw-r--r--recipes-graphics/userland/userland/0004-cmake-generate-and-install-pkgconfig-files.patch (renamed from recipes-graphics/userland/userland/0003-cmake-generate-and-install-pkgconfig-files.patch)20
-rw-r--r--recipes-graphics/userland/userland_git.bb15
8 files changed, 94 insertions, 83 deletions
diff --git a/recipes-graphics/userland/userland/0001-Fix-VCOS_INLINE_DECL-to-not-use-extern-inlines-in-de.patch b/recipes-graphics/userland/userland/0001-Fix-VCOS_INLINE_DECL-to-not-use-extern-inlines-in-de.patch
new file mode 100644
index 0000000..4824d1a
--- /dev/null
+++ b/recipes-graphics/userland/userland/0001-Fix-VCOS_INLINE_DECL-to-not-use-extern-inlines-in-de.patch
@@ -0,0 +1,45 @@
1From d0b146e6571585989e7149a512533fcd6532545a Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:00:25 -0800
4Subject: [PATCH 01/16] Fix VCOS_INLINE_DECL to not use extern inlines in
5 declarations
6
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 interface/vcos/pthreads/vcos_platform_types.h | 2 +-
10 interface/vcos/vcos_types.h | 4 ++--
11 2 files changed, 3 insertions(+), 3 deletions(-)
12
13diff --git a/interface/vcos/pthreads/vcos_platform_types.h b/interface/vcos/pthreads/vcos_platform_types.h
14index 17b422d..64fb381 100644
15--- a/interface/vcos/pthreads/vcos_platform_types.h
16+++ b/interface/vcos/pthreads/vcos_platform_types.h
17@@ -61,7 +61,7 @@ vcos_pthreads_logging_assert(const char *file, const char *func, unsigned int li
18 #define VCOS_ASSERT_MSG(...) ((VCOS_ASSERT_LOGGING && !VCOS_ASSERT_LOGGING_DISABLE) ? vcos_pthreads_logging_assert(__FILE__, __func__, __LINE__, __VA_ARGS__) : (void)0)
19
20 #define VCOS_INLINE_BODIES
21-#define VCOS_INLINE_DECL extern __inline__
22+#define VCOS_INLINE_DECL extern
23 #define VCOS_INLINE_IMPL static __inline__
24
25 #ifdef __cplusplus
26diff --git a/interface/vcos/vcos_types.h b/interface/vcos/vcos_types.h
27index 6feb4d2..e64fd99 100644
28--- a/interface/vcos/vcos_types.h
29+++ b/interface/vcos/vcos_types.h
30@@ -121,10 +121,10 @@ typedef enum
31 #if defined(NDEBUG)
32
33 #ifdef __GNUC__
34-# define VCOS_INLINE_DECL extern __inline__
35+# define VCOS_INLINE_DECL extern
36 # define VCOS_INLINE_IMPL static __inline__
37 #else
38-# define VCOS_INLINE_DECL static _VCOS_INLINE /* declare a func */
39+# define VCOS_INLINE_DECL extern
40 # define VCOS_INLINE_IMPL static _VCOS_INLINE /* implement a func inline */
41 #endif
42
43--
442.7.0
45
diff --git a/recipes-graphics/userland/userland/0001-fix-gcc-5.x-inlines.patch b/recipes-graphics/userland/userland/0001-fix-gcc-5.x-inlines.patch
deleted file mode 100644
index 57f3518..0000000
--- a/recipes-graphics/userland/userland/0001-fix-gcc-5.x-inlines.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1--- userland-fb11b39d97371c076eef7c85bbcab5733883a41e.orig/interface/vcos/vcos_types.h
2+++ userland-fb11b39d97371c076eef7c85bbcab5733883a41e/interface/vcos/vcos_types.h
3@@ -121,10 +121,10 @@
4 #if defined(NDEBUG)
5
6 #ifdef __GNUC__
7-# define VCOS_INLINE_DECL extern __inline__
8+# define VCOS_INLINE_DECL extern
9 # define VCOS_INLINE_IMPL static __inline__
10 #else
11-# define VCOS_INLINE_DECL static _VCOS_INLINE /* declare a func */
12+# define VCOS_INLINE_DECL extern
13 # define VCOS_INLINE_IMPL static _VCOS_INLINE /* implement a func inline */
14 #endif
15
16--- userland-fb11b39d97371c076eef7c85bbcab5733883a41e.orig/interface/vcos/pthreads/vcos_platform_types.h
17+++ userland-fb11b39d97371c076eef7c85bbcab5733883a41e/interface/vcos/pthreads/vcos_platform_types.h
18@@ -61,7 +61,7 @@
19 #define VCOS_ASSERT_MSG(...) ((VCOS_ASSERT_LOGGING && !VCOS_ASSERT_LOGGING_DISABLE) ? vcos_pthreads_logging_assert(__FILE__, __func__, __LINE__, __VA_ARGS__) : (void)0)
20
21 #define VCOS_INLINE_BODIES
22-#define VCOS_INLINE_DECL extern __inline__
23+#define VCOS_INLINE_DECL extern
24 #define VCOS_INLINE_IMPL static __inline__
25
26 #ifdef __cplusplus
diff --git a/recipes-graphics/userland/userland/0002-fix-musl-build.patch b/recipes-graphics/userland/userland/0002-fix-musl-build.patch
deleted file mode 100644
index 2fb11e7..0000000
--- a/recipes-graphics/userland/userland/0002-fix-musl-build.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1--- userland-d4aa617de3b196399bb8e2ce32e181768cb52179.orig/host_applications/linux/apps/raspicam/RaspiVidYUV.c
2+++ userland-d4aa617de3b196399bb8e2ce32e181768cb52179/host_applications/linux/apps/raspicam/RaspiVidYUV.c
3@@ -106,8 +106,6 @@
4 /// Run/record forever
5 #define WAIT_METHOD_FOREVER 4
6
7-extern FILE *stderr, *stdout;
8-
9 int mmal_status_to_int(MMAL_STATUS_T status);
10 static void signal_handler(int signal_number);
11
12--- userland-d4aa617de3b196399bb8e2ce32e181768cb52179.orig/host_applications/linux/libs/debug_sym/debug_sym.c
13+++ userland-d4aa617de3b196399bb8e2ce32e181768cb52179/host_applications/linux/libs/debug_sym/debug_sym.c
14@@ -67,6 +67,8 @@
15 # else
16 # define PAGE_SIZE 4096
17 # endif
18+#endif
19+#ifndef PAGE_MASK
20 #define PAGE_MASK (~(PAGE_SIZE - 1))
21 #endif
22
diff --git a/recipes-graphics/userland/userland/0002-musl-inspired-fixed.patch b/recipes-graphics/userland/userland/0002-musl-inspired-fixed.patch
new file mode 100644
index 0000000..bbb670d
--- /dev/null
+++ b/recipes-graphics/userland/userland/0002-musl-inspired-fixed.patch
@@ -0,0 +1,29 @@
1From 9856330f54c181e388df6f261c705e01500cf0bb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 6 Feb 2016 11:03:10 -0800
4Subject: [PATCH 02/16] musl inspired fixed
5
6stderr and stdout are not FILE pointers as per standards
7define PAGE_MASK if its not defined already
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 host_applications/linux/libs/debug_sym/debug_sym.c | 2 ++
12 1 file changed, 2 insertions(+)
13
14diff --git a/host_applications/linux/libs/debug_sym/debug_sym.c b/host_applications/linux/libs/debug_sym/debug_sym.c
15index 8886f99..c7ace37 100755
16--- a/host_applications/linux/libs/debug_sym/debug_sym.c
17+++ b/host_applications/linux/libs/debug_sym/debug_sym.c
18@@ -67,6 +67,8 @@ SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
19 # else
20 # define PAGE_SIZE 4096
21 # endif
22+#endif
23+#ifndef PAGE_MASK
24 #define PAGE_MASK (~(PAGE_SIZE - 1))
25 #endif
26
27--
282.7.0
29
diff --git a/recipes-graphics/userland/userland/0003-fix-alloc-size-uninitialized.patch b/recipes-graphics/userland/userland/0003-fix-alloc-size-uninitialized.patch
deleted file mode 100644
index 7dd6436..0000000
--- a/recipes-graphics/userland/userland/0003-fix-alloc-size-uninitialized.patch
+++ /dev/null
@@ -1,13 +0,0 @@
1diff --git a/host_applications/linux/apps/smem/smem.c b/host_applications/linux/apps/smem/smem.c
2index f780b79..618580e 100644
3--- a/host_applications/linux/apps/smem/smem.c
4+++ b/host_applications/linux/apps/smem/smem.c
5@@ -192,7 +192,7 @@ int main( int argc, char **argv )
6 int opt;
7 int opt_alloc = 0;
8 int opt_status = 0;
9- uint32_t alloc_size;
10+ uint32_t alloc_size = 0;
11 int opt_pid = -1;
12 VCSM_STATUS_T status_mode = VCSM_STATUS_NONE;
13
diff --git a/recipes-graphics/userland/userland/0002-set-VMCS_INSTALL_PREFIX-to-usr.patch b/recipes-graphics/userland/userland/0003-set-VMCS_INSTALL_PREFIX-to-usr.patch
index 1c981af..2829196 100644
--- a/recipes-graphics/userland/userland/0002-set-VMCS_INSTALL_PREFIX-to-usr.patch
+++ b/recipes-graphics/userland/userland/0003-set-VMCS_INSTALL_PREFIX-to-usr.patch
@@ -1,13 +1,12 @@
1From 05554d8486050546efc3c0605015786c8b267d19 Mon Sep 17 00:00:00 2001 1From 8792a3645822c3ee2cea74def2a48e3e7f247ee1 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 9 Aug 2015 23:58:17 -0700 3Date: Sun, 9 Aug 2015 23:58:17 -0700
4Subject: [PATCH 1/2] set VMCS_INSTALL_PREFIX to /usr 4Subject: [PATCH 03/16] set VMCS_INSTALL_PREFIX to /usr
5 5
6in OE we dont use /opt/vc but standard prefix 6in OE we dont use /opt/vc but standard prefix
7 7
8Signed-off-by: Khem Raj <raj.khem@gmail.com> 8Signed-off-by: Khem Raj <raj.khem@gmail.com>
9--- 9---
10Upstream-Status: Submitted
11 makefiles/cmake/vmcs.cmake | 2 +- 10 makefiles/cmake/vmcs.cmake | 2 +-
12 1 file changed, 1 insertion(+), 1 deletion(-) 11 1 file changed, 1 insertion(+), 1 deletion(-)
13 12
@@ -25,5 +24,5 @@ index 0f8641b..e9d576d 100644
25 24
26 SET(CMAKE_INSTALL_PREFIX "${VMCS_INSTALL_PREFIX}" CACHE INTERNAL "Prefix 25 SET(CMAKE_INSTALL_PREFIX "${VMCS_INSTALL_PREFIX}" CACHE INTERNAL "Prefix
27-- 26--
282.1.4 272.7.0
29 28
diff --git a/recipes-graphics/userland/userland/0003-cmake-generate-and-install-pkgconfig-files.patch b/recipes-graphics/userland/userland/0004-cmake-generate-and-install-pkgconfig-files.patch
index c644d52..aa209b2 100644
--- a/recipes-graphics/userland/userland/0003-cmake-generate-and-install-pkgconfig-files.patch
+++ b/recipes-graphics/userland/userland/0004-cmake-generate-and-install-pkgconfig-files.patch
@@ -1,20 +1,19 @@
1From ef43e09c2d13b88c2e92cffc94b68003afcb1f13 Mon Sep 17 00:00:00 2001 1From 59fd98d2ee9076c08d020167e5176e2e3e669917 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 9 Aug 2015 23:59:32 -0700 3Date: Sun, 9 Aug 2015 23:59:32 -0700
4Subject: [PATCH 2/2] cmake: generate and install pkgconfig files 4Subject: [PATCH 04/17] cmake: generate and install pkgconfig files
5 5
6many packages expect packageconfig support especially for detecting EGL 6many packages expect packageconfig support especially for detecting EGL
7libraries. This patch helps in compiling those packages on RPi 7libraries. This patch helps in compiling those packages on RPi
8 8
9Signed-off-by: Khem Raj <raj.khem@gmail.com> 9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10--- 10---
11Upstream-Status: Submitted
12 CMakeLists.txt | 10 +++++++++- 11 CMakeLists.txt | 10 +++++++++-
13 pkgconfig/bcm_host.pc.in | 10 ++++++++++ 12 pkgconfig/bcm_host.pc.in | 10 ++++++++++
14 pkgconfig/egl.pc.in | 12 ++++++++++++ 13 pkgconfig/egl.pc.in | 13 +++++++++++++
15 pkgconfig/glesv2.pc.in | 12 ++++++++++++ 14 pkgconfig/glesv2.pc.in | 12 ++++++++++++
16 pkgconfig/vg.pc.in | 11 +++++++++++ 15 pkgconfig/vg.pc.in | 11 +++++++++++
17 5 files changed, 54 insertions(+), 1 deletion(-) 16 5 files changed, 55 insertions(+), 1 deletion(-)
18 create mode 100644 pkgconfig/bcm_host.pc.in 17 create mode 100644 pkgconfig/bcm_host.pc.in
19 create mode 100644 pkgconfig/egl.pc.in 18 create mode 100644 pkgconfig/egl.pc.in
20 create mode 100644 pkgconfig/glesv2.pc.in 19 create mode 100644 pkgconfig/glesv2.pc.in
@@ -58,10 +57,10 @@ index 0000000..c7237c5
58+Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM 57+Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux -I${includedir}/interface/vcos/pthreads -DUSE_VCHIQ_ARM
59diff --git a/pkgconfig/egl.pc.in b/pkgconfig/egl.pc.in 58diff --git a/pkgconfig/egl.pc.in b/pkgconfig/egl.pc.in
60new file mode 100644 59new file mode 100644
61index 0000000..4e3d6ac 60index 0000000..27a6236
62--- /dev/null 61--- /dev/null
63+++ b/pkgconfig/egl.pc.in 62+++ b/pkgconfig/egl.pc.in
64@@ -0,0 +1,12 @@ 63@@ -0,0 +1,13 @@
65+prefix=@CMAKE_INSTALL_PREFIX@ 64+prefix=@CMAKE_INSTALL_PREFIX@
66+exec_prefix=${prefix} 65+exec_prefix=${prefix}
67+libdir=${exec_prefix}/lib 66+libdir=${exec_prefix}/lib
@@ -71,8 +70,9 @@ index 0000000..4e3d6ac
71+Description: Fake EGL package for RPi 70+Description: Fake EGL package for RPi
72+Version: 10 71+Version: 10
73+Requires: bcm_host 72+Requires: bcm_host
74+Libs: -L${libdir} -lEGL 73+Libs: -L${libdir} -lEGL -lGLESv2 -lbcm_host -lvchostif
75+Cflags: -I${includedir} 74+Cflags: -I${includedir} -I${includedir}/interface/vmcs_host/linux \
75+ -I${includedir}/interface/vcos/pthreads
76+ 76+
77diff --git a/pkgconfig/glesv2.pc.in b/pkgconfig/glesv2.pc.in 77diff --git a/pkgconfig/glesv2.pc.in b/pkgconfig/glesv2.pc.in
78new file mode 100644 78new file mode 100644
@@ -110,5 +110,5 @@ index 0000000..8c39c98
110+Libs: -L${libdir} -lOpenVG 110+Libs: -L${libdir} -lOpenVG
111+Cflags: -I${includedir} 111+Cflags: -I${includedir}
112-- 112--
1132.1.4 1132.7.1
114 114
diff --git a/recipes-graphics/userland/userland_git.bb b/recipes-graphics/userland/userland_git.bb
index 5bf4dda..4323228 100644
--- a/recipes-graphics/userland/userland_git.bb
+++ b/recipes-graphics/userland/userland_git.bb
@@ -2,8 +2,8 @@ DESCRIPTION = "This repository contains the source code for the ARM side \
2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \ 2libraries used on Raspberry Pi. These typically are installed in /opt/vc/lib \
3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\ 3and includes source for the ARM side code to interface to: EGL, mmal, GLESv2,\
4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG." 4vcos, openmaxil, vchiq_arm, bcm_host, WFC, OpenVG."
5LICENSE = "Broadcom" 5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENCE;md5=957f6640d5e2d2acfce73a36a56cb32f" 6LIC_FILES_CHKSUM = "file://LICENCE;md5=0448d6488ef8cc380632b1569ee6d196"
7 7
8PR = "r5" 8PR = "r5"
9 9
@@ -14,15 +14,14 @@ COMPATIBLE_MACHINE = "raspberrypi"
14 14
15SRCBRANCH = "master" 15SRCBRANCH = "master"
16SRCFORK = "raspberrypi" 16SRCFORK = "raspberrypi"
17SRCREV = "40e377862410371a9962db79b81fd4f0f266430a" 17SRCREV = "2a4af2192c0e161555fdb2a12e902b587166c4a6"
18 18
19SRC_URI = "\ 19SRC_URI = "\
20 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \ 20 git://github.com/${SRCFORK}/userland.git;protocol=git;branch=${SRCBRANCH} \
21 file://0001-fix-gcc-5.x-inlines.patch \ 21 file://0001-Fix-VCOS_INLINE_DECL-to-not-use-extern-inlines-in-de.patch \
22 file://0002-fix-musl-build.patch \ 22 file://0002-musl-inspired-fixed.patch \
23 file://0003-fix-alloc-size-uninitialized.patch \ 23 file://0003-set-VMCS_INSTALL_PREFIX-to-usr.patch \
24 file://0002-set-VMCS_INSTALL_PREFIX-to-usr.patch \ 24 file://0004-cmake-generate-and-install-pkgconfig-files.patch \
25 file://0003-cmake-generate-and-install-pkgconfig-files.patch \
26 " 25 "
27 26
28S = "${WORKDIR}/git" 27S = "${WORKDIR}/git"