diff options
-rw-r--r-- | recipes-devtools/pi-blaster/pi-blaster.inc | 21 | ||||
-rw-r--r-- | recipes-devtools/pi-blaster/pi-blaster_git.bb | 22 |
2 files changed, 21 insertions, 22 deletions
diff --git a/recipes-devtools/pi-blaster/pi-blaster.inc b/recipes-devtools/pi-blaster/pi-blaster.inc deleted file mode 100644 index 3cb79cc..0000000 --- a/recipes-devtools/pi-blaster/pi-blaster.inc +++ /dev/null | |||
@@ -1,21 +0,0 @@ | |||
1 | DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi." | ||
2 | HOMEPAGE = "https://github.com/sarfata/pi-blaster/" | ||
3 | SECTION = "devel/libs" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3" | ||
6 | |||
7 | SRC_URI = "git://github.com/sarfata/pi-blaster \ | ||
8 | file://remove-initscript-lsb-dependency.patch \ | ||
9 | " | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
12 | |||
13 | inherit update-rc.d autotools | ||
14 | |||
15 | INITSCRIPT_PACKAGES = "${PN}" | ||
16 | INITSCRIPT_NAME_${PN} = "${PN}.boot.sh" | ||
17 | INITSCRIPT_PARAMS_${PN} = "defaults 15 85" | ||
18 | |||
19 | COMPATIBLE_MACHINE = "^rpi$" | ||
20 | |||
21 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
diff --git a/recipes-devtools/pi-blaster/pi-blaster_git.bb b/recipes-devtools/pi-blaster/pi-blaster_git.bb index 730f9d3..2748459 100644 --- a/recipes-devtools/pi-blaster/pi-blaster_git.bb +++ b/recipes-devtools/pi-blaster/pi-blaster_git.bb | |||
@@ -1,3 +1,23 @@ | |||
1 | require pi-blaster.inc | 1 | DESCRIPTION = "This project enables PWM on the GPIO pins you request of a Raspberry Pi." |
2 | HOMEPAGE = "https://github.com/sarfata/pi-blaster/" | ||
3 | SECTION = "devel/libs" | ||
4 | LICENSE = "MIT" | ||
5 | LIC_FILES_CHKSUM = "file://README.md;beginline=225;endline=252;md5=a012868ef5f83b9f257af253d7cb07a3" | ||
6 | |||
7 | SRC_URI = "git://github.com/sarfata/pi-blaster \ | ||
8 | file://remove-initscript-lsb-dependency.patch \ | ||
9 | " | ||
10 | |||
11 | S = "${WORKDIR}/git" | ||
2 | 12 | ||
3 | SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98" | 13 | SRCREV = "1035ad7dffb270c40eec1bb3a654171a755fba98" |
14 | |||
15 | inherit update-rc.d autotools | ||
16 | |||
17 | INITSCRIPT_PACKAGES = "${PN}" | ||
18 | INITSCRIPT_NAME_${PN} = "${PN}.boot.sh" | ||
19 | INITSCRIPT_PARAMS_${PN} = "defaults 15 85" | ||
20 | |||
21 | COMPATIBLE_MACHINE = "^rpi$" | ||
22 | |||
23 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||