summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-core/images/core-image-rorootfs-overlay-initramfs.bb15
1 files changed, 13 insertions, 2 deletions
diff --git a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
index 4c21555..edb4ed9 100644
--- a/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
+++ b/recipes-core/images/core-image-rorootfs-overlay-initramfs.bb
@@ -3,12 +3,20 @@ DESCRIPTION = "Small image capable of booting a device. The kernel includes \
3the Minimal RAM-based Initial Root Filesystem (initramfs), mounts the root fs \ 3the Minimal RAM-based Initial Root Filesystem (initramfs), mounts the root fs \
4read only and uses a file system overlay for written data." 4read only and uses a file system overlay for written data."
5 5
6PACKAGE_INSTALL = "initramfs-readonly-rootfs-overlay ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}" 6INITRAMFS_SCRIPTS ?= "\
7 initramfs-framework-base \
8 initramfs-module-setup-live \
9 initramfs-module-udev \
10 initramfs-module-install \
11 initramfs-module-install-efi \
12 "
13
14PACKAGE_INSTALL = "initramfs-readonly-rootfs-overlay ${INITRAMFS_SCRIPTS} ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
7 15
8# Do not pollute the initrd image with rootfs features 16# Do not pollute the initrd image with rootfs features
9IMAGE_FEATURES = "" 17IMAGE_FEATURES = ""
10 18
11export IMAGE_BASENAME = "core-image-readonly-rootfs-overlay-initramfs" 19export IMAGE_BASENAME = "${MLPREFIX}core-image-rorootfs-overlay-initramfs"
12IMAGE_LINGUAS = "" 20IMAGE_LINGUAS = ""
13 21
14LICENSE = "MIT" 22LICENSE = "MIT"
@@ -20,3 +28,6 @@ IMAGE_ROOTFS_SIZE = "8192"
20IMAGE_ROOTFS_EXTRA_SPACE = "0" 28IMAGE_ROOTFS_EXTRA_SPACE = "0"
21 29
22BAD_RECOMMENDATIONS += "busybox-syslog" 30BAD_RECOMMENDATIONS += "busybox-syslog"
31
32# Use the same restriction as initramfs-live-install
33COMPATIBLE_HOST = "(i.86|x86_64).*-linux"