diff options
author | Jason Wessel <jason.wessel@windriver.com> | 2019-11-04 13:18:05 -0800 |
---|---|---|
committer | Jia Zhang <zhang.jia@linux.alibaba.com> | 2019-11-08 13:27:23 +0800 |
commit | 382ffa19cf3d22a6cdcff1c2a1bc78e0ecc5858c (patch) | |
tree | 339b63a3542831b88f2b491efce4acfa9df014bd | |
parent | fab7b8d93da0d7aad865d98b61c33e0529a44437 (diff) | |
download | meta-secure-core-382ffa19cf3d22a6cdcff1c2a1bc78e0ecc5858c.tar.gz |
efitools: Fix compilation problem with latest /usr/include/efi
| gcc -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/git/include/ -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/x86_64 -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/protocol -O2 -g -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector -ffreestanding -fno-stack-check -DGNU_EFI_USE_MS_ABI -DEFI_FUNCTION_WRAPPER -mno-red-zone -DCONFIG_x86_64 -fno-toplevel-reorder -DBUILD_EFI -c console.c -o console.efi.o
| console.c:360:5: error: ‘EFI_WARN_UNKOWN_GLYPH’ undeclared here (not in a function); did you mean ‘EFI_WARN_UNKNOWN_GLYPH’?
| { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"},
| ^~~~~~~~~~~~~~~~~~~~~
| EFI_WARN_UNKNOWN_GLYPH
| ../Make.rules:113: recipe for target 'console.efi.o' failed
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
-rw-r--r-- | meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch | 39 | ||||
-rw-r--r-- | meta-efi-secure-boot/recipes-bsp/efitools/efitools_git.bb | 1 |
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch b/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch new file mode 100644 index 0000000..fb7ac4b --- /dev/null +++ b/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From: Jason Wessel <jason.wessel@windriver.com> | ||
2 | Date: Mon, 4 Nov 2019 12:42:49 -0800 | ||
3 | Subject: [PATCH] console.c: Fix compilation against latest /usr/include/efi | ||
4 | MIME-Version: 1.0 | ||
5 | Content-Type: text/plain; charset=UTF-8 | ||
6 | Content-Transfer-Encoding: 8bit | ||
7 | |||
8 | | gcc -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/git/include/ -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/x86_64 -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/protocol -O2 -g -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector -ffreestanding -fno-stack-check -DGNU_EFI_USE_MS_ABI -DEFI_FUNCTION_WRAPPER -mno-red-zone -DCONFIG_x86_64 -fno-toplevel-reorder -DBUILD_EFI -c console.c -o console.efi.o | ||
9 | | console.c:360:5: error: ‘EFI_WARN_UNKOWN_GLYPH’ undeclared here (not in a function); did you mean ‘EFI_WARN_UNKNOWN_GLYPH’? | ||
10 | | { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~ | ||
12 | | EFI_WARN_UNKNOWN_GLYPH | ||
13 | | ../Make.rules:113: recipe for target 'console.efi.o' failed | ||
14 | | | ||
15 | |||
16 | |||
17 | Upstream-Status: Pending | ||
18 | |||
19 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | ||
20 | --- | ||
21 | lib/console.c | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/lib/console.c b/lib/console.c | ||
25 | index 9c10560..b932a44 100644 | ||
26 | --- a/lib/console.c | ||
27 | +++ b/lib/console.c | ||
28 | @@ -357,7 +357,7 @@ static struct { | ||
29 | { EFI_SECURITY_VIOLATION, L"Security Violation"}, | ||
30 | |||
31 | // warnings | ||
32 | - { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
33 | + { EFI_WARN_UNKNOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
34 | { EFI_WARN_DELETE_FAILURE, L"Warning Delete Failure"}, | ||
35 | { EFI_WARN_WRITE_FAILURE, L"Warning Write Failure"}, | ||
36 | { EFI_WARN_BUFFER_TOO_SMALL, L"Warning Buffer Too Small"}, | ||
37 | -- | ||
38 | 2.23.0 | ||
39 | |||
diff --git a/meta-efi-secure-boot/recipes-bsp/efitools/efitools_git.bb b/meta-efi-secure-boot/recipes-bsp/efitools/efitools_git.bb index 56ce41c..efa8674 100644 --- a/meta-efi-secure-boot/recipes-bsp/efitools/efitools_git.bb +++ b/meta-efi-secure-boot/recipes-bsp/efitools/efitools_git.bb | |||
@@ -10,6 +10,7 @@ SRC_URI_append += "\ | |||
10 | file://Build-DBX-by-default.patch \ | 10 | file://Build-DBX-by-default.patch \ |
11 | file://LockDown-disable-the-entrance-into-BIOS-setup-to-re-.patch \ | 11 | file://LockDown-disable-the-entrance-into-BIOS-setup-to-re-.patch \ |
12 | file://Fix-help2man-error.patch \ | 12 | file://Fix-help2man-error.patch \ |
13 | file://0001-console.c-Fix-compilation-against-latest-usr-include.patch \ | ||
13 | " | 14 | " |
14 | 15 | ||
15 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' | 16 | COMPATIBLE_HOST = '(i.86|x86_64).*-linux' |