summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2020-09-01 18:45:20 -0700
committerJia Zhang <zhang.jia@linux.alibaba.com>2020-09-23 15:57:43 +0800
commit4d59dc3037e54880bd3016839936e03364e63eb0 (patch)
tree973ec54d47b66a1155b30c9f299c9d5275c95e39
parent6c64d71334ab6bc9c1f9e6e66f8f692dd2af0943 (diff)
downloadmeta-secure-core-4d59dc3037e54880bd3016839936e03364e63eb0.tar.gz
trousers: fix build failure for gcc-10
gcc-10 uses '-fno-common' by default, causing build error of multiple definition. Use '-fcommon' to fix this problem. Signed-off-by: Chen Qi <Qi.Chen@windriver.com>
-rw-r--r--meta-tpm/recipes-tpm/trousers/trousers_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-tpm/recipes-tpm/trousers/trousers_git.bb b/meta-tpm/recipes-tpm/trousers/trousers_git.bb
index f899f5e..601d35d 100644
--- a/meta-tpm/recipes-tpm/trousers/trousers_git.bb
+++ b/meta-tpm/recipes-tpm/trousers/trousers_git.bb
@@ -38,6 +38,9 @@ inherit autotools pkgconfig useradd update-rc.d \
38 38
39EXTRA_OECONF="--with-gui=none" 39EXTRA_OECONF="--with-gui=none"
40 40
41# Fix build failure for gcc-10
42CFLAGS_append = " -fcommon"
43
41PACKAGECONFIG ?= "gmp " 44PACKAGECONFIG ?= "gmp "
42PACKAGECONFIG[gmp] = "--with-gmp, --with-gmp=no, gmp" 45PACKAGECONFIG[gmp] = "--with-gmp, --with-gmp=no, gmp"
43PACKAGECONFIG[gtk] = "--with-gui=gtk, --with-gui=none, gtk+" 46PACKAGECONFIG[gtk] = "--with-gui=gtk, --with-gui=none, gtk+"