diff options
author | Abdelrahman Ibrahem <abdelrahman.ibrahem@signify.com> | 2020-01-23 17:39:22 +0100 |
---|---|---|
committer | Jia Zhang <zhang.jia@linux.alibaba.com> | 2020-04-08 21:52:18 +0800 |
commit | a6c3d9fcd2da0d20f2916d36557a73ad8790fd1c (patch) | |
tree | 7669cbf9cae5dc2854cf77f15fbfb4ffe46e8695 | |
parent | e8e80fb7c4971bb05e14ec5e329c1435ba485b2b (diff) | |
download | meta-secure-core-a6c3d9fcd2da0d20f2916d36557a73ad8790fd1c.tar.gz |
Removed unneeded patch to fix compilation error in efi-tool's console.c
4 files changed, 0 insertions, 80 deletions
diff --git a/meta-efi-secure-boot/recipes-bsp/efitools/efitools.inc b/meta-efi-secure-boot/recipes-bsp/efitools/efitools.inc index 9f4bec4..1c014cd 100644 --- a/meta-efi-secure-boot/recipes-bsp/efitools/efitools.inc +++ b/meta-efi-secure-boot/recipes-bsp/efitools/efitools.inc | |||
@@ -29,7 +29,6 @@ SRC_URI = "\ | |||
29 | file://Reuse-xxdi.pl.patch \ | 29 | file://Reuse-xxdi.pl.patch \ |
30 | file://Add-static-keyword-for-IsValidVariableHeader.patch \ | 30 | file://Add-static-keyword-for-IsValidVariableHeader.patch \ |
31 | file://Dynamically-load-openssl.cnf-for-openssl-1.0.x-and-1.patch \ | 31 | file://Dynamically-load-openssl.cnf-for-openssl-1.0.x-and-1.patch \ |
32 | file://0001-console.c-Fix-compilation-against-latest-usr-include.patch \ | ||
33 | " | 32 | " |
34 | SRCREV = "392836a46ce3c92b55dc88a1aebbcfdfc5dcddce" | 33 | SRCREV = "392836a46ce3c92b55dc88a1aebbcfdfc5dcddce" |
35 | 34 | ||
diff --git a/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch b/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch deleted file mode 100644 index fb7ac4b..0000000 --- a/meta-efi-secure-boot/recipes-bsp/efitools/efitools/0001-console.c-Fix-compilation-against-latest-usr-include.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From: Jason Wessel <jason.wessel@windriver.com> | ||
2 | Date: Mon, 4 Nov 2019 12:42:49 -0800 | ||
3 | Subject: [PATCH] console.c: Fix compilation against latest /usr/include/efi | ||
4 | MIME-Version: 1.0 | ||
5 | Content-Type: text/plain; charset=UTF-8 | ||
6 | Content-Transfer-Encoding: 8bit | ||
7 | |||
8 | | gcc -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/git/include/ -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/x86_64 -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/protocol -O2 -g -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector -ffreestanding -fno-stack-check -DGNU_EFI_USE_MS_ABI -DEFI_FUNCTION_WRAPPER -mno-red-zone -DCONFIG_x86_64 -fno-toplevel-reorder -DBUILD_EFI -c console.c -o console.efi.o | ||
9 | | console.c:360:5: error: ‘EFI_WARN_UNKOWN_GLYPH’ undeclared here (not in a function); did you mean ‘EFI_WARN_UNKNOWN_GLYPH’? | ||
10 | | { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~ | ||
12 | | EFI_WARN_UNKNOWN_GLYPH | ||
13 | | ../Make.rules:113: recipe for target 'console.efi.o' failed | ||
14 | | | ||
15 | |||
16 | |||
17 | Upstream-Status: Pending | ||
18 | |||
19 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | ||
20 | --- | ||
21 | lib/console.c | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/lib/console.c b/lib/console.c | ||
25 | index 9c10560..b932a44 100644 | ||
26 | --- a/lib/console.c | ||
27 | +++ b/lib/console.c | ||
28 | @@ -357,7 +357,7 @@ static struct { | ||
29 | { EFI_SECURITY_VIOLATION, L"Security Violation"}, | ||
30 | |||
31 | // warnings | ||
32 | - { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
33 | + { EFI_WARN_UNKNOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
34 | { EFI_WARN_DELETE_FAILURE, L"Warning Delete Failure"}, | ||
35 | { EFI_WARN_WRITE_FAILURE, L"Warning Write Failure"}, | ||
36 | { EFI_WARN_BUFFER_TOO_SMALL, L"Warning Buffer Too Small"}, | ||
37 | -- | ||
38 | 2.23.0 | ||
39 | |||
diff --git a/meta-efi-secure-boot/recipes-bsp/shim/shim/0001-console.c-Fix-compilation-against-latest-usr-include.patch b/meta-efi-secure-boot/recipes-bsp/shim/shim/0001-console.c-Fix-compilation-against-latest-usr-include.patch deleted file mode 100644 index fb7ac4b..0000000 --- a/meta-efi-secure-boot/recipes-bsp/shim/shim/0001-console.c-Fix-compilation-against-latest-usr-include.patch +++ /dev/null | |||
@@ -1,39 +0,0 @@ | |||
1 | From: Jason Wessel <jason.wessel@windriver.com> | ||
2 | Date: Mon, 4 Nov 2019 12:42:49 -0800 | ||
3 | Subject: [PATCH] console.c: Fix compilation against latest /usr/include/efi | ||
4 | MIME-Version: 1.0 | ||
5 | Content-Type: text/plain; charset=UTF-8 | ||
6 | Content-Transfer-Encoding: 8bit | ||
7 | |||
8 | | gcc -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/git/include/ -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/x86_64 -I/opt/tmp/work/x86_64-linux/efitools-native/1.9.2+gitAUTOINC+392836a46c-r0/recipe-sysroot-native/usr/include/efi/protocol -O2 -g -fpic -Wall -fshort-wchar -fno-strict-aliasing -fno-merge-constants -fno-stack-protector -ffreestanding -fno-stack-check -DGNU_EFI_USE_MS_ABI -DEFI_FUNCTION_WRAPPER -mno-red-zone -DCONFIG_x86_64 -fno-toplevel-reorder -DBUILD_EFI -c console.c -o console.efi.o | ||
9 | | console.c:360:5: error: ‘EFI_WARN_UNKOWN_GLYPH’ undeclared here (not in a function); did you mean ‘EFI_WARN_UNKNOWN_GLYPH’? | ||
10 | | { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
11 | | ^~~~~~~~~~~~~~~~~~~~~ | ||
12 | | EFI_WARN_UNKNOWN_GLYPH | ||
13 | | ../Make.rules:113: recipe for target 'console.efi.o' failed | ||
14 | | | ||
15 | |||
16 | |||
17 | Upstream-Status: Pending | ||
18 | |||
19 | Signed-off-by: Jason Wessel <jason.wessel@windriver.com> | ||
20 | --- | ||
21 | lib/console.c | 2 +- | ||
22 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
23 | |||
24 | diff --git a/lib/console.c b/lib/console.c | ||
25 | index 9c10560..b932a44 100644 | ||
26 | --- a/lib/console.c | ||
27 | +++ b/lib/console.c | ||
28 | @@ -357,7 +357,7 @@ static struct { | ||
29 | { EFI_SECURITY_VIOLATION, L"Security Violation"}, | ||
30 | |||
31 | // warnings | ||
32 | - { EFI_WARN_UNKOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
33 | + { EFI_WARN_UNKNOWN_GLYPH, L"Warning Unknown Glyph"}, | ||
34 | { EFI_WARN_DELETE_FAILURE, L"Warning Delete Failure"}, | ||
35 | { EFI_WARN_WRITE_FAILURE, L"Warning Write Failure"}, | ||
36 | { EFI_WARN_BUFFER_TOO_SMALL, L"Warning Buffer Too Small"}, | ||
37 | -- | ||
38 | 2.23.0 | ||
39 | |||
diff --git a/meta-efi-secure-boot/recipes-bsp/shim/shim_git.bb b/meta-efi-secure-boot/recipes-bsp/shim/shim_git.bb index 6ebe282..e0dcd8b 100644 --- a/meta-efi-secure-boot/recipes-bsp/shim/shim_git.bb +++ b/meta-efi-secure-boot/recipes-bsp/shim/shim_git.bb | |||
@@ -28,7 +28,6 @@ SRC_URI = "\ | |||
28 | file://0011-Update-verification_method-if-the-loaded-image-is-si.patch;apply=0 \ | 28 | file://0011-Update-verification_method-if-the-loaded-image-is-si.patch;apply=0 \ |
29 | file://0012-netboot-replace-the-depreciated-EFI_PXE_BASE_CODE.patch \ | 29 | file://0012-netboot-replace-the-depreciated-EFI_PXE_BASE_CODE.patch \ |
30 | file://0001-MokManager-Use-CompareMem-on-MokListNode.Type-instea.patch \ | 30 | file://0001-MokManager-Use-CompareMem-on-MokListNode.Type-instea.patch \ |
31 | file://0001-console.c-Fix-compilation-against-latest-usr-include.patch \ | ||
32 | " | 31 | " |
33 | SRC_URI_append_x86-64 = "\ | 32 | SRC_URI_append_x86-64 = "\ |
34 | ${@bb.utils.contains('DISTRO_FEATURES', 'msft', \ | 33 | ${@bb.utils.contains('DISTRO_FEATURES', 'msft', \ |