summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2021-01-18 16:48:21 +0800
committerJia Zhang <zhang.jia@linux.alibaba.com>2021-01-19 17:44:02 +0800
commitd05fc08f90ceb97375a2032a79fd992bf25353cf (patch)
tree8ebe6637938e884f4745921ca6e1d5f9ffeaa785
parent2d1fb96206acfd5b85084304af1760a4f598741a (diff)
downloadmeta-secure-core-d05fc08f90ceb97375a2032a79fd992bf25353cf.tar.gz
meta-efi-secure-boot/systemd: switch to meson build
The systemd switched to meson build long time ago. Somehow this bbappend didn't update. Switch to meson build otherwise these options do not work at all. Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
-rw-r--r--meta-efi-secure-boot/recipes-core/systemd/systemd-efi-secure-boot.inc5
-rw-r--r--meta-efi-secure-boot/recipes-core/systemd/systemd_%.bbappend10
2 files changed, 6 insertions, 9 deletions
diff --git a/meta-efi-secure-boot/recipes-core/systemd/systemd-efi-secure-boot.inc b/meta-efi-secure-boot/recipes-core/systemd/systemd-efi-secure-boot.inc
new file mode 100644
index 0000000..da6e27b
--- /dev/null
+++ b/meta-efi-secure-boot/recipes-core/systemd/systemd-efi-secure-boot.inc
@@ -0,0 +1,5 @@
1DEPENDS += "gnu-efi"
2PACKAGECONFIG_append = " efi"
3EXTRA_OEMESON += "-Dgnu-efi=true \
4 -Defi-libdir=${STAGING_LIBDIR} \
5 -Defi-includedir=${STAGING_INCDIR}"
diff --git a/meta-efi-secure-boot/recipes-core/systemd/systemd_%.bbappend b/meta-efi-secure-boot/recipes-core/systemd/systemd_%.bbappend
index 665a025..c9e58fd 100644
--- a/meta-efi-secure-boot/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-efi-secure-boot/recipes-core/systemd/systemd_%.bbappend
@@ -1,9 +1 @@
1DEPENDS += "\ require ${@bb.utils.contains('DISTRO_FEATURES', 'efi-secure-boot', 'systemd-efi-secure-boot.inc', '', d)}
2 ${@bb.utils.contains('MACHINE_FEATURES', 'efi', 'gnu-efi', '', d)} \
3"
4
5EXTRA_OECONF += "\
6 ${@bb.utils.contains('MACHINE_FEATURES', 'efi', \
7 '--enable-efi --enable-gnuefi --with-efi-libdir=${STAGING_LIBDIR} --with-efi-ldsdir=${STAGING_LIBDIR} --with-efi-includedir=${STAGING_INCDIR}', \
8 '', d)} \
9"