summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlias Apalodimas <ilias.apalodimas@linaro.org>2021-02-28 16:21:49 +0200
committerJia Zhang <zhang.jia@linux.alibaba.com>2021-03-03 10:56:13 +0800
commitfa5550d97de634fc3d0bfc42e36796ab0936c8a9 (patch)
tree83ffe44a4de977869747bde305561d2e4a333559
parent6009b4d960aea634d89b11f5cee47e860bfc5d1f (diff)
downloadmeta-secure-core-fa5550d97de634fc3d0bfc42e36796ab0936c8a9.tar.gz
sbsigntool: Update to latest and change repos
The current sbsigntool repo is ancient and doesn't support native arm binaries. Let's switch to the current upstream and adjust the recipe accordingly, allowing the package to be used in native arm machines Signed-off-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
-rw-r--r--meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb37
1 files changed, 7 insertions, 30 deletions
diff --git a/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb
index b5120f0..2c2e9d9 100644
--- a/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb
+++ b/meta-signing-key/recipes-devtools/sbsigntool/sbsigntool_git.bb
@@ -7,26 +7,19 @@ LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=a7710ac18adec371b84a9594ed04fd20 \ 7 file://COPYING;md5=a7710ac18adec371b84a9594ed04fd20 \
8" 8"
9 9
10DEPENDS += "binutils openssl gnu-efi util-linux" 10DEPENDS += "binutils openssl gnu-efi gnu-efi-native"
11DEPENDS += "help2man-native coreutils-native openssl-native util-linux-native"
11 12
12PV = "0.6+git${SRCPV}" 13PV = "0.8+git${SRCPV}"
13 14
14SRC_URI = "\ 15SRC_URI = "\
15 git://kernel.ubuntu.com/jk/sbsigntool \ 16 git://git.kernel.org/pub/scm/linux/kernel/git/jejb/sbsigntools.git;protocol=https;name=sbsigntool \
16 file://ccan.git.tar.bz2 \
17 file://fix-mixed-implicit-and-normal-rules.patch;apply=0 \
18 file://disable-man-page-creation.patch \
19 file://Fix-for-multi-sign.patch \
20 file://sbsign-add-x-option-to-avoid-overwrite-existing-sign.patch \
21 file://image-fix-the-segment-fault-caused-by-the-uninitiali.patch \
22 file://Fix-the-deprecated-ASN1_STRING_data-in-openssl-1.1.0.patch \
23 file://Update-OpenSSL-API-usage-to-support-OpenSSL-1.1.patch \
24" 17"
25SRCREV="951ee95a301674c046f55330cd7460e1314deff2" 18SRCREV="f12484869c9590682ac3253d583bf59b890bb826"
26 19
27S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
28 21
29inherit autotools-brokensep pkgconfig 22inherit native autotools-brokensep pkgconfig
30 23
31def efi_arch(d): 24def efi_arch(d):
32 import re 25 import re
@@ -50,23 +43,7 @@ EXTRA_OEMAKE += "\
50 43
51do_configure() { 44do_configure() {
52 cd "${S}" 45 cd "${S}"
53 rm -rf "lib/ccan.git" 46 ./autogen.sh
54 git clone "${WORKDIR}/ccan.git" lib/ccan.git
55 cd lib/ccan.git && \
56 git apply "${WORKDIR}/fix-mixed-implicit-and-normal-rules.patch" && \
57 cd -
58
59 OLD_CC="${CC}"
60
61 if [ ! -e lib/ccan ]; then
62 export CC="${BUILD_CC}"
63 TMPDIR=lib lib/ccan.git/tools/create-ccan-tree \
64 --build-type=automake lib/ccan \
65 talloc read_write_all build_assert array_size endian || exit 1
66 fi
67
68 export CC="${OLD_CC}"
69 ./autogen.sh --noconfigure
70 oe_runconf 47 oe_runconf
71} 48}
72 49