diff options
author | Yi Zhao <yi.zhao@eng.windriver.com> | 2025-03-27 21:23:25 +0800 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2025-04-13 14:07:57 -0400 |
commit | b7b2d12c4f0e037894f2c8a46d3a254b5dc1b032 (patch) | |
tree | 2c6a3d88439b69d7fa59c846917e7a35a98b7f23 | |
parent | 2c9feba8103662daa648c6b5a8ad0b8f4107ab03 (diff) | |
download | meta-security-b7b2d12c4f0e037894f2c8a46d3a254b5dc1b032.tar.gz |
libgssglue: add ptest
Ptest result:
ptest-runner libgssglue
START: ptest-runner
2025-03-27T13:15
BEGIN: /usr/lib64/libgssglue/ptest
PASS: gss_create_empty_oid_set
PASS: gss_test_oid_set_member
PASS: gss_test_oid_set_member n==0
PASS: gss_add_oid_set_member() OK
PASS: gss_test_oid_set_member() OK
OID present in set with the OID added to it => 1
PASS: gss_test_oid_set_member() OK
PASS: gss_test_oid_set_member() OK
Another OID present in set without the OID => 0
PASS: gss_test_oid_set_member() OK
PASS: gss_add_oid_set_member() OK
PASS: gss_test_oid_set_member() OK
Another OID present in set with it added => 1
PASS: gss_test_oid_set_member() OK
PASS: gss_test_oid_set_member() OK
First OID present in set => 1
PASS: gss_test_oid_set_member() OK
PASS: gss_release_oid_set() OK
PASS: gss_indicate_mechs() OK
PASS: gss_release_oid_set() OK
PASS: gss_import_name() OK
PASS: gss_display_name() OK
display_name() => 27: imap@server.example.org@FOO
PASS: gss_release_buffer() OK
PASS: gss_release_name() OK
Basic self tests done with 0 errors
DURATION: 0
END: /usr/lib64/libgssglue/ptest
2025-03-27T13:15
STOP: ptest-runner
TOTAL: 1 FAIL: 0
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | recipes-security/libgssglue/files/run-ptest | 4 | ||||
-rw-r--r-- | recipes-security/libgssglue/libgssglue_0.9.bb | 15 |
2 files changed, 17 insertions, 2 deletions
diff --git a/recipes-security/libgssglue/files/run-ptest b/recipes-security/libgssglue/files/run-ptest new file mode 100644 index 0000000..04d492c --- /dev/null +++ b/recipes-security/libgssglue/files/run-ptest | |||
@@ -0,0 +1,4 @@ | |||
1 | #! /bin/sh | ||
2 | |||
3 | current_dir=$(dirname $(readlink -f $0)) | ||
4 | $current_dir/generic | ||
diff --git a/recipes-security/libgssglue/libgssglue_0.9.bb b/recipes-security/libgssglue/libgssglue_0.9.bb index 7e24450..73e6dec 100644 --- a/recipes-security/libgssglue/libgssglue_0.9.bb +++ b/recipes-security/libgssglue/libgssglue_0.9.bb | |||
@@ -21,12 +21,14 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=56871e72a5c475289c0d5e4ba3f2ee3a \ | |||
21 | file://src/oid_ops.c;beginline=378;endline=398;md5=72457a5cdc0354cb5c25c8b150326364\ | 21 | file://src/oid_ops.c;beginline=378;endline=398;md5=72457a5cdc0354cb5c25c8b150326364\ |
22 | " | 22 | " |
23 | 23 | ||
24 | SRC_URI = "git://gitlab.com/gsasl/libgssglue.git;protocol=https;branch=master" | 24 | SRC_URI = "git://gitlab.com/gsasl/libgssglue.git;protocol=https;branch=master \ |
25 | file://run-ptest \ | ||
26 | " | ||
25 | SRCREV = "ada76bdaec665f70505f0b3aefe871b873e7c4b6" | 27 | SRCREV = "ada76bdaec665f70505f0b3aefe871b873e7c4b6" |
26 | 28 | ||
27 | S = "${WORKDIR}/git" | 29 | S = "${WORKDIR}/git" |
28 | 30 | ||
29 | inherit autotools-brokensep | 31 | inherit autotools-brokensep ptest |
30 | 32 | ||
31 | do_configure:prepend() { | 33 | do_configure:prepend() { |
32 | cd ${S} | 34 | cd ${S} |
@@ -46,5 +48,14 @@ do_install:append() { | |||
46 | sed -i -e "s:/usr/lib/libgssapi_krb5.so:libgssapi_krb5.so.2:" ${D}${sysconfdir}/gssapi_mech.conf | 48 | sed -i -e "s:/usr/lib/libgssapi_krb5.so:libgssapi_krb5.so.2:" ${D}${sysconfdir}/gssapi_mech.conf |
47 | } | 49 | } |
48 | 50 | ||
51 | do_compile_ptest() { | ||
52 | echo 'buildtest-TESTS: $(check_PROGRAMS)' >> ${S}/tests/Makefile | ||
53 | oe_runmake -C ${S}/tests buildtest-TESTS | ||
54 | } | ||
55 | |||
56 | do_install_ptest() { | ||
57 | install -m 755 ${S}/tests/generic ${D}/${PTEST_PATH} | ||
58 | } | ||
59 | |||
49 | # gssglue can use krb5, spkm3... as gssapi library, configurable | 60 | # gssglue can use krb5, spkm3... as gssapi library, configurable |
50 | RRECOMMENDS:${PN} += "krb5" | 61 | RRECOMMENDS:${PN} += "krb5" |